Latest News:
2018-11-29: XigmaNAS 11.2.0.4.6229 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

No longer boots with 2 data drives

Everything Hardware related to build that XigmaNAS system!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
kenZ71
Advanced User
Advanced User
Posts: 400
Joined: 27 Jun 2012 20:18
Location: Northeast, USA
Status: Offline

No longer boots with 2 data drives

#1

Post by kenZ71 » 31 Oct 2018 01:46

Odd issue - my backup box - SuperMicro X7SBE no longer boots if both ZFS disks are connected.

It boots fine with no data drives or either of two data drives but not both.

Any ideas what the cause might be?

I already tried to move the drives around, reseating the cables - it boots with either connected to either data cable but not when both connected.

ZFS / BSD dont like it when drives are hot swapped, right? So I don't think I should try that. Or maybe I will. It's only my backup box.
11.2-RELEASE-p3 | ZFS Mirror - 2 x 8TB WD Red | 28GB ECC Ram
HP ML10v2 x64-embedded on Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz

Extra memory so I can host a couple VMs
1) Unifi Controller on Ubuntu
2) Librenms on Ubuntu

kenZ71
Advanced User
Advanced User
Posts: 400
Joined: 27 Jun 2012 20:18
Location: Northeast, USA
Status: Offline

Re: No longer boots with 2 data drives

#2

Post by kenZ71 » 10 Nov 2018 14:57

If anyone is curious or finds this via search with similar issues here is my hack solution:

Boot the box with one data drive, once at the main menu connect more data drives & run my rsync scripts to backup.

Done this a couple times, hot swapping seems to be ok.
11.2-RELEASE-p3 | ZFS Mirror - 2 x 8TB WD Red | 28GB ECC Ram
HP ML10v2 x64-embedded on Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz

Extra memory so I can host a couple VMs
1) Unifi Controller on Ubuntu
2) Librenms on Ubuntu

Post Reply

Return to “Server Build, Tips, Help and Suggestions”