*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Install and run on UEFI only system

New installs of XigmaNAS.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
wingenieur
Starter
Starter
Posts: 35
Joined: 25 Jan 2014 00:57
Location: Germany
Status: Offline

Install and run on UEFI only system

#1

Post by wingenieur » 21 Oct 2017 01:39

Hello,

the new Supermicro Atom C3000-Series mainboards do not support BIOS emulation or CSM anymore.
I've purchased the brandnew "A2SDi-2C-HLN4F" to build a new NAS-box, but now it won't boot the live-usb-key nor the live-cd.

So I've tried to install Nas4free on another computer (GPT installation) and added an efi-partition like described here:
http://www.wonkity.com/~wblock/docs/htm ... _with_uefi

But back in the supermicro board the new partition is recognized, but also won't boot anything.

I know that it can boot, because a memtest86 key prepared by rufus on windows will boot.

So please: Is there anyone, who runs on UEFI only? How to get it work?

Thanks in advance!
NAS4free 11.1.0.4.5579 x64-embedded
addons (jailed): Serviio 1.9 Pro, Owncloud 10.0.8
hardware:
mainboard: Intel S1200V3RPL
processor: Intel Xeon E3-1241 v3
ram: 4x Kingston KVR16E11/8I
extra storage controller: LSI SAS 9207-8i
extra network controller: Intel X540-T2 10GBase-T (x2)

storage:
boot, system, swap (geli encrypted), data: Plextor PX-AG256M6e
raidz2_1 (@C226, all geli encrypted): 6x Seagate ST8000VN0022
raidz2_2 + slog-mirror (@LSI, all geli encrypted): 6x Seagate ST3000VN000 + 2x Samsung MZ-7KE128 (16GB on each)

wingenieur
Starter
Starter
Posts: 35
Joined: 25 Jan 2014 00:57
Location: Germany
Status: Offline

Re: Install and run on UEFI only system

#2

Post by wingenieur » 21 Oct 2017 19:38

Hi,

I've managed to run NAS4free in "full"-version finally.
With embedded, I couldn't get the memory disk for the rootfs to work.

For interested people, here the steps in short:

1.) install a full NAS4free install (GPT) to a usb-key (1) other than the one you want to use on any pc with legacy capabilities
2.) download the freebsd 11.1 release memstick and get it on the usb-key you want to use (2) with rufus in windows
3.) put both usb-keys in any pc running freebsd or nas4free (also live is possible)
4.) mount the third partition on usb-key (2) and backup boot/loader.efi
5.) remove all partitions from usb-key (2) but the first two (efi, freebsd-boot) using gpart
6.) add another ufs partition on usb-key (2) using gpart and format it using newfs
7.) mount this new partition and mount the second partition from usb-key (1) to another location
8.) copy over all the files from mounted partition on key (1) to mounted partition on key (2) using "cp -R -p"
9.) add the backuped loader.efi to boot/ on the mounted partition of usb-key (2)
10.) change the kern.vty entry in boot/loader.conf to "vt" on the mounted partition of usb-key (2)
11.) change the rootfs entry in etc/fstab for your later needs (e.g. /dev/da0p3) on the mounted partition of usb-key (2)
12.) use usb-key (2) to boot up the UEFI only machine and go on with the standard configuration steps. Don't forget to add a swap later on!

In case of the mentioned mainboard, this is not everything to do.
The Denverton-NICs are not yet recognized (Intel X553 as GBit only) in NAS4free.
As I've read elsewhere, they should be supported in 11.1-stable already.

So with this board - wait for a 11.2-based NAS4free. ;-)
Best regards!
NAS4free 11.1.0.4.5579 x64-embedded
addons (jailed): Serviio 1.9 Pro, Owncloud 10.0.8
hardware:
mainboard: Intel S1200V3RPL
processor: Intel Xeon E3-1241 v3
ram: 4x Kingston KVR16E11/8I
extra storage controller: LSI SAS 9207-8i
extra network controller: Intel X540-T2 10GBase-T (x2)

storage:
boot, system, swap (geli encrypted), data: Plextor PX-AG256M6e
raidz2_1 (@C226, all geli encrypted): 6x Seagate ST8000VN0022
raidz2_2 + slog-mirror (@LSI, all geli encrypted): 6x Seagate ST3000VN000 + 2x Samsung MZ-7KE128 (16GB on each)

vkopzon
NewUser
NewUser
Posts: 5
Joined: 04 Dec 2016 10:24
Status: Offline

Re: Install and run on UEFI only system

#3

Post by vkopzon » 06 Nov 2017 13:48

Hi wingenieur,

Thanks for great guide! I have similar issue on new machine (also BIOS has CSM option) with American Megatrend BIOS.
Nothing helped, but your solution!!!

The only drawback is non-embeded install which will require same steps for update.
I hope nas4free devs will look into the issue and made install to work (similar to freebsd)

Thanks again!!!

ashkhosla
NewUser
NewUser
Posts: 2
Joined: 20 Dec 2017 21:56
Status: Offline

Re: Install and run on UEFI only system

#4

Post by ashkhosla » 20 Dec 2017 22:00

Hi Wingenieur,

just got a new Supermicro A2SDi-4C-HLN4F. I thought it was the perfect MB for Nas4Free. Was I ever wrong.
Have the same problem as you. Trying your solution now.

Thanks !

ashkhosla
NewUser
NewUser
Posts: 2
Joined: 20 Dec 2017 21:56
Status: Offline

Re: Install and run on UEFI only system

#5

Post by ashkhosla » 21 Dec 2017 00:16

Hi Wingenieur,

I followed your well written instructions, and now have it booting.
But as you pointed out, the network interfaces aren't recognised. I'm running the latest stable build 11.1.0.4
Did you manage to get this working ?

Any help greatly appreciated !!

wingenieur
Starter
Starter
Posts: 35
Joined: 25 Jan 2014 00:57
Location: Germany
Status: Offline

Re: Install and run on UEFI only system

#6

Post by wingenieur » 04 Mar 2018 14:47

Hi ashkhosla,

sorry to say, that I'm not able to make the NICs working.
It is up to the maintainers of NAS4free to do so, because the "ixgbe" driver is part of the kernel.

The 11.1-release-path (from which NAS4free is derived) includes 3.1.13-k version of the driver.
But our NICs are supported as of 3.2.12-k version, which is only part of the 11-stable-path at the moment:
https://svnweb.freebsd.org/base/stable/ ... dev/ixgbe/

The new driver will most likely be available to the next FreeBSD-release, whis is 11.2.
So we'll have to wait until June/July, when the NAS4free maintainers will derive their builds from 11.2-release.

Edit:
If you don't need any more than 6 SATA ports, you can plug in any GBit NIC in x4-slot@x2.
Then you can at least use the board within the waiting time. ;)

Best regards!
NAS4free 11.1.0.4.5579 x64-embedded
addons (jailed): Serviio 1.9 Pro, Owncloud 10.0.8
hardware:
mainboard: Intel S1200V3RPL
processor: Intel Xeon E3-1241 v3
ram: 4x Kingston KVR16E11/8I
extra storage controller: LSI SAS 9207-8i
extra network controller: Intel X540-T2 10GBase-T (x2)

storage:
boot, system, swap (geli encrypted), data: Plextor PX-AG256M6e
raidz2_1 (@C226, all geli encrypted): 6x Seagate ST8000VN0022
raidz2_2 + slog-mirror (@LSI, all geli encrypted): 6x Seagate ST3000VN000 + 2x Samsung MZ-7KE128 (16GB on each)

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: Install and run on UEFI only system

#7

Post by jasch » 23 Mar 2018 20:27

I would also like to bring this up.

I also need full efi boot, because in ESXI with Bios boot there are restriction in pcie passthrough, wich tends to freze the whole system with LSi controllers and high throughput.
with efi there are options tho rise PCIe BAR memory......

@Developers

is there any Plan to bring full efi boot to N4F ?
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

poroshok
NewUser
NewUser
Posts: 3
Joined: 04 Apr 2018 21:49
Status: Offline

Re: Install and run on UEFI only system

#8

Post by poroshok » 04 Apr 2018 22:24

I've managed to run N4F on that board with working NICs: https://nas4free.org/forums/viewtopic.php?t=13606

wingenieur
Starter
Starter
Posts: 35
Joined: 25 Jan 2014 00:57
Location: Germany
Status: Offline

Re: Install and run on UEFI only system

#9

Post by wingenieur » 29 Jun 2018 20:33

Hi,

every pain to this should have an end with the latest release (5673).
I'm going to check that out soon.
Thanks, devs! :)
NAS4free 11.1.0.4.5579 x64-embedded
addons (jailed): Serviio 1.9 Pro, Owncloud 10.0.8
hardware:
mainboard: Intel S1200V3RPL
processor: Intel Xeon E3-1241 v3
ram: 4x Kingston KVR16E11/8I
extra storage controller: LSI SAS 9207-8i
extra network controller: Intel X540-T2 10GBase-T (x2)

storage:
boot, system, swap (geli encrypted), data: Plextor PX-AG256M6e
raidz2_1 (@C226, all geli encrypted): 6x Seagate ST8000VN0022
raidz2_2 + slog-mirror (@LSI, all geli encrypted): 6x Seagate ST3000VN000 + 2x Samsung MZ-7KE128 (16GB on each)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#10

Post by JoseMR » 30 Jun 2018 14:46

wingenieur wrote:
29 Jun 2018 20:33
Hi,

every pain to this should have an end with the latest release (5673).
I'm going to check that out soon.
Thanks, devs! :)

Hello, NAS4Free UEFI initial installations has to be performed under Legacy BIOS mode first or through an alternate hardware/VM if Legacy BIOS mode is not an option, this is valid for all platforms, i.e Embedded, Full(Legacy) and Full RootOnZFS.

This limitation is because LiveMedia still does not support UEFI boot capability, however is already on TODO list.

Any feedback/suggestions are welcome.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

ivannn
NewUser
NewUser
Posts: 11
Joined: 20 Dec 2015 22:50
Status: Offline

Re: Install and run on UEFI only system

#11

Post by ivannn » 12 Jul 2018 08:37

Both CDROM and embedded images boot fine well using BIOS legacy mode on this board - tested with the last few 11.1 releases, the betas and the current 11.2

wingenieur
Starter
Starter
Posts: 35
Joined: 25 Jan 2014 00:57
Location: Germany
Status: Offline

Re: Install and run on UEFI only system

#12

Post by wingenieur » 17 Jul 2018 00:31

HI,

you're right, as of BIOS 1.0b they've added a CSM module (activate it in the security section), so the board is no longer UEFI only.
That means you can boot (and thus install XigmaNAS) from legacy devices now.
I've checked that with the ISO of 5748, and now onboard LAN is also working, so all problems gone. :-)
NAS4free 11.1.0.4.5579 x64-embedded
addons (jailed): Serviio 1.9 Pro, Owncloud 10.0.8
hardware:
mainboard: Intel S1200V3RPL
processor: Intel Xeon E3-1241 v3
ram: 4x Kingston KVR16E11/8I
extra storage controller: LSI SAS 9207-8i
extra network controller: Intel X540-T2 10GBase-T (x2)

storage:
boot, system, swap (geli encrypted), data: Plextor PX-AG256M6e
raidz2_1 (@C226, all geli encrypted): 6x Seagate ST8000VN0022
raidz2_2 + slog-mirror (@LSI, all geli encrypted): 6x Seagate ST3000VN000 + 2x Samsung MZ-7KE128 (16GB on each)

Vebster
NewUser
NewUser
Posts: 10
Joined: 09 Dec 2017 15:20
Status: Offline

Re: Install and run on UEFI only system

#13

Post by Vebster » 31 Jul 2018 22:47

Hi wingenieur.
I'm trying to install XigmaNas (5774) on Hyper-V server 2016 as a gen 2 virtual machine. Unfortunately, when I try to boot from full.iso, I get a message saying "No UEFI-compatible file system was found".
However, the installation distribution of FreeBSD 11.2 is loaded normally.
Are there any solutions for the XigmaNas distribution?
Thank you.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#14

Post by JoseMR » 08 Aug 2018 05:30

Vebster wrote:
31 Jul 2018 22:47
Hi wingenieur.
I'm trying to install XigmaNas (5774) on Hyper-V server 2016 as a gen 2 virtual machine. Unfortunately, when I try to boot from full.iso, I get a message saying "No UEFI-compatible file system was found".
However, the installation distribution of FreeBSD 11.2 is loaded normally.
Are there any solutions for the XigmaNas distribution?
Thank you.

Hi, XigmaNAS *LiveMedia still does not support EFI boot, please refer to Post #10 for possible solution until the feature is avail.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

SKYNET74
NewUser
NewUser
Posts: 9
Joined: 01 Oct 2018 20:56
Status: Offline

Re: Install and run on UEFI only system

#15

Post by SKYNET74 » 01 Oct 2018 21:12

Hello, the embedded version is still not possible to use on motherboards that can only EFI boot?

There is ASRock J4105B-ITX which is very well suited for NAS, but it can only work with Windows 10, even EFI from Windows 7 does not work on it, it just does not display such devices for download.
v11.2.0.4.6026 still does not support it, is there any solution to this problem?

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#16

Post by JoseMR » 03 Oct 2018 22:18

SKYNET74 wrote:
01 Oct 2018 21:12
Hello, the embedded version is still not possible to use on motherboards that can only EFI boot?

There is ASRock J4105B-ITX which is very well suited for NAS, but it can only work with Windows 10, even EFI from Windows 7 does not work on it, it just does not display such devices for download.
v11.2.0.4.6026 still does not support it, is there any solution to this problem?

Hi, EFI has been added to Embedded and LiveCD recently

However FreeBSD UEFI is a work in progress and not every motherboard will boot, either legacy mobos with buggy firmware or mobos with latest UEFI features such as Secure Boot, so make sure to at least disable Secure Boot before try.

This may change with FreeBSD 12 series between.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

SKYNET74
NewUser
NewUser
Posts: 9
Joined: 01 Oct 2018 20:56
Status: Offline

Re: Install and run on UEFI only system

#17

Post by SKYNET74 » 04 Oct 2018 20:39

JoseMR wrote:
03 Oct 2018 22:18
Hi, EFI has been added to Embedded and LiveCD recently

However FreeBSD UEFI is a work in progress and not every motherboard will boot, either legacy mobos with buggy firmware or mobos with latest UEFI features such as Secure Boot, so make sure to at least disable Secure Boot before try.

This may change with FreeBSD 12 series between.

Regards
Secure Boot is turned off, on Intel 3xx and AMD 3xx chipsets, as I understand it, XigmaNAS doesn't work either? There, too, only UEFI.

Solution to the problem, except how to wait for the introduction of support for new hardware is not? In terms, it is also not clear when it will be, maybe in a year, maybe in three.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#18

Post by JoseMR » 05 Oct 2018 12:34

SKYNET74 wrote:
04 Oct 2018 20:39
Secure Boot is turned off, on Intel 3xx and AMD 3xx chipsets, as I understand it, XigmaNAS doesn't work either? There, too, only UEFI.

Solution to the problem, except how to wait for the introduction of support for new hardware is not? In terms, it is also not clear when it will be, maybe in a year, maybe in three.

I don't know if you already tried or just asking if someone already tried XigmaNAS/FreeBSD UEFI on that motherboard you've specified :?: .

However, I can tell you that I've personally tested the current XigmaNAS UEFI implementation on HP Compaq Pro 6300, Asus X53E and VirtualBox 5.x with good results, also the main Dev's reported UEFI working on they SuperMicro X10SL7-F and ESXi 6.x, however I don't have more spare hardware with UEFI capability for testing unfortunately, so is the user responsibly to search for this compatibility/information before buying hardware.

P.S. XigmaNAS LiveCD, Embedded, Full UFS and Full RootOnZFS are the current Platforms supporting UEFI as of this writing.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

SKYNET74
NewUser
NewUser
Posts: 9
Joined: 01 Oct 2018 20:56
Status: Offline

Re: Install and run on UEFI only system

#19

Post by SKYNET74 » 10 Oct 2018 21:19

JoseMR wrote:
05 Oct 2018 12:34
I don't know if you already tried or just asking if someone already tried XigmaNAS/FreeBSD UEFI on that motherboard you've specified :?: .

However, I can tell you that I've personally tested the current XigmaNAS UEFI implementation on HP Compaq Pro 6300, Asus X53E and VirtualBox 5.x with good results, also the main Dev's reported UEFI working on they SuperMicro X10SL7-F and ESXi 6.x, however I don't have more spare hardware with UEFI capability for testing unfortunately, so is the user responsibly to search for this compatibility/information before buying hardware.

P.S. XigmaNAS LiveCD, Embedded, Full UFS and Full RootOnZFS are the current Platforms supporting UEFI as of this writing.

Regards
I tried LiveCD, Embedded, Full UFS, none.

Can I somehow help the implementation of the UEFI under my fee? Since this is the newest board on the Intel SoC.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#20

Post by JoseMR » 11 Oct 2018 14:14

SKYNET74 wrote:
10 Oct 2018 21:19
I tried LiveCD, Embedded, Full UFS, none.

Can I somehow help the implementation of the UEFI under my fee? Since this is the newest board on the Intel SoC.

Sure you can help improve XigmaNAS, can you please explain in detail the procedure of your installation, e.g. wen booting LiveCD is on EFI or legacy BIOS?, is this from standard hardware and physical CD or IPMI/BMC from an ISO?, did you installed Embedded OS/EFI options?, have you tried XigmaNAS RootOnZFS and/or a FreeBSD ISO with success?.

If none works including a native copy of FreeBSD, then capture or write down the event where it hangs, the errors etc, it may help also registering in the FreeBSD forums/mailing list and report about this newest hardware issues.

P.S. I don't own that motherboard so I have to read the manual to familiarize with the avail EFI options, but sure someone can bring some light with a similar one booting/running XigmaNAS/FreeBSD on UEFI.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

SKYNET74
NewUser
NewUser
Posts: 9
Joined: 01 Oct 2018 20:56
Status: Offline

Re: Install and run on UEFI only system

#21

Post by SKYNET74 » 13 Oct 2018 16:32

JoseMR wrote:
11 Oct 2018 14:14
Sure you can help improve XigmaNAS, can you please explain in detail the procedure of your installation, e.g. wen booting LiveCD is on EFI or legacy BIOS?, is this from standard hardware and physical CD or IPMI/BMC from an ISO?, did you installed Embedded OS/EFI options?, have you tried XigmaNAS RootOnZFS and/or a FreeBSD ISO with success?.

If none works including a native copy of FreeBSD, then capture or write down the event where it hangs, the errors etc, it may help also registering in the FreeBSD forums/mailing list and report about this newest hardware issues.

P.S. I don't own that motherboard so I have to read the manual to familiarize with the avail EFI options, but sure someone can bring some light with a similar one booting/running XigmaNAS/FreeBSD on UEFI.

Regards
I installed Embedded OS / EFI on USB Flesh, and I need it for my needs.
FreeBSD is installed and started.
Debian also installs and works (according to feedback from users of the board).

If you download the motherboard's BIOS, maybe it will give you more information about the problem?

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#22

Post by JoseMR » 13 Oct 2018 17:52

SKYNET74 wrote:
13 Oct 2018 16:32
I installed Embedded OS / EFI on USB Flesh, and I need it for my needs.
FreeBSD is installed and started.
Debian also installs and works (according to feedback from users of the board).

If you download the motherboard's BIOS, maybe it will give you more information about the problem?

Hi, thanks for the info, HERE is a test LiveUSB for GPT BIOS+UEFI you can try.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

SKYNET74
NewUser
NewUser
Posts: 9
Joined: 01 Oct 2018 20:56
Status: Offline

Re: Install and run on UEFI only system

#23

Post by SKYNET74 » 14 Oct 2018 19:07

JoseMR wrote:
13 Oct 2018 17:52
Hi, thanks for the info, HERE is a test LiveUSB for GPT BIOS+UEFI you can try.

Regards
The directory is empty, please check the availability of files.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#24

Post by JoseMR » 16 Oct 2018 11:48

SKYNET74 wrote:
14 Oct 2018 19:07
JoseMR wrote:
13 Oct 2018 17:52
Hi, thanks for the info, HERE is a test LiveUSB for GPT BIOS+UEFI you can try.

Regards
The directory is empty, please check the availability of files.

Hello LiveUSB-GPT has been officially added as for Revision 6121
The latest and working LiveUSB-GPT with BIOS+UEFI Boot Support Here
Mirror: LiveUSB-GPT with BIOS+UEFI Boot Support at zoon's repo

P.S. Sorry for the delay, since weekend, feedback is very welcome.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

SKYNET74
NewUser
NewUser
Posts: 9
Joined: 01 Oct 2018 20:56
Status: Offline

Re: Install and run on UEFI only system

#25

Post by SKYNET74 » 17 Oct 2018 21:46

JoseMR wrote:
16 Oct 2018 11:48
Hello LiveUSB-GPT has been officially added as for Revision 6121
The latest and working LiveUSB-GPT with BIOS+UEFI Boot Support Here
Mirror: LiveUSB-GPT with BIOS+UEFI Boot Support at zoon's repo

P.S. Sorry for the delay, since weekend, feedback is very welcome.

Regards
XigmaNAS-x64-embedded-11.2.0.4.6120.img - not detectable and not loaded
XigmaNAS-x64-embedded-11.2.0.4.6128.img - not detectable and not loaded
XigmaNAS-x64-LiveUSB-GPT-11.2.0.4.6120.img - detected and loaded
XigmaNAS-x64-LiveUSB-GPT-11.2.0.4.6123.img - detected and loaded

It is necessary to finish embedded since This is a very popular platform.

PS1: MariaDB is not possible to enable via WebGUI.
PS2: In which topic can I suggest a new plugin for XigmaNAS?

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1223
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Online

Re: Install and run on UEFI only system

#26

Post by JoseMR » 17 Oct 2018 22:32

SKYNET74 wrote:
17 Oct 2018 21:46
JoseMR wrote:
16 Oct 2018 11:48
Hello LiveUSB-GPT has been officially added as for Revision 6121
The latest and working LiveUSB-GPT with BIOS+UEFI Boot Support Here
Mirror: LiveUSB-GPT with BIOS+UEFI Boot Support at zoon's repo

P.S. Sorry for the delay, since weekend, feedback is very welcome.

Regards
XigmaNAS-x64-embedded-11.2.0.4.6120.img - not detectable and not loaded
XigmaNAS-x64-embedded-11.2.0.4.6128.img - not detectable and not loaded
XigmaNAS-x64-LiveUSB-GPT-11.2.0.4.6120.img - detected and loaded
XigmaNAS-x64-LiveUSB-GPT-11.2.0.4.6123.img - detected and loaded

It is necessary to finish embedded since This is a very popular platform.

PS1: MariaDB is not possible to enable via WebGUI.
PS2: In which topic can I suggest a new plugin for XigmaNAS?

Hi, thank you for confirming LiveUSB-GPT did loaded in your EFI system, after installer load, you have to install as option OS/EFI for your hardware, though I will try to work on making standard Ebedded and Full(legacy) to feature dual boot support(BIOS+UEFI) like RootOnZFS Platform before release to cover both scenarios.

As for MariaDB I don't use it here so pretty sure someone will yield into this.
As for request new features, look at the "Feature Request" forum section, but remember large yet secure packages have to be debated before addition.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
JoseMRPubServ(temporary down)

Post Reply

Return to “Install XigmaNAS”