*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Live USB Boot Successful - Failed to detect any CDROM / USB device.

New installs of XigmaNAS.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
bslezak
NewUser
NewUser
Posts: 2
Joined: 28 Jun 2019 00:40
Status: Offline

Live USB Boot Successful - Failed to detect any CDROM / USB device.

#1

Post by bslezak » 28 Jun 2019 02:27

I am building a box to replace my existing NAS4Free 11.1.x system (that has been running great for years)!

The short of it
  • Gigabyte H370 HD3 motherboard, 8 GB RAM, Core i3 Gen 8
  • "Other OS" (Not WIndows 8/10) selected at BIOS
  • Using Linux and dd command to create live usb on Sandisk Ultra Flair 16 GB
  • Second Sandisk 16 GB available in usb slot and recognized during XigmaNAS startup
  • 3 different SATA devices on two different controllers (onboard and adapter), all recognized during XigmaNAS startup
  • Boots fine, press 9 at the menu - every install option available results in "Failed to detect any CDROM / USB device."
  1. I've tried every combination of enabling / disabling CSM in the bios, and changing UEFI / Legacy support.
  2. I've tried different methods of creating the Live USB (mkusb, manually creating partitions, etc)
It feels like I'm missing something simple, but this usually just works! All my Googling turns up hits for booting issues, and the only good news is I have no problem with that. I just can't get the installer to see any device in the system, despite the fact that it shows them during startup and I can drop to a command prompt and list them in /dev/ - and there they are. Any help appreciated.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4918
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Live USB Boot Successful - Failed to detect any CDROM / USB device.

#2

Post by raulfg3 » 28 Jun 2019 08:50

post screen capture of your BIOs that show how you have configured SATA & USB

SATAmust be AHCI
USB must be ( NO LEGACY)

and remember that:

for embeded install, you can do the install on other machine and move the boot USB to your NAS to boot from it

PD: To install Xigmanas I use XigmaNAS-x64-LiveUSB-GPT-12.0.0.4.6766.img.gz and Rufus
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

bslezak
NewUser
NewUser
Posts: 2
Joined: 28 Jun 2019 00:40
Status: Offline

Re: Live USB Boot Successful - Failed to detect any CDROM / USB device.

#3

Post by bslezak » 29 Jun 2019 19:33

Well thank you. It ends up I needed to pay attention more. I had inadvertently downloaded the LiveCD image on my Linux box, not the LiveUSB-GPT image. *BONK*

The LiveCD boots and runs just fine if you write it to a USB but -- surprise, it doesn't work as expected. The error message was legit; it was neither a CDROM or a USB I suppose.

Post Reply

Return to “Install XigmaNAS”