Latest News:
2018-11-29: XigmaNAS 11.2.0.4.6229 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

Corrupt LiveUSB drive

For "upgrading" from FreeNAS/NAS4Free Legacy to XigmaNAS and upgrading XigmaNAS to newer builds.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
KTL
NewUser
NewUser
Posts: 6
Joined: 02 Dec 2018 01:27
Status: Offline

Corrupt LiveUSB drive

#1

Post by KTL » 02 Dec 2018 02:17

Original version: NAS4Free 11.0.0.4.3330
New version: XigmaNAS 11.0.2.4.6229

I was trying to replace my mirrored (RAID1) 2TB with a 10TB drive in the old version by following some old instructions, but I managed to corrupt the bootloader on the LiveUSB drive. So I downloaded the latest XigmaNAS version and burned it to the USB drive, and booted up to the WebGUI. I've imported the 2x2TB in ZFS storage pool along with the USB drive, and I tried to set it up as it used to be: a vdev_1/mirror and a pool_1, but it doesn't seem to be working.

Log indicated this: "root: invalid vdev specification use '-f' to override the following errors: /dev/ada0 is part of potentially active pool 'pool_1' /dev/ada1 is part of potentially active pool 'pool_1'".

Likewise, I'm trying to restore the datasets that I had set up before so I can access the files. I didn't reformat the hard drives, so I'm hoping the files are still in there, but need to access them again either through Explorer or WinSCP.

Please offer some advice. Thanks.
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4627
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Corrupt LiveUSB drive

#2

Post by raulfg3 » 02 Dec 2018 10:55

try to force import

in Disks > ZFS > Pools > Tools > Step 1
select List or import pools

then next

select force import & Search for and import all disks found

you also decide if want to use GPT labels or GPT ID.

netxt.

etc..

if all works, you need to sync webGUI and Real in: Disks > ZFS > Configuration > Synchronize
XigmaNAS 11.2.0.4 - Omnius (revision 6195)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes
Old Wiki

KTL
NewUser
NewUser
Posts: 6
Joined: 02 Dec 2018 01:27
Status: Offline

Re: Corrupt LiveUSB drive

#3

Post by KTL » 02 Dec 2018 14:51

Thanks. I had tried a force import, but there seems to be some config issues, probably due to the old-vs-new version. There is a suggestion to use the "zpool upgrade" command, would I need to append the "-a" to "zpool upgrade -a"? I read once issued, the pool won't be readable by the old ZFS version.
You do not have the required permissions to view the files attached to this post.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 860
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: Corrupt LiveUSB drive

#4

Post by JoseMR » 02 Dec 2018 14:59

KTL wrote:
02 Dec 2018 14:51
Thanks. I had tried a force import, but there seems to be some config issues, probably due to the old-vs-new version. There is a suggestion to use the "zpool upgrade" command, would I need to append the "-a" to "zpool upgrade -a"? I read once issued, the pool won't be readable by the old ZFS version.

Do not upgrade the zpool unless you definitely want to stick to the latest XigmaNAS version, otherwise the pool will not be importable on previous versions.

As to force pool import, execute "zpool import -f pool_1", or just "zpool import -f -a"

Regards
System: FreeBSD 12.0, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
Testing: XigmaNAS RootOnZFS v2(Unofficial/Alpha), VirtualBox, 2 x CPU Cores, 4GB vRAM. (Devel).
VMs: XigmaNAS Embedded and Full Latest, VirtualBox, 2 x CPU Cores, 4GB vRAM. (Devel).
Addons Devel GitHub
JoseMRPubServ Resources

KTL
NewUser
NewUser
Posts: 6
Joined: 02 Dec 2018 01:27
Status: Offline

Re: Corrupt LiveUSB drive

#5

Post by KTL » 02 Dec 2018 16:30

Thanks to both you, @raulfg3 and @JoseMR, I was able to go through the GUI with the "zpool import -f -a" feature, and the pool is finally recognized. :D I enabled FTP and was able to use WinSCP to see and transfer those files. Whew!

I'm going to backup those files to external drive(s) and likely start over with the new 10TB drives as the replacement under the new version.
You do not have the required permissions to view the files attached to this post.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 860
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: Corrupt LiveUSB drive

#6

Post by JoseMR » 02 Dec 2018 18:38

KTL wrote:
02 Dec 2018 16:30
I'm going to backup those files to external drive(s) and likely start over with the new 10TB drives as the replacement under the new version.
+1

After backup double check the files are there and perfectly accessible from the external storage device before starting with the new disks setup.

Regards
System: FreeBSD 12.0, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
Testing: XigmaNAS RootOnZFS v2(Unofficial/Alpha), VirtualBox, 2 x CPU Cores, 4GB vRAM. (Devel).
VMs: XigmaNAS Embedded and Full Latest, VirtualBox, 2 x CPU Cores, 4GB vRAM. (Devel).
Addons Devel GitHub
JoseMRPubServ Resources

Post Reply

Return to “Upgrade XigmaNAS”