Sorry we lost some posts because of database errors!

*New 12.1 series Release:
2020-09-01: XigmaNAS 12.1.0.4.7728 - released

*New 11.4 series Release:
2020-08-27: XigmaNAS 11.4.0.4.7718 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[SOLVED] TheBrig not working after upgrade

For "upgrading" from FreeNAS/NAS4Free Legacy to XigmaNAS and upgrading XigmaNAS to newer builds.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
blc
NewUser
NewUser
Posts: 5
Joined: 27 Aug 2016 16:51
Status: Offline

[SOLVED] TheBrig not working after upgrade

#1

Post by blc »

A reboot fixed this issue..


_________________________________________
Hi

Ok, this is going to be a post about how to NOT perform an upgrade..
But.. having tried the way of the "user manual" and not getting anywhere this is where i ended up.

So.. to start.
I wanted to upgrade my 9.x version of N4F.
I was recommended to do a clean install using the liveUSB image from the website.
That image would not boot.. i tried several different computers, no go.. first when i tried it in a VM i could finally see what it was supposed to do..

So.. i DD'ed a embedded install image onto a USB stick, and booted that.. and since it worked, i figured i would use that as my basis and rotate the mem stick as i had experienced crashes with the usb sticks before.. (they only have a limitted lifetime and usually after 2-4 years, they suddenly crash and refuse to reboot..)

So far so good, new system booted.
I tried to restore using the config from 9.x to see if that would crash it or restore ok, and it worked, so i tried the same on the actual box.

That too worked just fine. Only problem i had was that despite IP address being set statically i had to force a DHCP request to get the webgui responding..

Now.. here's where the fun starts.. as i tried to get into the menu of TheBrig, i was not really surprised to see that it would not load..

Error:
Warning: require_once(XML/Serializer.php): failed to open stream: No such file or directory in /usr/local/www/ext/thebrig/extensions_thebrig.php on line 10 Fatal error: require_once(): Failed opening required 'XML/Serializer.php' (include_path='.:/etc/inc:/usr/local/www') in /usr/local/www/ext/thebrig/extensions_thebrig.php on line 10

I tried upgrading the installation with the script, but no change. i tried moving to a different folder, and reinstall there, no change..

I did the "Ask a friend" part, as he being a programmer and well versed in PHP, might have some insight for me..
As a result, i tried renaming the folder /usr/local/www/ext/thebrig to something else, and reinstall..

Now i got the following error:
No input file specified.

So i then tried deleting the symlinks from /usr/local/www/ and reinstall, and just like before the script goes like this:
Retrieving the alcatraz branch as a zip file
alcatraz.zip 100% of 145 kB 45 kBps 00m03s
Unpacking the tarball...
Done!
Detecting current configuration...
Detecting current configuration...
Look like update thebrig
Congratulations! You have fresh TheBrig version.

And i still get the same error..
No input file specified.

So.. now what?

Anyone got any insight as to how i can manually remove any and all traces of the old install so the script will perform a correct install?

Gleneisenbach
Starter
Starter
Posts: 37
Joined: 04 Apr 2015 10:36
Location: Neu-Anspach
Status: Offline

NOT SOLVED!! TheBrig not working after upgrade

#2

Post by Gleneisenbach »

Hi BLC,

I also upgraded my nas from 9.3.0.2 to 11.0.0.4 and got the same error when I tried to open TheBrig in the GUI.
I searched the missing "Serializer.php" via WinSCP in '/etc/' and '/usr/local', but I couldn't find it. A simple reboot didn't help.

I used TheBrig to run the Plex Media Sever. Now I did the follwoing:
- I de-activated the start command of TheBrig in System/advanced/scribs
- I installed the OneButtonInstaller
- I installed Plex with the OneButtonInstaller without a Jail

As a side effect Plex again needs days to build a new database and thumbnails.

The only problem which still remain is that the OneButtonInstaller shows TheBrig as installed.
ASRock Q1900-ITX, be quiet! System Power S7 300 Watt bulk, Kingston 4GB DDR3L SO-DIMM 1600MHz, PC3-12800, 2 X Seagate ST3000VN000 NAS HDD 3TB, Cooler Master Elite 120 Advanced schwarz,Toshiba TransMemory mini Suruga 8GB schwarz
NAS4Free11.0.0.4 -(Sayyadina)

zmoneyradio
NewUser
NewUser
Posts: 1
Joined: 18 Feb 2017 06:07
Status: Offline

Re: [SOLVED] TheBrig not working after upgrade

#3

Post by zmoneyradio »

I've had this same problem and have been searching for hours to find a solution! I figured it out:

The problem:

After removing TheBrig either manually or through the OneButtonInstaller, when trying to reinstall TheBrig, OneButtonInstaller reports TheBrig is already installed. When attempting to manually install TheBrig (without OBI) thebrig_install.sh reports TheBrig is already installed and attempts to run an upgrade instead, but fails despite claiming the update was successful.

The issue is that thebrig_install.sh checks to see if TheBrig is already installed by reading the N4F config.xml file and/or there are remaining TheBrig remnants from the previous install that make it appear as if it's still installed.

The solution:


(assuming TheBrig no longer shows up under the extensions tab)

**BACKUP YOUR N4F CONFIG BEFORE TRYING THIS**

1. Manually delete /thebrig folder and all its contents using SSH, FTP, CIFS, etc. (Mine was located in a ZFS dataset I created called "Jail")
2. Remove all TheBrig entries (if any) in the following sections (System --> Advanced): Command Scripts, Cron, Loader.conf, rc.conf, and sysctl.conf
3. Edit config.xml to remove TheBrig entry (Tools --> File Editor), file path: /conf/config.xml. Remove all text from <thebrig> to </thebrig> (including the brackets). Be sure not to remove or adjust any other entries in this file!!
4. Save the edited config.xml file
5. Reboot

TheBrig should now be removed from the system and a fresh install can be performed, either manually or through OBI. OBI will no longer report TheBrig as already installed.

NOTE: I am not a programmer! I figured this out through trial and error. If I missed something, or if there's a better way to handle this, please let me know. However, having spent many hours trying to figure out how to reinstall TheBrig properly, I've found there is almost NO information on how to do this! I checked the config.xml file as a last resort, having already done steps 1 and 2 above to no avail. When I found <thebrig> entry in the config.xml file and removed it, this fixed my problem for good! Hope this helps you as well!

MatthewOgs
NewUser
NewUser
Posts: 1
Joined: 24 Jan 2018 07:23
Status: Offline

Re: [SOLVED] TheBrig not working after upgrade

#4

Post by MatthewOgs »

Thanks for this it worked perfectly. Its impossible to find info on this

mmihaylov
NewUser
NewUser
Posts: 9
Joined: 07 Mar 2017 12:58
Location: Bulgaria
Status: Offline

Re: [SOLVED] TheBrig not working after upgrade

#5

Post by mmihaylov »

Worked like a charm for me
I saw some instructions in other threads but point 3 made the magic
Thank you zmoneyradio !

Post Reply

Return to “Upgrade XigmaNAS”