Page 1 of 1

Step by step from NAS4Free 10.x.x.x to 11.x.x.x

Posted: 28 Dec 2017 23:48
by CheshireCat
This note is a record of an upgrade process that worked for me. It is not necessarily the "right" way to do the upgrade. I couldn't find any similar information, so I noted down what happened when I ran the process. If these notes help anyone else do the upgrade, then it has been worth writing them. The whole operation took a little over an hour, including making notes and taking photos. There are probably better ways to do the job so comments may well help other people.

Hardware: 2012 vintage HP Microserver N40L, 8GB ECC memory, 2x4TB WD red drives (ZFS mirror), 2x6TB WD red drives (ZFS mirror). Normally headless but can easily have a monitor, keyboard and mouse attached. The N40L has an internal USB socket and four external sockets. It can be booted from any of the five USB sockets. There is no optical drive on this system.

This is a 64 bit system, hence capable of running 11.x.x.x.

Preparatory work is done on Windows 10.

Hardware pre-requisites: two USB thumb drives of at least 4GB capacity in addition to the drive already in the NAS. Having drives of different sizes can make it easier to distinguish between the drives. I prefer to format the drives as FAT32 in a single partition but it may well not be necessary. If the USB drives have previously been used as NAS4Free embedded systems, they will have several partitions on them. The free software "Rufus" from will reformat USB drives. It can also be used to load images on to USB drives.

Software pre-requisites: Live USB file from - it is important to read the "readme" text. The file downloaded will be an img.gz file.
Software to load the img.gz file on to a USB drive. The NAS4free project suggests using "Win32DiskImager" but "Etcher" works well for me when working with Raspberry Pi .img files so that is what is used here. Etcher will load images direct from .img.gz files, which makes life slightly easier.

Information pre-requisites: Network settings. Using the WebGUI, navigate to "Network > LAN Management" and note the network settings.

Task list:
1) Backup the NAS4Free config using "System > Backup" from the WebGUI. Store the backup somewhere other than on the NAS! I like to keep copies on at least one PC and at least one USB stick (not one I'm going to use later in the process) and to check that the files are readable.
2) Load the LiveUSB system on to a USB. Etcher reported that the process had worked correctly. Windows then complained that some of the partitions needed formatting so I cancelled all the messages and removed the USB device.
3) Shutdown NAS4Free using "System > Shutdown" from the webGUI. When safely shut down, disconnect power.
4) Connect keyboard, mouse and monitor. From here to step .., the keyboard and monitor are used.
5) Remove existing embedded system USB drive.
6) Insert live USB drive in external USB socket.
7) Boot up the NAS. This takes some time on the N40L, which is quite slow.
8) A screen will briefly appear saying "Welcome to NAS4Free!" and offering various boot options. The default worked for me, which is just as well because it doesn't give you long to select an option.
9) Eventually the system pauses, showing a screen with the WebGUI Address and a list of options that can be selected by entering a number. There is also the statement "Now, the blank USB memory for installation can be inserted."
10) Insert the clean 4GB USB drive into internal socket.
11) Select option 9 "Install/Upgrade from LiveCD/LiveUSB".
12) After various messages about the devices found, a screen headed "NAS4Free Install & Upgrade Menu" appears. Select "Install 'Embedded' OS on HDD/SSD/CF/USB (Preferred)". This is the default. Tab keys move round the options and Enter selects.
13) A screen headed "NAS4Free Embedded Install Options Menu" appears. Select the default "Install 'Embedded' OS/GPT on HDD/SSD/CF/USB (Preferred)".
14) A screen headed "Choose Installation media" appears. For me, there was only one option "da0 Lexar JumpDrive 1.00" which I recognised as the LiveUSB drive. Select the drive.
15) A screen headed "Choose destination media" appears. This listed ada0 to ada3 (the data drives) and "da1 4.02GB <Generic Flash Disk 8.07>". Select da1.
16) A screen requires one to select the size of the swap partition. I chose the recommended value as I don't know any better.
17) A screen shows creation of partitions and file systems. At the bottom of the screen a percentage appears at the left and estimate of remaining time at the right. The percentage sticks at 99.9% for quite a time and the remaining time number doesn't bear much relation to the actual time the process takes - it stuck on 1 second for at least 30 seconds for me.
18) After the installation completes, a screen appears reporting that NAS4Free has been installed on da1p2. "You can now safely remove the LiveCD/USB and reboot the server". In addition, there is information about the DATA partition. I photographed the screen to record the information. "Press Enter to continue".
19) The screen displayed previously at (12) above appears. Select "Exit".
20) The options previously shown in step (9) are shown. Select option 8, "Shutdown Server" and confirm that you "really want to shutdown the server".
21) Wait until system has powered down, then remove power from server and remove LiveUSB.
22) Reboot the NAS. It should now boot from the embedded system just installed and display the default network address ( The "Console Menu" offers a list of options. Select option 2, "Configure Network IP address". At this point, the information logged under "information pre-requisites" is required.
23) Set up the network information. When complete, the system will tell you how to access the WebGUI, finishing with "Press ENTER to continue".
24) The console menu seen in step (22) now appears.
25) Use the WebGUI to access the NAS, logging in as user admin with password nas4free.
26) Backup the config using "System > Backup" as in (1) above. It is unlikely that this config will ever be required again, so multiple storage is probably not necessary.
27) Restore the config from the backup taken in (1) above using using "System > Restore". The NAS will reboot as soon as the configuration has been restored.
28) When the server is fully running, log in from a browser using the credentials you used before the upgrade. Your data should now be accessible as it was before the upgrade.
29) Backup the configuration as in (1) above and save in multiple places. On my system, although I had made no configuration changes, the upgrade to 11.x.x.x resulted in some modifications to the config file.
30) Shutdown the NAS, remove power from server, disconnect the keyboard, mouse and monitor.
31) Reconnect the power, Reboot the NAS.

Job done!

Re: Step by step from NAS4Free 10.x.x.x to 11.x.x.x

Posted: 26 Mar 2019 21:56
by thegush
Thanks - that was very useful

Re: Step by step from NAS4Free 10.x.x.x to 11.x.x.x

Posted: 27 Apr 2019 23:42
by sauvel
Hi TheGush,
Very nice post, very useful, just used it to upgrade. I do have a couple of caveats/corrections, they might be useful to others:
1. On older systems, use MBR and not GPT (like mine, I was not going anywhere using GPT)
2. Windows 10 really, really deeply sucks at formatting, imaging tasks even with 3rd party help.
I did the formatting, image loading on the usb stick using linux mint. On windows 10, it was one problem after another, If may work using windows 10 OS but if you get stuck for no apparent reason, use linux (my failed OS was Windows 10 pro build 17134).
3. The default password has changed to xigmanas, might cause a moment of panic!
Finally, for the people at xigmanas, WELL DONE. Faster, better, a pleasure to use.
Best wishes to all.

Re: Step by step from NAS4Free 10.x.x.x to 11.x.x.x

Posted: 15 Jun 2019 17:26
by CheshireCat
For creating the installation USB under Windows 10, I now use Balena Etcher.

This will create a bootable drive from a compressed image without requiring a separate un-gz step. It is widely used in the Raspberry Pi world so it is well tested.

Re: Step by step from NAS4Free 10.x.x.x to 11.x.x.x

Posted: 19 Aug 2019 01:16
by rwps
great post - many thanks
I used this guide to go from 10.xxxx to 12.xxxx on a full install
the only hiccup I found was at step 13. I've got a full (not embedded) install, and when I went for GPT I had issues when trying to boot to full install (an error came up about GPT or MBR that stopped the system loading).
Easily fixed by using the MBR full install option.
The only learning for me next time was that Transmission lost it's files on the way through, and similarly Plex did too - I needed to back them up better before embarking on the upgrade.

Re: Step by step from NAS4Free 10.x.x.x to 11.x.x.x

Posted: 30 Aug 2019 17:18
by CheshireCat
Glad it came in useful. Thanks for letting me know.

In this situation you might consider "bookmark backup" as documented here:
viewtopic.php?f=66&t=13539&p=84028&hili ... ark#p84028
It doesn't save any space first time round but next time you want to do a system refresh and consider it prudent to protect your data there should be far fewer changes and you won't have snapshots lurking that can silently fill your disks.