*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Slow as a trickle after upgrade - Accessing from Mac

For "upgrading" from FreeNAS/NAS4Free Legacy to XigmaNAS and upgrading XigmaNAS to newer builds.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
tdiaz
Starter
Starter
Posts: 27
Joined: 08 Mar 2017 21:12
Status: Offline

Slow as a trickle after upgrade - Accessing from Mac

#1

Post by tdiaz » 19 Sep 2018 03:16

I don't have anything other than OSX 10.13.3 to access from at the moment, but:

I have an 11.x based box. Root on ZFS., that's been upgraded a few times and was previously at the first release that had Samba 4.8.2.

I upgraded it to 11.2.0.4.6005 and it's now rediculously slow at writing to SMB shares with a 1GB test file. It would take about a minute previously, now it's saying it's still got 15 minutes to go.

Now for a twist:

I also have an older box that was running on a two year old embedded 10.1 that I wanted to update to the latest and was ready to re-install via boot CD and saved config file, however the optical drive was being uncooperative and when I tried it with the USB it wasn't finding my boot volume, at least it wasn't recognizing it the same way I'm used to finding, but the upgrade function actually did.. (Yes, I know. "Don't upgrade old boxes), I fully expected it to just make a mess of it but I let it do it anyway.

It took all of about 20 seconds, to which I replied to myself, there's no way that did anything useful. I was expecting to have to remove the optical drive and it was time for filter cleaning and what not anyway. I restarted from the LiveUSB and the next thing I see it saying Xigmanas instead of NAS4Free.

Well, that upgrade in place worked absolutely flawlessly. ;-)

I can access that one and write that same 1TB file to it in under 40 seconds, but no longer on the newer one.

The shares from the older one are recognized as SMB (unknown) where as the newer (slow) one shows SMB (OS X).

I had signing turned off, and all that other typical Mac speed related stuff.

Where should I start looking?

Post Reply

Return to “Upgrade XigmaNAS”