*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Can't Delete Users

Authenticating users & groups on XigmaNAS.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Jyjon
Starter
Starter
Posts: 17
Joined: 17 Nov 2014 21:51
Status: Offline

Can't Delete Users

#1

Post by Jyjon » 22 May 2018 22:19

I am unable to find a way in the WebGUI to delete users.

If I do 'pw deluser <user>' from the command line, the user is deleted. I confirm the user is no longer in /etc/passwd, but the WebGUI doesn't update the deletion.
After a reboot the user is back.

Is there a way to delete users, if so, what is it?
Supermicro X9SCM-F-O : Intel E3-1225v2 : 32GB ECC RAM : Dell Perc H200i flashed to Dell 6Gbps SAS HBA : Mirrored 2x 4TB 2.5" Seagate ST4000LM016 : Raidz1 3x6TB WL6000GSA6457

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Can't Delete Users

#2

Post by ms49434 » 22 May 2018 22:53

Jyjon wrote:
22 May 2018 22:19
I am unable to find a way in the WebGUI to delete users.

If I do 'pw deluser <user>' from the command line, the user is deleted. I confirm the user is no longer in /etc/passwd, but the WebGUI doesn't update the deletion.
After a reboot the user is back.

Is there a way to delete users, if so, what is it?
goto Access > Users & Groups > Users, mark the user account(s) you want to delete and push button "Delete Selected User Accounts"
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Jyjon
Starter
Starter
Posts: 17
Joined: 17 Nov 2014 21:51
Status: Offline

Re: Can't Delete Users

#3

Post by Jyjon » 22 May 2018 23:01

There is no 'Delete Selected User Accounts' button.
Supermicro X9SCM-F-O : Intel E3-1225v2 : 32GB ECC RAM : Dell Perc H200i flashed to Dell 6Gbps SAS HBA : Mirrored 2x 4TB 2.5" Seagate ST4000LM016 : Raidz1 3x6TB WL6000GSA6457

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Can't Delete Users

#4

Post by ms49434 » 22 May 2018 23:12

Jyjon wrote:
22 May 2018 23:01
There is no 'Delete Selected User Accounts' button.
please provide platform and version of your NAS4Free installation.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4921
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Can't Delete Users

#5

Post by raulfg3 » 22 May 2018 23:17

please clear cache or use different explorer:
You do not have the required permissions to view the files attached to this post.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

Jyjon
Starter
Starter
Posts: 17
Joined: 17 Nov 2014 21:51
Status: Offline

Re: Can't Delete Users

#6

Post by Jyjon » 22 May 2018 23:28

Nas4Free 11.1.0.4.5565
users.jpeg
You do not have the required permissions to view the files attached to this post.
Supermicro X9SCM-F-O : Intel E3-1225v2 : 32GB ECC RAM : Dell Perc H200i flashed to Dell 6Gbps SAS HBA : Mirrored 2x 4TB 2.5" Seagate ST4000LM016 : Raidz1 3x6TB WL6000GSA6457

Jyjon
Starter
Starter
Posts: 17
Joined: 17 Nov 2014 21:51
Status: Offline

Re: Can't Delete Users

#7

Post by Jyjon » 22 May 2018 23:53

System > Advanced and check "Button Location - Display action buttons in the scrollable area instead of the footer area." Solved the problem. There is a delete button on the screen now.

Thank you for your help.
Supermicro X9SCM-F-O : Intel E3-1225v2 : 32GB ECC RAM : Dell Perc H200i flashed to Dell 6Gbps SAS HBA : Mirrored 2x 4TB 2.5" Seagate ST4000LM016 : Raidz1 3x6TB WL6000GSA6457

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Can't Delete Users

#8

Post by ms49434 » 22 May 2018 23:56

ftr, my previous reply was messed up by attachments.
192.168.0.44_access_users.php (1).png
If you cannot see the Delete Selected User Account button right below the list or just above the footer (see above) you should go to System > Advanced and check "Button Location - Display action buttons in the scrollable area instead of the footer area."
192.168.0.44_access_users.php (1).png
You do not have the required permissions to view the files attached to this post.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Post Reply

Return to “Local Users & Groups”