*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Unable to access files after domain join Please Help

Authenticating XigmaNAS users using Active Directory or NT PDC
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Dudefoxlive
NewUser
NewUser
Posts: 4
Joined: 11 Jan 2016 02:43
Status: Offline

Unable to access files after domain join Please Help

#1

Post by Dudefoxlive » 18 Jan 2016 02:29

I joined my nas4free server to my domain and no user from the server can access the shares and I need active directory login to work because of the backup program and a few other things I use will not stop complaining about unable to access share possible cause wrong username and password. it is a big problem and I can not get to my files. Please Help Me

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4918
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Unable to access files after domain join Please Help

#2

Post by raulfg3 » 18 Jan 2016 07:21

More info is needed.

Revise that user password do not contain localized characters like "ñ" or "ç" <- In my case for spanish keyboard.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

KimmoJ
Starter
Starter
Posts: 42
Joined: 02 Feb 2016 15:02
Status: Offline

Re: Unable to access files after domain join Please Help

#3

Post by KimmoJ » 18 Feb 2016 09:49

Go to to Diagnostics / Information and click on "MS Domain". The information should include stuff like "Join to DOMAINNAME is OK" and you should be able to see imported users.

If that works your AD connection is probably fine, which means you have permission issues on the shares.

In that case and if you can't access the share, your best bet is to set your domain administrator account as owner of the share, to begin with. Enable the SSH service, SSH to the machine and go to the place where you have your file shares mounted, probably " cd /mnt/poolname" (with your own pool name, obviously) and do "chown -R administrator sharename" where sharename is the dataset where you have your files.

You could also use the Advanced / Command function, I suppose.

After that, I'd go to a Windows machine/server in your active directory and open the Computer Management program, in Administrative Tools (at least on server 2008 r2). Go to the Action menu, select "connect to another computer" and put in the name of your NAS4Free. Then you can go to System Tools, Shared Folders and see your shares and set proper permissions on them from the familiar Windows end.

At least that's what I'd try.

Post Reply

Return to “Active Directory”