*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Error when trying to start samba4 in jail - NT_STATUS_ADDRESS_ALREADY_ASSOCIAT

Authenticating XigmaNAS users using Active Directory or NT PDC
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
aleatorvb
NewUser
NewUser
Posts: 12
Joined: 21 Nov 2012 00:45
Status: Offline

Error when trying to start samba4 in jail - NT_STATUS_ADDRESS_ALREADY_ASSOCIAT

#1

Post by aleatorvb » 11 Dec 2014 20:26

When starting samba4 i get this in the log:
[2014/12/11 19:21:49, 0] ../source4/smbd/server.c:369(binary_smbd_main)
samba version 4.0.8 started.
Copyright Andrew Tridgell and the Samba Team 1992-2012
[2014/12/11 19:21:51, 0] ../source4/smbd/server.c:475(binary_smbd_main)
samba: using 'standard' process model
[2014/12/11 19:21:51, 0] ../source4/cldap_server/cldap_server.c:134(cldapd_add_socket)
Failed to bind to ipv4:10.11.12.166:389 - NT_STATUS_ADDRESS_ALREADY_ASSOCIATED
[2014/12/11 19:21:51, 0] ../source4/smbd/service_task.c:35(task_server_terminate)
task_server_terminate: [cldapd failed to setup interfaces]
[2014/12/11 19:21:51, 0] ../source4/kdc/kdc.c:690(kdc_add_socket)
Failed to bind to 10.11.12.166:88 UDP - NT_STATUS_ADDRESS_ALREADY_ASSOCIATED
[2014/12/11 19:21:51, 0] ../source4/smbd/service_task.c:35(task_server_terminate)
task_server_terminate: [kdc failed to setup interfaces]
[2014/12/11 19:21:51, 0] ../source4/smbd/server.c:210(samba_terminate)
samba_terminate: cldapd failed to setup interfaces

I did the following steps to install samba4

- install the brig
- create jail
- assign ip to jail
- jls
- jexec <jail> csh
- pkg_add -r nano mc-light
- pkg_add -r samba4
- samba-tool domain provision --use-ntvfs --use-rfc2307 --host-ip=10.11.12.166 --interactive
- edit rc.conf and add samba4_enable="YES"

What am i doing wrong?

I'm confident no other service is using that port.
Hardware: 9.1.0.1 - Sandstorm (revision 847) | Intel Corporation DQ87PG | 6x 3TB WD Red drives in a raid-z2 storage |Services: CIFS, Nagios Client, SSH, BitTorrent, Bittorent Sync. Saturating a gigabyte link over cifs! :)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4918
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Error when trying to start samba4 in jail - NT_STATUS_ADDRESS_ALREADY_ASSOCIAT

#2

Post by raulfg3 » 11 Dec 2014 20:58

samba in a jail is not a good idea, better try this experimental build that have SAMBA 4. viewtopic.php?f=69&t=5365

PD: You do not notice any speed improvements to upgrade to SAMBA 4.x , if you are a regular/normal user SAMBA included on Nas4Free is enought for normal usage, only install / Test SAMBA 4 if you need some new feature like AD included on SAMBA 4.

viewtopic.php?f=69&t=5365
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

aleatorvb
NewUser
NewUser
Posts: 12
Joined: 21 Nov 2012 00:45
Status: Offline

Re: Error when trying to start samba4 in jail - NT_STATUS_ADDRESS_ALREADY_ASSOCIAT

#3

Post by aleatorvb » 16 Dec 2014 19:30

Thank you for the information. I need an active directory over nas4free. I will then attach nas4free cifs to use that active directory and serve all data from nas4free shares. I don't see any other option except use a second system just for the AD part..
Hardware: 9.1.0.1 - Sandstorm (revision 847) | Intel Corporation DQ87PG | 6x 3TB WD Red drives in a raid-z2 storage |Services: CIFS, Nagios Client, SSH, BitTorrent, Bittorent Sync. Saturating a gigabyte link over cifs! :)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4918
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Error when trying to start samba4 in jail - NT_STATUS_ADDRESS_ALREADY_ASSOCIAT

#4

Post by raulfg3 » 16 Dec 2014 21:19

aleatorvb wrote:Thank you for the information. I need an active directory over nas4free. I will then attach nas4free cifs to use that active directory and serve all data from nas4free shares. I don't see any other option except use a second system just for the AD part..
OK, please use latest build 1190, that have SAMBA 4.1.13 : http://sourceforge.net/projects/nas4fre ... .0.2.1190/

Read readme first: http://sourceforge.net/projects/nas4fre ... t/download
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

aleatorvb
NewUser
NewUser
Posts: 12
Joined: 21 Nov 2012 00:45
Status: Offline

Re: Error when trying to start samba4 in jail - NT_STATUS_ADDRESS_ALREADY_ASSOCIAT

#5

Post by aleatorvb » 27 Dec 2014 18:24

raulfg3 - i managed to install debian

GNU/kFreeBSD ****** 9.3-RELEASE-p6 FreeBSD 9.3-RELEASE-p6 #0 r275752M: Sun Dec 14 01:40:23 CET 2014 root@dev.nas4free:/usr/obj/nas4free/usr/src/sys/NAS4FREE-i386 i386 i386 Intel(R) Atom(TM) CPU N2800 @ 1.86GHz GNU/kFreeBSD

but now I'm stuck at using samba-tools:

apt-get update
Hit http://cdn.debian.net squeeze Release.gpg
Ign http://cdn.debian.net/debian/ squeeze/main Translation-en
Hit http://cdn.debian.net squeeze Release
Hit http://cdn.debian.net squeeze/main kfreebsd-i386 Packages
Reading package lists... Done

apt-get install samba-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
samba-tools is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

but i can't actually use it...

root@debian:/home# samba-tool
bash: samba-tool: command not found
root@debian:/home# samba-tools
bash: samba-tools: command not found

any hints on fixing this? I did the jail twice using the tutorial you mentioned. Samba 4 works fine, but i can't configure ad server without samba-tool (as far as i know from tutorials)

Thank you for taking time to help me!
Hardware: 9.1.0.1 - Sandstorm (revision 847) | Intel Corporation DQ87PG | 6x 3TB WD Red drives in a raid-z2 storage |Services: CIFS, Nagios Client, SSH, BitTorrent, Bittorent Sync. Saturating a gigabyte link over cifs! :)

Post Reply

Return to “Active Directory”