Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[HOW TO] Fix authentication problem for older clients in XigmaNAS

CIFS/SMB network sharing.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
isoellias
NewUser
NewUser
Posts: 9
Joined: 24 Jul 2019 15:41
Location: Brasil, RS
Status: Offline

[HOW TO] Fix authentication problem for older clients in XigmaNAS

#1

Post by isoellias » 31 Jul 2019 21:02

Hello,
I would like to contribute to the forum with this little How To.
When you set up a default samba share, it may not be accessible to other platforms. Type FreeBSD client, Linux or even some older Windows.

Error:

Client FreeBSD:

Code: Select all

mount_smbfs -I <ip-host> -U <user> //<netbios-name>/<share> /mnt/bkp
Password: ********
mount_smbfs: unable to open connection: syserr = Authentication error
Client Linux

Code: Select all

mount -v -t cifs //<ip-host>/<share> /mnt/bkp -o username=<user>, password=<*******>, noperm
mount error 13 = Permission denied
Refer to the mount.cifs (8) manual page (e.g.man mount.cifs)
This must be due to the evolution of the smb protocol. Because of this, older systems may not support "NTLMv2" authentication.

To remedy this problem add these two parameters to: "Additional Parameters [Global]" (SERVICES>CIFS/SMB)
xigmanas_smb_ntlmv2.PNG
Thankful!
You do not have the required permissions to view the files attached to this post.
Last edited by isoellias on 02 Aug 2019 15:02, edited 1 time in total.
12.0.0.4 - Reticulus (revision 6766) | FreeBSD 12.0-RELEASE-p6
x64-full on Intel Xeon 2.33GHz | 4G/Ram
Two 2Tb disks over zraid

sleid
PowerUser
PowerUser
Posts: 739
Joined: 23 Jun 2012 07:36
Location: FRANCE LIMOUSIN CORREZE
Status: Offline

Re: How to fix authentication problem for older clients in XigmaNAS

#2

Post by sleid » 02 Aug 2019 10:01

README XigManas:

cifs/smb note:
==============
From Samba 4.5.0 and up the default value for the "ntlm auth" option is changed from "yes" to "no".
This may have impact on very old clients which doesn't support NTLMv2 yet.
Only if you really need NTLMv1 Authentication you can set in Services > CIFS/SMB > Settings on
Additional Parameters: "ntlm auth = yes".
12.0.0.4 - Reticulus (revision 6766)
FreeBSD 12.0-RELEASE-p6 #0 r349200M: Wed Jun 19 20:27:52 CEST 2019
X64-embedded sur Intel(R) Atom(TM) CPU C2750 @ 2.40GHz Boot UEFI
ASRock C2750D4I 2 X 8GB DDR3 ECC
Pool of 2 vdev Raidz1: 3 x WDC WD40EFRX + 3 x WDC WD30EZRX

isoellias
NewUser
NewUser
Posts: 9
Joined: 24 Jul 2019 15:41
Location: Brasil, RS
Status: Offline

Re: How to fix authentication problem for older clients in XigmaNAS

#3

Post by isoellias » 02 Aug 2019 14:57

Good Morning!
Thank you for your contribution in bringing this official information.
I believe that just putting this flag "ntlm auth = yes" already shows result. Because it is likely that more modern customers will use "NTLMv2".
Thankful.
12.0.0.4 - Reticulus (revision 6766) | FreeBSD 12.0-RELEASE-p6
x64-full on Intel Xeon 2.33GHz | 4G/Ram
Two 2Tb disks over zraid

sleid
PowerUser
PowerUser
Posts: 739
Joined: 23 Jun 2012 07:36
Location: FRANCE LIMOUSIN CORREZE
Status: Offline

Re: [HOW TO] Fix authentication problem for older clients in XigmaNAS

#4

Post by sleid » 03 Aug 2019 23:35

2018 december
12.0.0.4 - Reticulus (revision 6766)
FreeBSD 12.0-RELEASE-p6 #0 r349200M: Wed Jun 19 20:27:52 CEST 2019
X64-embedded sur Intel(R) Atom(TM) CPU C2750 @ 2.40GHz Boot UEFI
ASRock C2750D4I 2 X 8GB DDR3 ECC
Pool of 2 vdev Raidz1: 3 x WDC WD40EFRX + 3 x WDC WD30EZRX

Post Reply

Return to “CIFS/SMB (Samba)”