Page 1 of 1

I am using FULL installation - nevertheless my ~/.ssh/authorized keys file is deleted on every reboot

Posted: 08 Jun 2019 21:54
by fallen2109
Today I migrated from XigmaNAS 11 to the new 12 version.

However - I discovered that my ~/.ssh/authorized_keys file is deleted on every reboot and replaced by an empty file containitng one string "# created by raki" .

Can you please help ? I am using key generated by Putty and it worked flawlessly in the past 2 years on v10 and v11. I am confident that I have a FULL installation.
What am I doing wrong ?!?

Re: I am using FULL installation - nevertheless my ~/.ssh/authorized keys file is deleted on every reboot

Posted: 08 Jun 2019 22:58
by ms49434
fallen2109 wrote:
08 Jun 2019 21:54
Today I migrated from XigmaNAS 11 to the new 12 version.

However - I discovered that my ~/.ssh/authorized_keys file is deleted on every reboot and replaced by an empty file containitng one string "# created by raki" .

Can you please help ? I am using key generated by Putty and it worked flawlessly in the past 2 years on v10 and v11. I am confident that I have a FULL installation.
What am I doing wrong ?!?
We have added some basic public key management.
Please goto Access > Users & Groups > Public Keys and add records for your users and their public keys (You can also add public keys for root).

Re: I am using FULL installation - nevertheless my ~/.ssh/authorized keys file is deleted on every reboot

Posted: 09 Jun 2019 14:32
by fallen2109
ms49434 wrote:
08 Jun 2019 22:58
fallen2109 wrote:
08 Jun 2019 21:54
Today I migrated from XigmaNAS 11 to the new 12 version.

However - I discovered that my ~/.ssh/authorized_keys file is deleted on every reboot and replaced by an empty file containitng one string "# created by raki" .

Can you please help ? I am using key generated by Putty and it worked flawlessly in the past 2 years on v10 and v11. I am confident that I have a FULL installation.
What am I doing wrong ?!?
We have added some basic public key management.
Please goto Access > Users & Groups > Public Keys and add records for your users and their public keys (You can also add public keys for root).
Thanks for the information! I have pasted my key there (Puttygen generated ) and it works flawlessly from now on. Thank you again.