Page 1 of 1

Server not supported by OS X 10.8.5

Posted: 24 Oct 2013 13:07
by apalmela
Hello,

I'm trying to configure my TimeMachine (Macbook with OS X 10.8.5 to work with Nas4Free under AFP.
The problem I get is that OS X reports this error:

"There was a problem connecting to the server “192.168.1.250”.
The version of the server you are trying to connect to is not supported. Please contact your system administrator to resolve the problem."

I tried these resolutions but with no success:
http://support.apple.com/kb/HT4700
http://www.alexanderwilde.com/2011/04/o ... orkaround/
http://frankleng.me/2011/07/21/connect- ... orkaround/

Is there another way to fix this ?

Re: Server not supported by OS X 10.8.5

Posted: 24 Oct 2013 13:34
by raulfg3
try to use SAMBA/SMB in Macbook = Option 1 in your provided link: http://frankleng.me/2011/07/21/connect- ... orkaround/

Re: Server not supported by OS X 10.8.5

Posted: 26 Oct 2013 01:56
by apalmela
I can't access to Time Machine if i choose SMB.... :(
When I list the time machine disc the smb server don't appear.

Works for me with OS X 10.8.5

Posted: 05 Jan 2014 18:22
by seaside
AFP works nicely for me with 10.8.5 and NAS4Free 9.1.0.1 - Sandstorm (revision 457).

Compare your /Library/Preferences/com.apple.AppleShareClient.plist with this one:

Code: Select all

{
	"afp_active_timeout" = 0;
	"afp_allow_submounts" = YES;
	"afp_allow_system_uams" = NO;
	"afp_allow_user_uams" = NO;
	"afp_debug_level" = 5;
	"afp_debug_syslog" = YES;
	"afp_disabled_uams" = (
		"Cleartxt Passwrd",
		"MS2.0",
		"2-Way Randnum exchange",
		DHCAST128,
	);
	"afp_forceKerberosOnly" = NO;
	"afp_host_prefs_version" = 15;
	"afp_idle_timeout" = 0;
	"afp_immutable_dirs" = YES;
	"afp_maxDirCache" = 60;
	"afp_maxFileCache" = 60;
	"afp_maxIOToleranceMSecs" = 0;
	"afp_maxQuantumNbr" = 0;
	"afp_maxQuantumSize" = 0;
	"afp_maxSingleIOToleranceMSecs" = 0;
	"afp_minDirCache" = 5;
	"afp_minFileCache" = 5;
	"afp_minIOToleranceMSecs" = 0;
	"afp_minQuantumNbr" = 0;
	"afp_minQuantumSize" = 0;
	"afp_minSingleIOToleranceMSecs" = 0;
	"afp_mount_defaultFlags" = 0;
	"afp_no_caseSensitiveVols" = 0;
	"afp_no_kQueues" = 0;
	"afp_no_volChange_caching" = 1;
	"afp_prefer_IPv4" = YES;
	"afp_reconnect_allow" = YES;
	"afp_reconnect_interval" = 10;
	"afp_reconnect_max_time" = 600;
	"afp_softautomount_vols" = NO;
	"afp_softmount_vols" = NO;
	"afp_wan_quantum" = 0;
	"afp_wan_threshold" = 0;
}
BTW there is a comment on this page:

http://www.alexanderwilde.com/2011/04/o ... orkaround/
For OS X 10.8 Mountain Lion (tested on an iMac 12,2 running a clean install of 10.8.3), follow the above instructions and omit the following two steps:

defaults write /Library/Preferences/com.apple.AppleShareClient afp_host_prefs_version -int 1

Note: To add a “DHCAST128″ to the disable list, use
sudo defaults write /Library/Preferences/com.apple.AppleShareClient afp_disabled_uams -array-add “DHCAST128″
You may try that one, too.

Best regards