*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Rsync presents deleted datasets

Synchronize files & directories to/from NAS4Free with minimal data transfer.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
hummel124
NewUser
NewUser
Posts: 2
Joined: 15 Feb 2018 21:02
Status: Offline

Rsync presents deleted datasets

#1

Post by hummel124 » 15 Feb 2018 21:33

Hi,
I encounter a weird behavior with the rsync.

I had a pool containing 2 datasets "backup1" and "backup2".
I deleted the datasets and created a new one "backup".

Different rsync clients still show backup1 and backup2 (and nothing else) as virtual directories, no matter what I try.
I deleted the whole ZFS and recreated the pool. Still only backup1 and backup2 visible.
No snapshots, no volumes, "zfs list -t all" shows the current datasets correctly

When I create a backup1 or 2 dataset it becomes usable so I use this as a workaround, but I'm not able to use additional datasets besides backup1 and backup2.
Update to the latest release did not fix the issue.

Any ideas?

Thank you
Chris

User avatar
ms49434
Developer
Developer
Posts: 715
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Rsync presents deleted datasets

#2

Post by ms49434 » 15 Feb 2018 22:33

Could it be that you've setup server modules named backup1 and backup2 which are linked to datasets backup1 and backup2?
Could it be that you haven't deleted the modules or you haven't disabled module listing in the modules configuration yet?
Could it be that they are still listed in your rsync client because of the above?

Please check Services > Rsync > Server > Modules
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

hummel124
NewUser
NewUser
Posts: 2
Joined: 15 Feb 2018 21:02
Status: Offline

Re: Rsync presents deleted datasets

#3

Post by hummel124 » 16 Feb 2018 14:50

OMG,
I actually forgot about the modules.

Thank you :)

Post Reply

Return to “RSYNC”