*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

automatisches starten

German community

Moderators: b0ssman, apollo567, crowi, Princo

Forum rules
Set-Up GuideFAQsForum Rules
variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

automatisches starten

#1

Post by variousos » 19 Aug 2018 22:26

Hallo und guten Abend,

ich möchte meinen NAS-Server gerne zu der immer gleichen Uhrzeit starten. Die Möglichkeit wird mir ja gegeben.

Leider funzt das nicht...der Server startet einfach zur eingestellten Uhrzeit nicht. Woran kann das liegen?

Lieben Dank für die Antwort
variousos
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#2

Post by Princo » 20 Aug 2018 03:35

variousos wrote:
19 Aug 2018 22:26
ich möchte meinen NAS-Server gerne zu der immer gleichen Uhrzeit starten. Die Möglichkeit wird mir ja gegeben.
WO wird dir denn diese Möglichkeit gegeben? In XigmaNAS selbst jedenfalls nicht.

Nach meiner Erfahrung gibt es ungefähr vier Möglichkeiten, einen Server zu einer bestimmten Zeit hochfahren zu lassen:

1. Per BIOS Einstellung. Manche Motherboards bieten einem die Möglichkeit, das Gerät zu einer bestimmten Zeit hochfahren zu lassen. Diese Einstellung findet sich generell nur sehr selten, und besonders bei der für XigmaNAS besonders geeigneten Hardware (Serverboards) eigentlich gar nicht.

2. Per WakeUp-On-Lan (WOL). Das wäre die beste und eleganteste Methode. Allerdings setzt sie ein externes Gerät voraus, welches diesen Impuls zu einer bestimmten Zeit aussendet. Leider hängt die Funktionalität sowohl von der Hardware, als auch von der eingesetzten XigmaNAS Version (genauer: der dort verwendeten FreeBSD-Version) ab. WOL ist etwas, was bei FreeBSD leider keinen großen Stellenwert hat. Ich bin davon selbst betroffen, und kann meine Systeme dadurch nicht auf den derzeitig aktuellen Stand heben, da ich sonst die WOL-Funktionalität verlieren würde.

3. Per IPMI; https://de.wikipedia.org/wiki/Intellige ... _Interface
Damit habe ich keine Erfahrung, und es ist sehr stark von der Hardware abhängig. Dafür wäre aber auch ein externes Gerät zur automatischen Steuerung nötig.

4. Per fernsteuerbaren Steckdosen. Das funktioniert aber nur, wenn man im BIOS einstellen kann, daß das NAS nach einem Stromausfall automatisch startet, wenn der Strom wieder da ist. Dafür wäre aber auch u.U. ein externes Gerät zur automatischen Steuerung nötig.

Meine eigene Lösung sieht derzeit so aus:

Früher konnte ich das zeitgesteuerte WOL von meinem DSL-Router durchführen lassen. Dazu verwendete ich eine modifizierte Firmware für meine Fritz!Box (Freetz).
Durch aktuelle EU-Bestimmungen ist dies leider nicht mehr möglich.

Jetzt verwende ich dafür einen Raspberry Pi, der mir meine NAS-Systeme pünktlich kurz vor 20 Uhr per WOL aufweckt, damit dann dort ein Auto-Snapshot stattfinden kann.

Alternativen:
Wenn es beim automatischen Start nur darum geht, daß ein Auto-Snapshot angelegt wird, dann gäbe es noch die Skripte von Fritz: viewtopic.php?f=70&t=2197

Damit kann man auch regelmäßige Snapshots erzeugen.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

defcon999
Advanced User
Advanced User
Posts: 150
Joined: 07 Dec 2013 10:55
Status: Offline

Re: automatisches starten

#3

Post by defcon999 » 20 Aug 2018 04:59

@Princo

Du siehst mich bezüglich des Hinweises auf das Snapshot-Script von Fritz etwas überrascht: Ich erinnere mich an ein Posting von Dir, in dem Du auf die Problematik bei dessen Nutzung hingewiesen hast.

Tenor war - wenn ich mich recht erinnere - dass man Probleme bekommen kann, weil die "Reihenfolge der Snapshots" problematisch ist.

Hast Du Deine Meinung geändert??

defcon999

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
NAS: HP MicroServer Gen8 - CPU: Intel Xeon E3-1230 V2 - QuadCore 3,3 GHz ** 16 GB ECC RAM ** 4 x 2 TB WD Red RaidZ1 ** Samsung 840 120 GB SSD RootOnZFS-System ** 1 x 6 TB WD Red RClone lokal via USB 3.0 Inateck USB 3.0 Dualschacht Festplatten-Dockingstation ** Cloning mit 1 x 6 TB WD RED im 2. Schacht der Docking-Station ** XigmaNAS-Version: 12.0.0.4.6881 - Reticulus** ZFSOnRoot-Installation (full) ** OneButtonInstaller: Plex & RClone -- VirtualBox: Ubuntu-Server with Pi-Hole

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#4

Post by variousos » 20 Aug 2018 19:59

Hallo @Princo,

woher ich das habe? Vielleicht verstehe ich die Version von NAS4free falsch...aber es steht ganz eindeutig "Geplanter Neustart" und "Geplantes Herunterfahren"...mit mehreren Möglichkeiten die Uhrzeit und Tage und Monate einzustellen.

Danke für Deine Mühe und die Antwort
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#5

Post by Princo » 20 Aug 2018 22:22

@variousos

Na, das hat sich ja schnell aufgeklärt:

Dort steht "geplanter Neustart". Dafür muß das Gerät aber bereits laufen. Das ist ein geplanter Reboot, und kein Aufwecken oder Boot.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#6

Post by variousos » 20 Aug 2018 22:47

SHIIIT :oops:
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#7

Post by variousos » 20 Aug 2018 22:48

"Jetzt verwende ich dafür einen Raspberry Pi, der mir meine NAS-Systeme pünktlich kurz vor 20 Uhr per WOL aufweckt, damit dann dort ein Auto-Snapshot stattfinden kann"

Könntest Du mir den Weg dahin aufzeigen...oder hast Du irgendwo ein Tutorial?
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#8

Post by Princo » 20 Aug 2018 23:03

defcon999 wrote:
20 Aug 2018 04:59
@Princo

Du siehst mich bezüglich des Hinweises auf das Snapshot-Script von Fritz etwas überrascht: Ich erinnere mich an ein Posting von Dir, in dem Du auf die Problematik bei dessen Nutzung hingewiesen hast.

Tenor war - wenn ich mich recht erinnere - dass man Probleme bekommen kann, weil die "Reihenfolge der Snapshots" problematisch ist.

Hast Du Deine Meinung geändert??
Du meinst sicher diesen Thread hier: viewtopic.php?p=71570#p71570

Da habe ich eine Problematik beschrieben, welche bei einer großen Anzahl von Snapshots auftreten kann, wenn man diese Skripte einsetzt. Benutzt man die Skripte aber durchgängig (also sowohl zum Erstellen, als auch zum Löschen der Snapshots), dann kann man das (mit Zähneknirschen) durchaus benutzen, wenn einem die anderen Alternativen dazu noch weniger gefallen.

Übrigens hattest du in dem anderen Thread mit deinem Hinweis auf das Löschen der Snapshots im Backup völlig recht.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#9

Post by variousos » 21 Aug 2018 10:13

Hallo Princo,

irgendwie ist Dein letzter Post ja nicht für mich bestimmt. Denn "defcon999" hat ja die Frage auf Deiner Beantwortung gestellt :o

Zu meinem Punkt.....es wäre natürlich toll wenn ich das NAS mit Hilfe eines Pi´s starten könnte. Habe noch zwei hier herumliegen...

LG
variousos
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#10

Post by Princo » 22 Aug 2018 02:31

variousos wrote:
20 Aug 2018 22:48
"Jetzt verwende ich dafür einen Raspberry Pi, der mir meine NAS-Systeme pünktlich kurz vor 20 Uhr per WOL aufweckt, damit dann dort ein Auto-Snapshot stattfinden kann"

Könntest Du mir den Weg dahin aufzeigen...oder hast Du irgendwo ein Tutorial?
Das ist ganz einfach.

Auf dem Raspi installierst du das Paket "etherwake":

Code: Select all

apt install -y etherwake
Dann fügst du auf dem Raspi in der Datei /etc/crontab den Zeitplan und den Befehl zum Aufwecken der NAS hinzu:

Beispiel:

Code: Select all

45 19	* * *	root	/usr/sbin/etherwake 38:EA:A7:A3:F2:D2
50 19	* * *	root	/usr/sbin/etherwake 38:EA:A7:A3:A0:71
Hier wird das NAS mit der MAC-Adresse 38:EA:A7:A3:F2:D2 täglich um 19:45 Uhr gestartet,
und das NAS mit der MAC-Adresse 38:EA:A7:A3:A0:71 wird täglich um 19:50 Uhr gestartet.

Das funktioniert natürlich nur, wenn das NAS und die darauf eingesetzte XigmaNAS-Version das Starten mittels WOL unterstützt.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#11

Post by variousos » 23 Aug 2018 17:27

@Princo....erst mal danke für die Erläuterung.

Jetzt setze ich ja die Version 10.1.0.2 - Prescience (Revision 1608)ein.

Wie könnte auf XigmaNAS migrieren? Gibt es da ein Tutorial und gehe ich ein Risiko ein?

Lieben Dank für die Antwort
variousos
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

defcon999
Advanced User
Advanced User
Posts: 150
Joined: 07 Dec 2013 10:55
Status: Offline

Re: automatisches starten

#12

Post by defcon999 » 23 Aug 2018 19:10

Danke für den tollen Tipp, Princo :mrgreen:

Ich hatte vorher immer immer über ein WOL-Impuls beim Start eines Clients gearbeitet.

Aber die Möglichkeit zeitgesteuert über den ohnehin laufenden Raspberry (mit Pi-Hole) ist ja um ein Vielfaches eleganter. Zusammen mit dem "manageACPI-Script" von Fritz kann man nun sehr gut den Start und das automatisierte Herunterfahren steuern. Außerdem erspart man sich die ca. 3-minütige Wartezeit bis der Server hochgefahren ist.

defcon999
NAS: HP MicroServer Gen8 - CPU: Intel Xeon E3-1230 V2 - QuadCore 3,3 GHz ** 16 GB ECC RAM ** 4 x 2 TB WD Red RaidZ1 ** Samsung 840 120 GB SSD RootOnZFS-System ** 1 x 6 TB WD Red RClone lokal via USB 3.0 Inateck USB 3.0 Dualschacht Festplatten-Dockingstation ** Cloning mit 1 x 6 TB WD RED im 2. Schacht der Docking-Station ** XigmaNAS-Version: 12.0.0.4.6881 - Reticulus** ZFSOnRoot-Installation (full) ** OneButtonInstaller: Plex & RClone -- VirtualBox: Ubuntu-Server with Pi-Hole

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#13

Post by variousos » 30 Aug 2018 22:23

Hallo und guten Abend,

ich wollte mich einmal bedanken. Das mit den automatischen Start über den Cronjob hat gut funktioniert. Der Pi startet das NAS pünktlich jeden Abend.

Gibt es das auch für einen Shutdown? Das ich über den Pi das NAS 2 oder 3 Stunden später herunter fahren lasse?

DANKE UND GRUSS
variousos
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

defcon999
Advanced User
Advanced User
Posts: 150
Joined: 07 Dec 2013 10:55
Status: Offline

Re: automatisches starten

#14

Post by defcon999 » 01 Sep 2018 13:47

Gibt es ....

viewtopic.php?f=70&t=2197

Dort findest Du das "manageACPI"-Script von FRITZ ... die Beschreibung ist selbsterklärend.

Du kannst diverse Abschaltparameter konfigurieren (Uhrzeit, IP-Adressen etc.) Ich nutze das Script seit den ersten NAS4Free-Zeiten und es funktioniert absolut tadellos bei mir.

Gruß - defcon999
NAS: HP MicroServer Gen8 - CPU: Intel Xeon E3-1230 V2 - QuadCore 3,3 GHz ** 16 GB ECC RAM ** 4 x 2 TB WD Red RaidZ1 ** Samsung 840 120 GB SSD RootOnZFS-System ** 1 x 6 TB WD Red RClone lokal via USB 3.0 Inateck USB 3.0 Dualschacht Festplatten-Dockingstation ** Cloning mit 1 x 6 TB WD RED im 2. Schacht der Docking-Station ** XigmaNAS-Version: 12.0.0.4.6881 - Reticulus** ZFSOnRoot-Installation (full) ** OneButtonInstaller: Plex & RClone -- VirtualBox: Ubuntu-Server with Pi-Hole

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#15

Post by Princo » 02 Sep 2018 14:41

variousos wrote:
30 Aug 2018 22:23
Gibt es das auch für einen Shutdown? Das ich über den Pi das NAS 2 oder 3 Stunden später herunter fahren lasse?
Ein simples zeitgesteuertes Herunterfahren kannst du am einfachsten über das WebGUI "System|Shutdown|Scheduled" einrichten.

Etwas näher an der Praxis wäre aber das Skript "manageAcpi.sh" vom User Fritz.. Da kann man konfigurieren, daß das NAS herunterfährt wenn bestimmte andere PCs im Heimnetz nicht mehr online sind.

Das funktioniert alles ohne ein externes Gerät (z.B. Raspberry Pi).

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#16

Post by variousos » 03 Sep 2018 21:00

Guten Abend Princo,

meinst Du das so wie ich das glaube zu verstehen? Siehe Attachment

Da, so würde ich es verstehen, schaltet das NAS sich jeden Abend um 22 Uhr aus....
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#17

Post by Princo » 05 Sep 2018 03:26

variousos wrote:
03 Sep 2018 21:00
Da, so würde ich es verstehen, schaltet das NAS sich jeden Abend um 22 Uhr aus....
Richtig.
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#18

Post by variousos » 04 Oct 2018 20:51

Hallo und guten Abend Zusammen,

also...das alles hat Prima geklappt. Mit dem Pi und dem "Job" das allabendliche Starten...dann 4 Stunden später das schöne Herunterfahren. Toll :D :D

Ich möchte in einem weiteren Thread mal auf Hilfe hoffen, was mich seit einiger Zeit beschäftig und einfach nicht klappen will.

DANKE NOCH MAL
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#19

Post by variousos » 24 Dec 2018 15:53

Hallo Zusammen,

nachdem die SD-Card von meinem Pi das zeitliche hinter sich gebracht hatte, habe ich die neue mit dem Raspbian installiert...danach Etherwake und dann nach:
sudo nano /etc /cronstab:
00 20 *** root /usr/sbin/etherwake 74:B8:73:CD:15
eingegeben.

Der Pi hat eine statische IP und ist mit dem Netzwerk verbunden. Er bekommt die richtige Zeit...aber das NAS will einfach nicht starten:-(

Hat jemand eine Idee?

Euch allen ein frohes Fest!!!
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#20

Post by Princo » 25 Dec 2018 21:36

variousos wrote:
24 Dec 2018 15:53

00 20 *** root /usr/sbin/etherwake 74:B8:73:CD:15
Deine MAC-Adresse ist unvollständig.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#21

Post by variousos » 30 Dec 2018 16:52

@Princo,

guten Abend...sorry, dass war allerdings nur ein Fehler beim aufzeigen hier im Forum. In Cronstab steht die richtige...habe ich ein dutzend mal mir angesehen...
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#22

Post by Princo » 31 Dec 2018 18:36

variousos wrote:
24 Dec 2018 15:53
sudo nano /etc /cronstab:
Die Datei heißt /etc/crontab

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#23

Post by variousos » 01 Jan 2019 19:21

OHH....sorry...da habe ich ein "s" einschleichen lassen. Das kann ja dann nicht funktionieren.

LIEBEN DANK DAFÜR
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#24

Post by variousos » 01 Jan 2019 22:43

Hallo Zusammen,

bevor ich mit um das Problem, dass der NAS-Server nicht durch die crontab startet (denn das tut er immer noch nicht) kümmere, hier kurz die Frage, warum der Server nach dem ausschalten immer wieder bootet...?

DANKE für die Hilfe
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#25

Post by Princo » 02 Jan 2019 06:38

In Network|LAN Management muß die Einstellung "Wake On LAN" auf "WOL_MAGIC" gesetzt sein.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#26

Post by variousos » 02 Jan 2019 19:30

Hallo und guten Abend Princo,

danke...damit startet das System schon mal nicht ständig:-)

Einzig...es startet immer noch nicht per WOL und Etherwake. Seltsam ist, dass ein "ifconfig" beim Pi mir eine andere MAC nennt, als es der Advanced IP Scanner tut....s. Attachments.
Bildschirmfoto 2019-01-02 um 19.21.24.png
Bildschirmfoto 2019-01-02 um 19.20.05.png
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#27

Post by Princo » 02 Jan 2019 21:52

Gib doch auf dem Raspberry einfach mal

Code: Select all

sudo /usr/sbin/etherwake BC:AE:C5:4F:8C:51
ein, wenn dein NAS heruntergefahren ist.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#28

Post by variousos » 03 Jan 2019 18:36

N´abend Princo,

das NAS startet dann sofort! Ich habe wiederholt in die Datei eingegeben:

40 18 * * * root /usr/sbin/etherwake BC:AE:C5:4F:8C:51

Die Zwischenräume immer nur mit einer Leertaste...! Es passiert nichts!!
Es kann dann doch nur an einer Kleinigkeit liegen. Wenigstens meinem Vernehmen nach...
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

User avatar
Princo
Forum Moderator
Forum Moderator
Posts: 1081
Joined: 15 Jul 2012 01:21
Location: Berlin, Germany
Status: Offline

Re: automatisches starten

#29

Post by Princo » 03 Jan 2019 23:00

Die Kleinigkeit gibt es tatsächlich:

Die /etc/crontab muß mit einer Leerzeile enden.

Einfach nach der MAC-Adresse einmal Return drücken und abspeichern.

Grüße
Princo
Meine Antworten beziehen sich immer auf die englischsprachige GUI. ECC-RAM ist Pflicht beim Einsatz von ZFS.

variousos
Advanced User
Advanced User
Posts: 164
Joined: 23 Jun 2015 19:37
Status: Offline

Re: automatisches starten

#30

Post by variousos » 05 Jan 2019 11:51

Guten Morgen Princo,

erst einmal vielen Dank für den Tipp!
Bei dem von Dir aufgezeigten Procedere startete das NAS wie bereits erwähnt ja sofort. Aber auch mit dem Return war das nicht möglich :roll: Ich habe noch einmal nachgesehen ob das Datum/Zeit am NAS als auch am Raspberry stimmen. Alles gut! Fällt sonst noch etwas auf (s.Screenshot). Oder sollte ich Raspbian und Etherwake neu installieren?
Bildschirmfoto 2019-01-05 um 11.49.11.png
XigmaNAS 11.2.0.4.6315, 19" 2HE, ASUS P7F-M Board, Xenon 3450 CPU, 16GB ECC-RAM DDR3, Dell H310 als HBA, 4 x 3TB WD RED

Post Reply

Return to “Deutsch”