*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Samba Verbindung auf neues Xigmanas nicht mehr möglich

German community

Moderators: b0ssman, apollo567, crowi, Princo

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Samba Verbindung auf neues Xigmanas nicht mehr möglich

#1

Post by mahlzeit » 05 Mar 2019 17:48

Hi Jungs

ich habe gerade ein zeitliches Problem, deswegen setze ich es hier noch ins Deutsche Forum rein.

Ich habe mir ein neues Xigmanas aufgenaut um das alte zu ersetzen.
Der Zugriff auf ein riesiges Verzeichniss wird immer zäher, deswegen besteht das neue NAS nur noch aus SSDs
Tests sind auch erfolgreich und der Zugriff ist Welten schneller.

Jetzt würde ich gerne auf den Server umstellen aber ich habe noch ein Problem mit einem Client.

Auf einem Rechner läuft noch eine alte Oracle Datenbank und der PC greift auf Samba Freigaben vom Server zu.
Bis jetzt kein Problem aber ich schaffe es auf Teufel komm raus nicht mich mit dem neuen Server zu verbinden.

Egal was ich teste - ich bekomme ein "mount error (13): permission denied"

Habe auch schon alles an min max SMB2 usw, in die smb.conf vom Client eingetragen - keine Chance
Ich verzweifel langsam - was übersehe ich denn...

Auf dem Client läuft Samba 3.6 und ich kann ihn nicht updaten.
Ich wollte ihn zwar auch demnächst frisch aufsetzen aber da fehlt mir gerade die Zeit.

Ein neues Ubuntu was ich zum Test von einer Live CD gestartet habe oder alle Windows Rechner die hier so rumstehen, verbinden sich einwandfrei.

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#2

Post by ms49434 » 05 Mar 2019 20:59

Dann lass doch mal testweise die SMB-Hose runter und konfiguriere auf der XigmaNAS-Box

Services > CIFS/SMB > Settings:
Server Max. Protocol: SMB3
Server Min. Protocol: NT1 (CIFS)
Client Max. Protocol: SMB3
Client Min. Protocol: NT1 (CIFS)
Log Level: Debug (nur zur Analyse, danach wieder ausschalten)

und zusätzlich unter Additional Parameters:
ntlm_auth = yes
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#3

Post by mahlzeit » 06 Mar 2019 00:25

Danke für deine Antwort

Die Parameter habe ich schon in zig Varianten gesetzt, habe aber alles wie gewünscht eingetragen (und wie erwartet keine Änderung).
Er sagt zwar laut Log, dass das Passwort nicht stimmt aber es stimmt 100pro - mehrmals gegengeprüft!
Es handelt sich um das aktuelle Xigmanas Release von letzter Woche.
Wusste nicht wie ich das Log File speichern soll, hoffe es passt so:

Code: Select all

smbd[7086]: [2019/03/05 23:11:26.055166, 4, pid=7086, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:486(ntlm_password_check)
smbd[7086]: ntlm_password_check: Checking LMv2 password with domain
smbd[7086]: [2019/03/05 23:11:26.055226, 4, pid=7086, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:515(ntlm_password_check)
smbd[7086]: ntlm_password_check: Checking LMv2 password with upper-cased version of domain
smbd[7086]: [2019/03/05 23:11:26.055269, 4, pid=7086, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:543(ntlm_password_check)
smbd[7086]: ntlm_password_check: Checking LMv2 password without a domain
smbd[7086]: [2019/03/05 23:11:26.055311, 4, pid=7086, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:574(ntlm_password_check)
smbd[7086]: ntlm_password_check: Checking NT MD4 password in LM field
smbd[7086]: [2019/03/05 23:11:26.055346, 3, pid=7086, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:595(ntlm_password_check)
smbd[7086]: ntlm_password_check: LM password and LMv2 failed for user dewald, and NT MD4 password in LM field not permitted
smbd[7086]: [2019/03/05 23:11:26.055383, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.055418, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.055451, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.055484, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.055515, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.055624, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.055661, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.055696, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.055728, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.055761, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.055791, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.055847, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.055882, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.055914, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.055946, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.055977, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.056085, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.056131, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.056199, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.056233, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.056265, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.056297, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.056331, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.056642, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/lib/substitute.c:435(automount_server)
smbd[7086]: Home server: lise-neu
smbd[7086]: [2019/03/05 23:11:26.056781, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/lib/substitute.c:435(automount_server)
smbd[7086]: Home server: lise-neu
smbd[7086]: [2019/03/05 23:11:26.056887, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.056922, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.056955, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.056988, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.057019, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.057134, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.057264, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.057299, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.057339, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.057372, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.057403, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.057512, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.057551, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
smbd[7086]: push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.057585, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:493(push_conn_ctx)
smbd[7086]: push_conn_ctx(0) : conn_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.057618, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 2
smbd[7086]: [2019/03/05 23:11:26.057651, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.057683, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.057792, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 1
smbd[7086]: [2019/03/05 23:11:26.057834, 5, pid=7086, effective(0, 0), real(0, 0), class=passdb] ../source3/passdb/pdb_tdb.c:813(tdb_update_samacct_only)
smbd[7086]: Storing account dewald with RID 1001
smbd[7086]: [2019/03/05 23:11:26.057872, 5, pid=7086, effective(0, 0), real(0, 0), class=locking] ../lib/dbwrap/dbwrap.c:133(dbwrap_lock_order_lock)
smbd[7086]: dbwrap_lock_order_lock: check lock order 1 for /var/etc/private/passdb.tdb
smbd[7086]: [2019/03/05 23:11:26.057974, 5, pid=7086, effective(0, 0), real(0, 0), class=locking] ../lib/dbwrap/dbwrap.c:162(dbwrap_lock_order_unlock)
smbd[7086]: dbwrap_lock_order_unlock: release lock order 1 for /var/etc/private/passdb.tdb
smbd[7086]: [2019/03/05 23:11:26.058046, 5, pid=7086, effective(0, 0), real(0, 0), class=locking] ../lib/dbwrap/dbwrap.c:133(dbwrap_lock_order_lock)
smbd[7086]: dbwrap_lock_order_lock: check lock order 1 for /var/etc/private/passdb.tdb
smbd[7086]: [2019/03/05 23:11:26.058123, 5, pid=7086, effective(0, 0), real(0, 0), class=locking] ../lib/dbwrap/dbwrap.c:162(dbwrap_lock_order_unlock)
smbd[7086]: dbwrap_lock_order_unlock: release lock order 1 for /var/etc/private/passdb.tdb
smbd[7086]: [2019/03/05 23:11:26.058181, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
smbd[7086]: pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.058221, 5, pid=7086, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:251(auth_check_ntlm_password)
smbd[7086]: auth_check_ntlm_password: sam_ignoredomain authentication for user [dewald] FAILED with error NT_STATUS_WRONG_PASSWORD, authoritative=1
smbd[7086]: [2019/03/05 23:11:26.058265, 2, pid=7086, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:332(auth_check_ntlm_password)
smbd[7086]: check_ntlm_password: Authentication for user [dewald] -> [dewald] FAILED with error NT_STATUS_WRONG_PASSWORD, authoritative=1
smbd[7086]: [2019/03/05 23:11:26.058330, 2, pid=7086, effective(0, 0), real(0, 0)] ../auth/auth_log.c:760(log_authentication_event_human_readable)
smbd[7086]: Auth: [SMB,(null)] user []\[dewald] at [Tue, 05 Mar 2019 23:11:26.058306 UTC] with [NTLMv1] status [NT_STATUS_WRONG_PASSWORD] workstation [192.168.111.112] remote host [ipv4:192.168.111.112:52444] mapped to []\[dewald]. local host [ipv4:192.168.111.110:445]
smbd[7086]: [2019/03/05 23:11:26.058934, 2, pid=7086, effective(0, 0), real(0, 0)] ../auth/auth_log.c:220(log_json)
smbd[7086]: JSON Authentication: {"timestamp": "2019-03-05T23:11:26.058662+0000", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 0}, "status": "NT_STATUS_WRONG_PASSWORD", "localAddress": "ipv4:192.168.111.110:445", "remoteAddress": "ipv4:192.168.111.112:52444", "serviceDescription": "SMB", "authDescription": null, "clientDomain": "", "clientAccount": "dewald", "workstation": "192.168.111.112", "becameAccount": null, "becameDomain": null, "becameSid": "(NULL SID)", "mappedAccount": "dewald", "mappedDomain": "", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": "(NULL SID)", "passwordType": "NTLMv1"}}
smbd[7086]: [2019/03/05 23:11:26.059005, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/auth_ntlmssp.c:196(auth3_check_password)
smbd[7086]: Checking NTLMSSP password for \dewald failed: NT_STATUS_WRONG_PASSWORD, authoritative=1
smbd[7086]: [2019/03/05 23:11:26.059049, 3, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/error.c:82(error_packet_set)
smbd[7086]: NT error packet at ../source3/smbd/sesssetup.c(955) cmd=115 (SMBsesssetupX) NT_STATUS_LOGON_FAILURE
smbd[7086]: [2019/03/05 23:11:26.059090, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/lib/util.c:184(show_msg)
smbd[7086]: [2019/03/05 23:11:26.059112, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/lib/util.c:194(show_msg)
smbd[7086]: size=35
smbd[7086]: smb_com=0x73
smbd[7086]: smb_rcls=109
smbd[7086]: smb_reh=0
smbd[7086]: smb_err=49152
smbd[7086]: smb_flg=128
smbd[7086]: smb_flg2=49155
smbd[7086]: smb_tid=0
smbd[7086]: smb_pid=8996
smbd[7086]: smb_uid=0
smbd[7086]: smb_mid=2
smbd[7086]: smt_wct=0
smbd[7086]: smb_bcc=0
smbd[7084]: [2019/03/05 23:11:26.086197, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/lib/util_sock.c:134(read_fd_with_timeout)
smbd[7084]: read_fd_with_timeout: blocking read. EOF from client.
smbd[7084]: [2019/03/05 23:11:26.086267, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/process.c:554(receive_smb_talloc)
smbd[7084]: receive_smb_raw_talloc failed for client ipv4:192.168.111.112:52440 read error = NT_STATUS_END_OF_FILE.
smbd[7084]: [2019/03/05 23:11:26.086342, 4, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7084]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7084]: [2019/03/05 23:11:26.086379, 5, pid=7084, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7084]: Security token: (NULL)
smbd[7084]: [2019/03/05 23:11:26.086413, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7084]: UNIX token of user 0
smbd[7084]: Primary group is 0 and contains 0 supplementary groups
smbd[7084]: [2019/03/05 23:11:26.086483, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7084]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7084]: [2019/03/05 23:11:26.086525, 4, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7084]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7084]: [2019/03/05 23:11:26.086557, 5, pid=7084, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7084]: Security token: (NULL)
smbd[7084]: [2019/03/05 23:11:26.086589, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7084]: UNIX token of user 0
smbd[7084]: Primary group is 0 and contains 0 supplementary groups
smbd[7084]: [2019/03/05 23:11:26.086643, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7084]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7084]: [2019/03/05 23:11:26.086681, 4, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7084]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7084]: [2019/03/05 23:11:26.086713, 5, pid=7084, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7084]: Security token: (NULL)
smbd[7084]: [2019/03/05 23:11:26.086744, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7084]: UNIX token of user 0
smbd[7084]: Primary group is 0 and contains 0 supplementary groups
smbd[7084]: [2019/03/05 23:11:26.086798, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7084]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7084]: [2019/03/05 23:11:26.086837, 4, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7084]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7084]: [2019/03/05 23:11:26.086869, 5, pid=7084, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7084]: Security token: (NULL)
smbd[7084]: [2019/03/05 23:11:26.086900, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7084]: UNIX token of user 0
smbd[7084]: Primary group is 0 and contains 0 supplementary groups
smbd[7084]: [2019/03/05 23:11:26.086954, 5, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7084]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7084]: [2019/03/05 23:11:26.088480, 3, pid=7084, effective(0, 0), real(0, 0)] ../source3/smbd/server_exit.c:236(exit_server_common)
smbd[7084]: Server exit (failed to receive smb request)
smbd[7085]: [2019/03/05 23:11:26.135911, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/lib/util_sock.c:134(read_fd_with_timeout)
smbd[7085]: read_fd_with_timeout: blocking read. EOF from client.
smbd[7085]: [2019/03/05 23:11:26.135955, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/process.c:554(receive_smb_talloc)
smbd[7085]: receive_smb_raw_talloc failed for client ipv4:192.168.111.112:52442 read error = NT_STATUS_END_OF_FILE.
smbd[7085]: [2019/03/05 23:11:26.136012, 4, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7085]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7085]: [2019/03/05 23:11:26.136025, 5, pid=7085, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7085]: Security token: (NULL)
smbd[7085]: [2019/03/05 23:11:26.136036, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7085]: UNIX token of user 0
smbd[7085]: Primary group is 0 and contains 0 supplementary groups
smbd[7085]: [2019/03/05 23:11:26.136079, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7085]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7085]: [2019/03/05 23:11:26.136094, 4, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7085]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7085]: [2019/03/05 23:11:26.136104, 5, pid=7085, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7085]: Security token: (NULL)
smbd[7085]: [2019/03/05 23:11:26.136113, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7085]: UNIX token of user 0
smbd[7085]: Primary group is 0 and contains 0 supplementary groups
smbd[7085]: [2019/03/05 23:11:26.136130, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7085]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7085]: [2019/03/05 23:11:26.136141, 4, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7085]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7085]: [2019/03/05 23:11:26.136151, 5, pid=7085, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7085]: Security token: (NULL)
smbd[7085]: [2019/03/05 23:11:26.136160, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7085]: UNIX token of user 0
smbd[7085]: Primary group is 0 and contains 0 supplementary groups
smbd[7085]: [2019/03/05 23:11:26.136176, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7085]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7085]: [2019/03/05 23:11:26.136189, 4, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7085]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7085]: [2019/03/05 23:11:26.136198, 5, pid=7085, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7085]: Security token: (NULL)
smbd[7085]: [2019/03/05 23:11:26.136207, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7085]: UNIX token of user 0
smbd[7085]: Primary group is 0 and contains 0 supplementary groups
smbd[7085]: [2019/03/05 23:11:26.136223, 5, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7085]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7085]: [2019/03/05 23:11:26.136799, 3, pid=7085, effective(0, 0), real(0, 0)] ../source3/smbd/server_exit.c:236(exit_server_common)
smbd[7085]: Server exit (failed to receive smb request)
smbd[7086]: [2019/03/05 23:11:26.186131, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/lib/util_sock.c:134(read_fd_with_timeout)
smbd[7086]: read_fd_with_timeout: blocking read. EOF from client.
smbd[7086]: [2019/03/05 23:11:26.186201, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/process.c:554(receive_smb_talloc)
smbd[7086]: receive_smb_raw_talloc failed for client ipv4:192.168.111.112:52444 read error = NT_STATUS_END_OF_FILE.
smbd[7086]: [2019/03/05 23:11:26.186259, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.186273, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.186284, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.186309, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7086]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7086]: [2019/03/05 23:11:26.186338, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.186348, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.186358, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.186387, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7086]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7086]: [2019/03/05 23:11:26.186398, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.186407, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.186417, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.186432, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7086]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7086]: [2019/03/05 23:11:26.186444, 4, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:320(set_sec_ctx_internal)
smbd[7086]: setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
smbd[7086]: [2019/03/05 23:11:26.186454, 5, pid=7086, effective(0, 0), real(0, 0)] ../libcli/security/security_token.c:53(security_token_debug)
smbd[7086]: Security token: (NULL)
smbd[7086]: [2019/03/05 23:11:26.186463, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/auth/token_util.c:810(debug_unix_user_token)
smbd[7086]: UNIX token of user 0
smbd[7086]: Primary group is 0 and contains 0 supplementary groups
smbd[7086]: [2019/03/05 23:11:26.186479, 5, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/uid.c:427(smbd_change_to_root_user)
smbd[7086]: change_to_root_user: now uid=(0,0) gid=(0,0)
smbd[7086]: [2019/03/05 23:11:26.187091, 3, pid=7086, effective(0, 0), real(0, 0)] ../source3/smbd/server_exit.c:236(exit_server_common)
smbd[7086]: Server exit (failed to receive smb request)
nmbd[7063]: [2019/03/05 23:11:28.509057, 4, pid=7063, effective(0, 0), real(0, 0)] ../source3/nmbd/nmbd_workgroupdb.c:165(find_workgroup_on_subnet)
nmbd[7063]: find_workgroup_on_subnet: workgroup search for KUNST on subnet 192.168.111.110: found.
nmbd[7063]: [2019/03/05 23:11:28.509118, 4, pid=7063, effective(0, 0), real(0, 0)] ../source3/nmbd/nmbd_workgroupdb.c:276(dump_workgroups)
nmbd[7063]: dump_workgroups()
nmbd[7063]: dump workgroup on subnet 192.168.111.110: netmask= 255.255.255.0:
nmbd[7063]: KUNST(1) current master browser = UNKNOWN
nmbd[7063]: LISE-NEU 40809a03 (Samba 4.8.9)

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#4

Post by ms49434 » 06 Mar 2019 01:18

Ich glaube da hab ich im letzten Posting verschrieben, versuche es mal mit

ntlm auth = yes (diesmal ohne Unterstrich)

Dein Client will tatsächlich mit NTLMv1 authentifizieren ( => "passwordType": "NTLMv1"), dass ist aber seit geraumer Zeit und einigen Samba Releases standardmäßig deaktiviert.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#5

Post by mahlzeit » 06 Mar 2019 10:44

Super - vielen Dank
Das wars, jetzt klappt die Verbindung

Komisch, dachte eigentlich Samba 3.6 unterstützt SMB2 aber egal wie, ich konnte es nicht dazu "zwingen"

mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#6

Post by mahlzeit » 08 Mar 2019 14:50

Eine Frage noch, wobei ich nicht glaube, dass es lösbar ist.

Ich habe noch eine alte Werkzeugmaschine auf der Win CE 4.2 Net Pro läuft.
Alle anderen Maschinen verbinden sich sauber per SMB oder NFS auf den Server, nur diese eben nicht.

Nach etwas googeln gibt es wohl probleme mit dem Win CE aber eine wirkliche Lösung habe ich auch nicht gefunden.
Auf der Maschine kommt nur "Login failed" egal was ich eingebe und wie locker ich die Freigaben mache (auch als Guest usw.)

Im Log kommt auf den ersten Blick auch nur:

Code: Select all

Mar 8 13:38:38	lise	smbd[33200]: check_ntlm_password: Authentication for user [makino] -> [makino] FAILED with error NT_STATUS_WRONG_PASSWORD, authoritative=1
Mar 8 13:38:38	lise	smbd[33200]: [2019/03/08 13:38:38.321348, 2] ../auth/auth_log.c:760(log_authentication_event_human_readable)
Mar 8 13:38:38	lise	smbd[33200]: Auth: [SMB,(null)] user [kunst]\[makino] at [Fri, 08 Mar 2019 13:38:38.321308 UTC] with [LANMan] status [NT_STATUS_WRONG_PASSWORD] workstation [] remote host [ipv4:192.168.111.156:1056] mapped to [kunst]\[makino]. local host [ipv4:192.168.111.110:139]
Mar 8 13:38:38	lise	smbd[33200]: [2019/03/08 13:38:38.321593, 2] ../auth/auth_log.c:220(log_json)
Mar 8 13:38:38	lise	smbd[33200]: JSON Authentication: {"timestamp": "2019-03-08T13:38:38.321428+0000", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 0}, "status": "NT_STATUS_WRONG_PASSWORD", "localAddress": "ipv4:192.168.111.110:139", "remoteAddress": "ipv4:192.168.111.156:1056", "serviceDescription": "SMB", "authDescription": null, "clientDomain": "kunst", "clientAccount": "makino", "workstation": "", "becameAccount": null, "becameDomain": null, "becameSid": "(NULL SID)", "mappedAccount": "makino", "mappedDomain": "kunst", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": "(NULL SID)", "passwordType": "LANMan"}}
Manche hatten wohl scheinbar mit

client use spnego = no
client ntlmv2 auth = no

in der SMB.conf erfolg aber da hatte ich auch keinen Erfolg...

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#7

Post by ms49434 » 08 Mar 2019 15:04

mahlzeit wrote:
08 Mar 2019 14:50
Eine Frage noch, wobei ich nicht glaube, dass es lösbar ist.

Ich habe noch eine alte Werkzeugmaschine auf der Win CE 4.2 Net Pro läuft.
Alle anderen Maschinen verbinden sich sauber per SMB oder NFS auf den Server, nur diese eben nicht.

Nach etwas googeln gibt es wohl probleme mit dem Win CE aber eine wirkliche Lösung habe ich auch nicht gefunden.
Auf der Maschine kommt nur "Login failed" egal was ich eingebe und wie locker ich die Freigaben mache (auch als Guest usw.)

Im Log kommt auf den ersten Blick auch nur:

Manche hatten wohl scheinbar mit

client use spnego = no
client ntlmv2 auth = no

in der SMB.conf erfolg aber da hatte ich auch keinen Erfolg...
das Teil will mit LANMan authentifizieren und Dein Server ist ja eh schon nicht mehr sicher wg. NTLM, dann probiere doch mal

Code: Select all

lanman auth = yes
ntlm auth = yes
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#8

Post by mahlzeit » 13 Mar 2019 00:50

Konnte die letzten Tage zeitlich nicht an dem Problem weitermachen aber danke nochmal für deine Hilfe.
Leider hat es nicht geklappt.

Der Server ist von außen nicht erreichbar und ich versuche über kurz oder lang auf neue Systeme umzuschwenken bzw. kann ich bei der Maschine gegen Aufpreis einen FTP Zugang installieren.

Derzeit wäre es aber gut wenn es gehen würde, ansonsten muss ich sonst die ganze Zeit mit einem USB Stick hin und her rennen.

Vielleicht hilft ja nochmal ein Blick aufs Log oder soll ich nochmal den Debug einschalten?

Code: Select all

Mar 12 23:41:19	lise	smbd[69128]: check_ntlm_password: Authentication for user [makino] -> [makino] FAILED with error NT_STATUS_WRONG_PASSWORD, authoritative=1
Mar 12 23:41:19	lise	smbd[69128]: [2019/03/12 23:41:19.928271, 2] ../auth/auth_log.c:760(log_authentication_event_human_readable)
Mar 12 23:41:19	lise	smbd[69128]: Auth: [SMB,(null)] user [KUNST]\[makino] at [Tue, 12 Mar 2019 23:41:19.928263 UTC] with [LANMan] status [NT_STATUS_WRONG_PASSWORD] workstation [] remote host [ipv4:192.168.111.156:1061] mapped to [KUNST]\[makino]. local host [ipv4:192.168.111.110:139]
Mar 12 23:41:19	lise	smbd[69128]: [2019/03/12 23:41:19.928320, 2] ../auth/auth_log.c:220(log_json)
Mar 12 23:41:19	lise	smbd[69128]: JSON Authentication: {"timestamp": "2019-03-12T23:41:19.928286+0000", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 0}, "status": "NT_STATUS_WRONG_PASSWORD", "localAddress": "ipv4:192.168.111.110:139", "remoteAddress": "ipv4:192.168.111.156:1061", "serviceDescription": "SMB", "authDescription": null, "clientDomain": "KUNST", "clientAccount": "makino", "workstation": "", "becameAccount": null, "becameDomain": null, "becameSid": "(NULL SID)", "mappedAccount": "dewald", "mappedDomain": "KUNST", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": "(NULL SID)", "passwordType": "LANMan"}}

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#9

Post by ms49434 » 13 Mar 2019 02:31

mahlzeit wrote:
13 Mar 2019 00:50
Konnte die letzten Tage zeitlich nicht an dem Problem weitermachen aber danke nochmal für deine Hilfe.
Leider hat es nicht geklappt.

Der Server ist von außen nicht erreichbar und ich versuche über kurz oder lang auf neue Systeme umzuschwenken bzw. kann ich bei der Maschine gegen Aufpreis einen FTP Zugang installieren.

Derzeit wäre es aber gut wenn es gehen würde, ansonsten muss ich sonst die ganze Zeit mit einem USB Stick hin und her rennen.

Vielleicht hilft ja nochmal ein Blick aufs Log oder soll ich nochmal den Debug einschalten?

Code: Select all

Mar 12 23:41:19	lise	smbd[69128]: check_ntlm_password: Authentication for user [makino] -> [makino] FAILED with error NT_STATUS_WRONG_PASSWORD, authoritative=1
Mar 12 23:41:19	lise	smbd[69128]: [2019/03/12 23:41:19.928271, 2] ../auth/auth_log.c:760(log_authentication_event_human_readable)
Mar 12 23:41:19	lise	smbd[69128]: Auth: [SMB,(null)] user [KUNST]\[makino] at [Tue, 12 Mar 2019 23:41:19.928263 UTC] with [LANMan] status [NT_STATUS_WRONG_PASSWORD] workstation [] remote host [ipv4:192.168.111.156:1061] mapped to [KUNST]\[makino]. local host [ipv4:192.168.111.110:139]
Mar 12 23:41:19	lise	smbd[69128]: [2019/03/12 23:41:19.928320, 2] ../auth/auth_log.c:220(log_json)
Mar 12 23:41:19	lise	smbd[69128]: JSON Authentication: {"timestamp": "2019-03-12T23:41:19.928286+0000", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 0}, "status": "NT_STATUS_WRONG_PASSWORD", "localAddress": "ipv4:192.168.111.110:139", "remoteAddress": "ipv4:192.168.111.156:1061", "serviceDescription": "SMB", "authDescription": null, "clientDomain": "KUNST", "clientAccount": "makino", "workstation": "", "becameAccount": null, "becameDomain": null, "becameSid": "(NULL SID)", "mappedAccount": "dewald", "mappedDomain": "KUNST", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": "(NULL SID)", "passwordType": "LANMan"}}
XigmaNAS speichert, wenn möglich, nur die MD4/SHA1 Hash-Werte der Benutzerpasswörter in der Konfigurationsdatei. Mit diesen Hashes wird beim Systemstart die Benutzerdatenbank aufgebaut. Der LANMan Hash wird aus Sicherheitsgründen nicht gespeichert, da sich daraus das Originalpasswort berechnen läßt.
Der Eintrag für Benutzer makino sieht nach dem Systemstart so aus:

Code: Select all

xigmanas: ~# pdbedit -L -w makino
makino:1006:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:457E8981B24C9183580320701DE459DF:[U          ]:LCT-5C8859DA:
Der dritte Parameter enthält den LANMan Hash, der besteht hier aber nur aus 32 schicken X, ist also nicht vorhanden. Daher schlägt auch die Authentifizierung fehl.
Du mußt nach dem Systemstart das Passwort über das Programm smbpasswd erneut setzen, um auch den LANMan Hash zu erzeugen (wenn lanman auth = yes gesetzt ist).

Code: Select all

smbpasswd makino
Danach sieht der Benutzereintrag wie folgt aus:

Code: Select all

xigmanas: ~# pdbedit -L -w makino
makino:1006:CB57B0D352B19A1AAAD3B435B51404EE:457E8981B24C9183580320701DE459DF:[U          ]:LCT-5C885B47:
Jetzt sollte sich Deine Maschine verbinden können.
Du mußt den LANMan Hash bei jedem Systemstart neu setzten, aber dass kannst Du ja ein Script erledigen lassen. Eine Änderung in der SMB Konfiguration kann auch die Benutzerdatenbank zurücksetzen, auch hier muß dann der LANMan Hash neu gesetzt werden.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#10

Post by mahlzeit » 13 Mar 2019 11:12

Du bist einfach gut :)
Es klappt jetzt!

Hab jetzt mal ein Script in der Preinit:
"printf "%s\n%s\n" passwort passwort| smbpasswd -s makino"

Im Terminal klappt das schonmal, beim nächsten Neustart dann nochmal prüfen.

Natürlich sicherheitstechnisch ein "Desaster" aber in dem freigegeben Verzeichnis für User makino befinden sich ausschließlich die generierten Maschinenprogramme die wöchentlich gelöscht werden, damit der Ordner übersichtlich bleibt.

mahlzeit
Starter
Starter
Posts: 44
Joined: 23 Oct 2012 19:02
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#11

Post by mahlzeit » 21 Mar 2019 11:01

Hm, irgendwie hab ich mich wohl vertan. Nach einem Neustart klappt das doch nicht und ich habe auch sonst keine Lösung gefunden.
Hat jemand eine Idee, wie ich das Passwort beim booten setzen kann?

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#12

Post by ms49434 » 21 Mar 2019 12:23

mahlzeit wrote:
21 Mar 2019 11:01
Hm, irgendwie hab ich mich wohl vertan. Nach einem Neustart klappt das doch nicht und ich habe auch sonst keine Lösung gefunden.
Hat jemand eine Idee, wie ich das Passwort beim booten setzen kann?
PreInit ist zu früh, bitte auf PostInit setzen.

folgender Befehl könnte funktionieren, hab's aber nicht getestet:

Code: Select all

( /bin/echo "password" ; /bin/echo "password" ) | /usr/local/bin/smbpasswd -s makino
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

tongatahu
NewUser
NewUser
Posts: 4
Joined: 05 Mar 2017 10:18
Status: Offline

Re: Samba Verbindung auf neues Xigmanas nicht mehr möglich

#13

Post by tongatahu » 16 Apr 2019 09:16

Hallo miteinander,

ich hatte das gleiche(?) Problem:
Umstellung von nasf4free auf xigmanas -> ging problemlos. Zugang zum NAS vom Linux-Client (kein Problem). Zugang von 2 Win 10 Virtualbox-Clients -> kein Problem. Zugang vom Win 10 Client meiner Frau -> war nicht möglich. (Win 10 sagte: Falsche Zugangsdaten, Fehler 86...). Ich habe einen Tag daran gearbeitet, bis ich dieses fand:
ms49434 wrote:
06 Mar 2019 01:18
Ich glaube da hab ich im letzten Posting verschrieben, versuche es mal mit

ntlm auth = yes (diesmal ohne Unterstrich)

Dein Client will tatsächlich mit NTLMv1 authentifizieren ( => "passwordType": "NTLMv1"), dass ist aber seit geraumer Zeit und einigen Samba Releases standardmäßig deaktiviert.
Der Eintrag
ms49434 wrote:
06 Mar 2019 01:18

ntlm auth = yes (diesmal ohne Unterstrich)
hat es gerichtet.

Vielen Dank!

Post Reply

Return to “Deutsch”