*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

Stream media from NAS4Free using iTunes/DAAP protocols.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
marcusman
NewUser
NewUser
Posts: 5
Joined: 20 Nov 2012 19:01
Status: Offline

Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#1

Post by marcusman » 18 Feb 2013 19:43

Hello:

I can't seem to get iTunes 11.0.1 on my MBP to connect to my DAAP service running on Nas4free. This used to work just fine. I'm not sure why its not working anymore and I'm wondering if anyone else is having this issue?

-Thanks

Jaslo581
NewUser
NewUser
Posts: 11
Joined: 23 Jun 2012 07:05
Location: New York
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#2

Post by Jaslo581 » 19 Feb 2013 19:37

For some reason Bonjour service is disabled in Firefly Media Server.
Cant get it enabled in GUI.

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#3

Post by pierouelle » 19 Feb 2013 22:54

have you check in system, advanced to see if Enable Zeroconf/Bonjour.

marcusman
NewUser
NewUser
Posts: 5
Joined: 20 Nov 2012 19:01
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#4

Post by marcusman » 21 Feb 2013 21:28

Yes, Bonjour is enabled. I see Apple just released a new version of iTunes. I'll download it and try it out.

Ov10fac
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#5

Post by Ov10fac » 15 Oct 2013 23:32

Did you ever resolve this issue. I am having a similar problem.

Jaslo581
NewUser
NewUser
Posts: 11
Joined: 23 Jun 2012 07:05
Location: New York
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#6

Post by Jaslo581 » 05 Feb 2014 23:14

got the same problem with NAS4Free-9.2.0.1 / 9.2.0.1.943.Just not showing in Itunes.
Everything was ok in NAS4Free-9.1.0.1 / 9.1.0.1.847.
After upgrading and importing /restoring the configuration - no go.
Bonjur is enabled.

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#7

Post by pierouelle » 06 Feb 2014 13:32

Jaslo581 wrote:got the same problem with NAS4Free-9.2.0.1 / 9.2.0.1.943.Just not showing in Itunes.
Everything was ok in NAS4Free-9.1.0.1 / 9.1.0.1.847.
After upgrading and importing /restoring the configuration - no go.
Bonjur is enabled.
Same here :( with .943

jj69
NewUser
NewUser
Posts: 6
Joined: 06 Feb 2014 10:46
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#8

Post by jj69 » 07 Feb 2014 09:18

NAS4Free 9.2.0.1.943 here.
I found that the mdnsresponder (aka Bonjour) is all screwed-up once you enable AFP service on the latest version.
Basically, it will not adverstize services past http(s) configuration page and AFP shares.

If you enabled AFP, could you try disabling it for the sake of verification ?
Also, if you're a Mac user, there's a small utility called 'Bonjour browser' that will list all Bonjour services available, it proved usefull to me.

Jaslo581
NewUser
NewUser
Posts: 11
Joined: 23 Jun 2012 07:05
Location: New York
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#9

Post by Jaslo581 » 07 Feb 2014 21:55

AFP is not enabled on my server.
Only CIFS/samba and iTunes/DAAP.

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#10

Post by pierouelle » 07 Feb 2014 23:05

Jaslo581 wrote:AFP is not enabled on my server.
Only CIFS/samba and iTunes/DAAP.
Same here... :o

Jaslo581
NewUser
NewUser
Posts: 11
Joined: 23 Jun 2012 07:05
Location: New York
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#11

Post by Jaslo581 » 08 Feb 2014 22:00

switched to xpenology.com,hacked synology os.Everything works ,providing you have right hardware.

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#12

Post by pierouelle » 09 Feb 2014 14:19

I think they are aware of the problem and hopefully will be fix next release have a look viewtopic.php?f=78&t=5890&start=25

jj69
NewUser
NewUser
Posts: 6
Joined: 06 Feb 2014 10:46
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#13

Post by jj69 » 12 Feb 2014 22:13

Based on trial/error, I reordered the items in mdnsresponder.conf.
ATM, I've got AFP, DAAP, NFS and SSH advertized correctly.
The problem is the solution involves quite some work to 'survive' reboot.

I'll share if you absolutely need it, but I really hope they fix the mdns issue in the next release.

Going the xpenology way is not for the faint hearted IMO.
I would not entrust my personal data to a hacked system (I know about those, I'm writing these words on my Hackintosh ;) )

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#14

Post by pierouelle » 13 Feb 2014 13:15

jj69 if you do not ming sharing, cause i am using daap for my music library especialy over the network.
IMHO they will fix in next release, when only god knows...:-)

jj69
NewUser
NewUser
Posts: 6
Joined: 06 Feb 2014 10:46
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#15

Post by jj69 » 14 Feb 2014 11:16

Since pierouelle asks, here's what I did:

0) Caveats
- This applies to embedded install (full install would be easier)
- Shell commands are involved.
- I'm not responsible for your messing your system during the process, the change is rather
harmless and easily revertible, nevertheless, running a root shell never insignificant.
- The solution is not guarantied to work. It may depend on the services you activated.

1) What we'll do.
We need to fix the order of the services appearing in *msdnsresponder.conf*
My experience is that records pertaining to AFP should be at the end of the file
but your mileage may vary. Be prepared to twik the structure by yourself.
Working with an embedded system, any modification made directly to *msdnsresponder.conf*
would *not* survive reboot. Moreover, the *msdnsresponder.conf* is actually regenerated from
other configuration files at reboot time and each time a change is made in a service with GUI.
This includes: enabling a service, adding a share and many other cases.
What needs be done is actually changing template used by the regeneration process.
This regeneration process is done in the very same rc script that allows to start
mdnsresponder demon (/etc/rc.d/msdnsresponder) and this file will *not* persist after reboot.

So basically, we create a *msdnsresponder* rc script that fits our needs, somewhere on the
filesystem where it will persist after reboot then create a startup script (again on persistent
storage) that will replace the broken mdnsreponder rc script at each reboot.

If you understood but nothing of what I just explained, stay away from this guide & wait for an offical fix

2) How we do it.
When shell command are involved, I always choose to SSH directly on the NAS.
You could run the commands form WebUI if you like.
All shell command run as root (su if necessary)

a) Getting a copy of mdnsresponder rc script to work with
Choose a persistant folder somewhere on yout filesystem to host the files.
Mine is in /mnt/Apps/users/chris/

Copy the current mdnsresponder rc script to this folder

Code: Select all

cp /etc/rc.d/mdnsresponder /mnt/Apps/users/chris/
b) Edit the copy of mdnsresponder rc script
You should use the WebUI for that: Advance->File editor
Load the copy in the editor.
The begining of the file shouldn't be changed and has been striped off.
see:
Image 135.png
You want to relocate the red sections at the bottom of the file just before the line:

Code: Select all

${configxml_file} | /usr/local/bin/xml unesc >> ${mdnsresponder_config}
In the end, the file should look like this :
Image 136.png
Save the edited file.

c) create the startup script
In the same folder you copied mdnsresponder rc script, create a new file

Code: Select all

touch /mnt/Apps/users/chris/bonjourfix
The edit this file with WebUI. File should be empty.
Copy/past the lines :

Code: Select all

#!/bin/sh
mv /etc/rc.d/mdnsresponder mdnsresponder.broken
cp /mnt/Apps/users/chris/mdnsresponder /etc/rc.d/
/etc/rc.d/mdnsresponder restart
/!\ You will have to fix the source file path in the cp command

Save the edited file.

d) adjust permissions
Both the files we edited should be owned by root:wheel and made executable.
To achieve this from shell:

Code: Select all

chown root:wheel /mnt/Apps/users/chris/mdnsresponder /mnt/Apps/users/chris/bonjourfix
chmod a+x /mnt/Apps/users/chris/mdnsresponder /mnt/Apps/users/chris/bonjourfix
/!\ Obviously, you have to change the file paths to yours.

e) try the fix
From shell, simply run the bonjourfix script

Code: Select all

/mnt/Apps/users/chris/bonjourfix
mdnsresponder will restart.

Hopefully, you will see some change when browsing bonjour services from your computer.

There are several utilities out there that are able to list all advertied services on a network. There's even an iOS app that does just that.

f) Install the fix as a startup script
When happy with your fix, install it as a startup script.
In WebUI go to System | Advance | Command scripts:
Add a new script:
Command to be executed :

Code: Select all

/bin/sh /mnt/Apps/users/chris/bonjourfix
/!\ Change path accordingly

Script type is PostInit

g) Done !
At laong last ;)

Appendix:
Should you want to revert the fix: simply remove the startup script & reboot the NAS
You do not have the required permissions to view the files attached to this post.

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#16

Post by pierouelle » 14 Feb 2014 13:42

Thanks jj69 i will try it over the week end and let you know how it goes, have a great day and thanks again for sharing your knowledge,,,:-)

Jaslo581
NewUser
NewUser
Posts: 11
Joined: 23 Jun 2012 07:05
Location: New York
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#17

Post by Jaslo581 » 01 May 2014 21:46

is the Bonjur -DAAP problem has been fixed in latest 9.2.0.1.972 version? Does anybody know?

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#18

Post by pierouelle » 02 May 2014 00:21

no it is not, hopefully next one

Jaslo581
NewUser
NewUser
Posts: 11
Joined: 23 Jun 2012 07:05
Location: New York
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#19

Post by Jaslo581 » 02 May 2014 02:32

looks like it is fixed

Fixes: - Fix mDNSResponder start

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#20

Post by pierouelle » 02 May 2014 14:18

Jaslo581 wrote:looks like it is fixed

Fixes: - Fix mDNSResponder start
This may be fix but, ITUNES/DAAP services still not appear in ITunes since version .847 on my side anyway.
I test version .847 in a virtual box and that version is beeing seen in ITunes not the latest ones.

kenZ71
Advanced User
Advanced User
Posts: 403
Joined: 27 Jun 2012 20:18
Location: Northeast, USA
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#21

Post by kenZ71 » 05 May 2014 19:22

I must be missing something. What does the itunes / daap service do? It seems just as easy to load the music from a share to itunes, Rhythmbox or whatever client your using for music.
11.2-RELEASE-p3 | ZFS Mirror - 2 x 8TB WD Red | 28GB ECC Ram
HP ML10v2 x64-embedded on Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz

Extra memory so I can host a couple VMs
1) Unifi Controller on Ubuntu
2) Librenms on Ubuntu

Enter_Untyl
NewUser
NewUser
Posts: 6
Joined: 13 Jul 2014 21:54
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#22

Post by Enter_Untyl » 20 Jul 2014 22:55

I have mount a NAS with NAS4Free 9.2.0.1 - Shigawire (revision 972).

The first day I tried the DAAP service, it was see in ITunes in (windows and Mac OSx)...
But few days later, there was no share library view in iTunes (all system).

The service Bonjour seem disabled in FireFly...

I think the problem is always there...
But I can see the Image that jj69 post in is message (I got the message : "Image corrupt")

Can someone help me ?
NAS4Free 9.2.0.1 - Shigawire (revision 972), x64-embedded sur Intel(R) Atom(TM) CPU D425 @ 1.80GHz
NAS home made :
- ]Slim case Advance 3908B - 60W
- Motherboard ASUSTeK AT4NM10T-I, RAM 4Go, 4 ports SATA 3Gb/s
- 2 hard drives Hitachi 5K1000 1Terra - ZFS Mirror

jlb0305
NewUser
NewUser
Posts: 2
Joined: 27 Sep 2014 13:42
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#23

Post by jlb0305 » 27 Sep 2014 14:42

not working with recent itunes versions still and I can't implement the fix above because the .png images say they aren't valid files anymore. 1st won't even download and second won't open.

jlb0305
NewUser
NewUser
Posts: 2
Joined: 27 Sep 2014 13:42
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#24

Post by jlb0305 » 20 Oct 2014 02:04

Found that fork-daapd split may still work with itunes 11. It is still under current development and last update was a week ago. Issue is you have a full BSD install (jail or other), download and compile it, then make a jail for the forked-daapd to run in.

Still working on doing all that...

zakroma
Starter
Starter
Posts: 22
Joined: 26 Jun 2012 07:43
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#25

Post by zakroma » 18 Mar 2015 10:12

Where did you get the info that forked-daapd is still being worked on?
https://github.com/jasonmc/forked-daapd says that last commit was in 2012 :<

kounch
NewUser
NewUser
Posts: 1
Joined: 09 Aug 2015 20:11
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#26

Post by kounch » 09 Aug 2015 20:20

This one is still being worked on

https://github.com/ejurgensen/forked-daapd

dyshie
NewUser
NewUser
Posts: 1
Joined: 16 Mar 2015 06:49
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#27

Post by dyshie » 04 Sep 2015 11:00

thanks jj69

but I can't I see the Image that jj69 post in is message,also

Can someone help me ?

sheldar
NewUser
NewUser
Posts: 7
Joined: 24 Nov 2015 23:43
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#28

Post by sheldar » 19 Dec 2015 16:19

I am trying to follow these instructions but was unable to see the two .png files (they came thru as corrupted.) Thus I cannot determine which lines in the mdnsresponder file need to be moved. I looked for information on how to read the XML portion of the file but was unable to find anything.

Any suggestions?

michael-vs-N4F
NewUser
NewUser
Posts: 4
Joined: 18 Oct 2015 21:10
Status: Offline

Re: Problem with iTunes 11.0.1 and Nas4free 9.1.0.1 (636)

#29

Post by michael-vs-N4F » 24 Jan 2016 22:32

Dead-end!
Keeping ignorance alive with misinformation and ambiguity is not uncommon;
in many fora, it's the preferred method.

Post Reply

Return to “iTunes/DAAP”