*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Quelle Version Choisir

French community

Moderators: mtiburs, velivole18, ernie

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
CorbeilleNews
Advanced User
Advanced User
Posts: 261
Joined: 04 Jul 2012 20:40
Status: Offline

Quelle Version Choisir

#1

Post by CorbeilleNews »

Bonjour,

Je reviens vers vous car j'aimerais refaire une nouvelle machine

Dans un précedent sujet, j'avais évoqué que les versions récentes de XigmaNAS (et peut être certaines dernières de NAS4Free) faisaient "perdre plus de place dans le Pool" que les anciennes : un upgrade du NAS puis de ZFS (d'une 9.2.0.1 à une 12.0.0.4 puis 12.1.0.4 m'avais obligé à supprimer plus de 2 To (en 9.2.0.1 le pool était presque plein) pour me réapproprier les droits de modification des fichiers/dossier (confirmé sur d'autres NAS et un chmod n'avait rien changé, par contre possible de supprimer des fichiers/dossiers) et impossible de lui remettre ces fichiers/dossiers après upgrade.

On se retrouve avec un déchet d'espace disque de 2-2.5 To non exploitable. Même si le WebGUI dit qu'il reste plus de 2 To inutilisé, imposible d'ajouter des fichiers au dela !!!

Du coup j'ai envisagé de ne plus utiliser que des 9.2.0.1 qui me permettraient d'exploiter au quasi maximum la taille des Pools car 2 à 2.5 To pour chaque NAS çà commence à faire ...

J'ai donc configuré une clé en 9.2.0.1 mais je n'arrive pas à la faire booter jusqu'au bout sur une machine à base de i7 6700 alors qu'elle passe sur du Core2Duo ou Core2Quad. J'ai le message The device that contains the configuration file (config.xml) could not be found. NAS4Free can not continue booting alors qu'en version 11 pas de problème) (2 clés faites sur une même machine tierce qui ne pose pas de soucis pour chaque clé que je fais dessus)

Qu'est-ce qui pourrait expliquer ce message ?

Je me pose également la question de la sécurité du NAS (MAJs) et des protocoles comme SMB qui il me semble est encore en V2 sur les 9.2.0.1 ? Il me semble qu'il y a des failles critiques sur SMB V2 ?

Qui de SMB V3 avec de l'Ubuntu 14.04 ou d'anciennes Debian / Windows 7 / MacOS Snow Leopard ?

Et si je passe sur de la 12.1 il parait qu'il y a encore des soucis ...

Que faire ?

Merci et portez vous bien

CorbeilleNews
Advanced User
Advanced User
Posts: 261
Joined: 04 Jul 2012 20:40
Status: Offline

Re: Quelle Version Choisir

#2

Post by CorbeilleNews »

Bonjour,

Personne pour me donner son avis ? :oops:

Merci :D

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: Quelle Version Choisir

#3

Post by ernie »

Hello,

De quelle version de xigmanas vient ton fichier de configuration ? 11 ? 12 ?
Potentiellement je crois que le fichier de configuration n'est pas retro compatible (12 vers 9 par exemple). Je laisse les experts confirmer.
Ou une corruption sur la clé du fichier config est aussi possible.

Sur le forum anglais, 2 infos sur ce type d'erreur (https://www.xigmanas.com/forums/viewtop ... =15&t=7111):
- brancher sur un autre port usb
- bug de la version 9.2.0.1 : essayer la version 9 suivante

Pour la sécurité, je ne sais pas pour smb. Par contre si la sécurité est clé pour toi, il faut aller vers les versions 11.3 ou 12.
Pour 12.1, il y a quelques soucis, mais je dirais surtout pour phpvirtualbox. Donc à tester pour voir et au pire tu rebootes sur ton ancienne version (garder la clé intacte).

A+
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

CorbeilleNews
Advanced User
Advanced User
Posts: 261
Joined: 04 Jul 2012 20:40
Status: Offline

Re: Quelle Version Choisir

#4

Post by CorbeilleNews »

La clé est neuve, j’ai essayé plusieurs clés et sur plusieurs ports USB.

Les clés fonctionnent toutes sur des anciennes machines mais pas sur la récente

Bizarre ?

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: Quelle Version Choisir

#5

Post by ernie »

Hello
N est ce pas un problème de Bios ?
La carte mère gère t elle l UEFI ? Quelle type d installation a été faite sur la clé : gpt, mbr ?
Il y a peut être un conflit : sur ma carte mère il a fallu désactiver l option Legacy du port usb pour avoir l’uefi et utiliser les nouvelles options d installation.
A+
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

CorbeilleNews
Advanced User
Advanced User
Posts: 261
Joined: 04 Jul 2012 20:40
Status: Offline

Re: Quelle Version Choisir

#6

Post by CorbeilleNews »

Sur les versions 9 on ne peut pas choisir donc j’imagine MBR

J’ai désactivé l’UEFI dans le BIOS

Vous semblez avoir fait l’inverse pour les versions récentes donc cela me semble cohérent

Post Reply

Return to “Français”