*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[Topic Unique] Installation Owncloud 8.02 + Mysql56

French community

Moderators: mtiburs, velivole18, ernie

Forum rules
Set-Up GuideFAQsForum Rules
ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#61

Post by ZiEg »

Alors le tuto Owncloud .... grande classe !!!! Ca a fonctionne sans le moindre accro.
Maintenant, merci laster13 de me donner toutes ces bonnes infos mais je vais devoir utiliser le Bittorent Sync (toujours pour les photos de ma femme)

De plus, mes jails fonctionnent maintenant laster13 !!!!
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#62

Post by laster13 »

Effectivement dedbue a simplifié et optimisé le tuto de manière à nous faire profiter au maximum des possibilités de owncloud. C'est vrai que c'est nickel!!

ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#63

Post by ZiEg »

Une petite derniers question sur l'install d'Owncloud :
J'ai lancé l'interface web : tout va bien
Je rentre les paramètres indiqués dans le tuto.....
Mais "Répertoire de données", c'est quoi ?

Pour info mon NAS a un répertoire Shared qui contient les reperoires
* Film
* Photo
* Document
* Musique

le but de ownCloud sera pour moi de pouvoir uploader/downloader sur le NAS de quelque poste je me trouve (iPad en vacances, iPhone en sortie, PC du boulot......)

Je pense donc mettre mon point de montage soit /mnt/disk1
ou alors il faut mettre autre chose comme le défaut /usr/local/www/owncloud/data ?

Merci de votre aide

et encore une fois un énorme bravo pour ce super tuto
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#64

Post by laster13 »

Mon répertoire de données d'owncloud est /mnt/pool1/Jail/owncloud/usr/local/www/owncloud/data/laster13/files (avec TheBrig)
tu changes l'utilisateur "laster13" bien sur :mrgreen:

Tu peux créer un dossier Photo en entrant au préalable dans la jail (jexec ....)

Code: Select all

mkdir /usr/local/www/owncloud/data/laster13/files/Photo
En supposant que tes données soient localisées de cette manière à l’extérieur de la jail:
/mnt/disk1/shared/Photo

tu auras:

Code: Select all

/mnt/disk1/shared/Photo /usr/jails/owncloud/usr/local/www/owncloud/data/laster13/files/Photo nullfs rw 0 0
Tu colles cette ligne de code dans TheBrig, partie fstab

dedbue
Starter
Starter
Posts: 16
Joined: 10 Dec 2014 19:44
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#65

Post by dedbue »

j'ai des soucis lorsque j'utilise fstab... Tout fonctionne bien sur owncloud, mais j'ai des problèmes de droits pour acceder et modifier par la suite les données par le biais du partage CIFS de Nas4free, j'ai bien sur corrigé le truc avec chmod, mais à chaque fois que j'envoie des nouvelles données par le biais de owncloud, je ne peux pas les supprimer via le partage CIFS

J'ai contourné le problème en utilisant le partage samba via "external storage", mais c'est moins propre... si tu as une solution, je suis preneur !

ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#66

Post by ZiEg »

Mes fichiers se trouvant comme suit :
/mnt/disk1/Photos
/mnt/disk1/Films
/mnt/disk1/Musique
/mnt/disk1/Documents

mon répertoire de données pour owncloud doit donc être :

/usr/local/www/owncloud/data/user/files/disk1

C'est correct ou il faut que je déplace tout dans un répertoire "racine" ?
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

User avatar
lulu80
PowerUser
PowerUser
Posts: 763
Joined: 15 Jun 2014 12:15
Location: France-(Picardie 80)
Contact:
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#67

Post by lulu80 »

bonjour ,
j'ai eu pas mal de problème avec c'est droit (unix je crois) :x , j'ai fini par crée un groupe que j'ai appeller "maison" et un utilisateur qui se ratache a plusieur groupe
et depuis je peut même supprimé un repertoire avec c'est dossiers a l'intérieur pour moi sa fonctionne :?
Groupe GID Description
maison xxxx famille
-------------------------------------------------------------------------------------------------
Utilisateur Nom complet UID Groupe
xxx xxx xxxx maison, admin, sshd, sys, wheel
Version 11.2.0.4 - Omnius (revision 6400)
https://lucinfordi.fr

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#68

Post by laster13 »

ZiEg wrote:mon répertoire de données pour owncloud doit donc être :

/usr/local/www/owncloud/data/user/files/disk1
Ton répertoire de données est:

/usr/local/www/owncloud/data/user/files/

Après tu crées des dossiers correspondants aux medias que tu veux classer et tu fais tes points de montage, genre:

Code: Select all

/usr/local/www/owncloud/data/user/files/Photos
/usr/local/www/owncloud/data/user/files/Musqiues
/usr/local/www/owncloud/data/user/files/Documents
....

Exemple de point de montage adapté à ton cas:

Code: Select all

/mnt/disk1/Photos /usr/jails/owncloud/usr/local/www/owncloud/data/user/files/Photos nullfs rw 0 0
dedbue wrote:j'ai des problèmes de droits pour acceder et modifier par la suite les données par le biais du partage CIFS de Nas4free, j'ai bien sur corrigé le truc avec chmod, mais à chaque fois que j'envoie des nouvelles données par le biais de owncloud, je ne peux pas les supprimer via le partage CIFS
Concernant owncloud et les droits, la suggestion de lulu me semble appropriée... à tester!!

ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#69

Post by ZiEg »

Bon......
Compte administrateur j'ai choisi ZiEg (oui je sais c'est original)
Répertoire de données : /usr/local/www/owncloud/data/ZiEg/files
Base de données : MySQL/MariaDB
root
le mot de passe qui va bien
owncloud
localhost

Je clique sur terminer l'installation et la j'ai un topissime message d'erreur :
Can't create or write into the data directory /usr/local/www/owncloud/data/ZiEg/files
bon a part changer les droits sur ledit répertoire via un chmod ..... pas de grandes idées

Merci de votre aide
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#70

Post by laster13 »

Désolé Zieg, j'ai mal interprété ta question.

Pour le répertoire de données tu laisses par défaut soit:

/usr/local/www/owncloud/data

Edit: J'ai testé le tuto avec finch et cela fonctionne parfaitement bien, sauf pour smbclient et le stokage externe ou tout comme avec TheBrig il faut lancer lighttpt en onestart et désactiver lighttpd_enable="YES" dans /etc/rc.conf. La prise en charge du ftp par contre ne pose aucun problème.

2 solutions:

- Soit vous n'avez pas besoin de smbclient parce que vous n'avez pas activer le stokage externe, alors dans /etc/rc.conf vous rajoutez

Code: Select all

lighttpd_enable="YES"
Et lighttpd se lancera automatiquement au démarage de la jail

- Soit tout comme dedbue vous avez besoin de smbclient, auquel cas vous effacez lighttpd_enable="YES" dans /etc/rc.conf et vous lancez la commande suivante manuellement

Code: Select all

/usr/local/etc/rc.d/lighttpd onestart
Mais comme on est tous un peu faineant, on va plutôt écrire un script qui le fera à notre place :mrgreen: et c'est là que je vous mets à contribution...

A vos plumes :mrgreen:

ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#71

Post by ZiEg »

Dernière petite question :
La base de données, elle doit être dans la Jail ou une base "externe" fonctionne ? Par base "externe", j'entends bien évidemment hors de la jail pas sur un PC externe....
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#72

Post by ZiEg »

ZiEg wrote:Dernière petite question :
La base de données, elle doit être dans la Jail ou une base "externe" fonctionne ? Par base "externe", j'entends bien évidemment hors de la jail pas sur un PC externe....
Please.... help
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#73

Post by laster13 »

Bonsoir,

Plutôt que de te répondre à coté, peux tu me dire exactement pourquoi tu veux sortir la base MySQL de la jail?

ZiEg
experienced User
experienced User
Posts: 135
Joined: 12 May 2013 20:20
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#74

Post by ZiEg »

Laster13,

ayant une install complète tournant avec un serveur web (donc php + mySQL), j'ai deja une BDD installée.... mais pas dans la jail.
Conclusion je n'ai plus qu'à killer cette jail et réinstaller dans la version complète .....

Je vais m'en sortir, tout va bien, je ne désespère pas !!
NAS 1 : Version 11.2.0.4 - Omnius (revision 6625) x64-full on Intel(R) Pentium(R) CPU G840 @ 2.80GHz
MSI B75A-G43 (MS-7758) w/ BIOS American Megatrends Inc. version: V10.5 10/12/2012

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#75

Post by laster13 »

Bonjour zieg,

Je suppose que tu souhaites n'avoir qu'une base MySQL pour owncloud et serveur web. Tiens nous au courant de tes résultats

Merci

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#76

Post by ernie »

Bonjour,

Les chemins trop long posent toujours problèmes :

[2015/01/25 00:22:11]: TheBrig error!: mount_nullfs: /mnt/pool1/extensions/brig/Jail/owncloud/usr/local/www/owncloud/data/champagne/files/music: File name too long


Même si je mets m au lieu de music c est trop long à cause du début.

Auriez vous une solution pour m éviter une réinstallation total de thebrig et des jails ?

Merci
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#77

Post by laster13 »

Bonjour,
ernie wrote:Les chemins trop long posent toujours problèmes :

[2015/01/25 00:22:11]: TheBrig error!: mount_nullfs: /mnt/pool1/extensions/brig/Jail/owncloud/usr/local/www/owncloud/data/champagne/files/music: File name too long
Peut être en installant Thebrig de manière à ce que le chemin devienne "mnt/pool1/Jail", cela te ferait déjà gagner de la longueur. Tu peux aussi gagner sur "champagne" ;)

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#78

Post by ernie »

Oui mais cela implique de des'installer the Brig et de recommencer. Je viens d y passer la matinée , je suis deg.
J ai poste un message sur le forum de owncloud.

C est chiant car je fais me retrouver même en raccourcissant le début avec du /ch/m pour musique .... Très pratique à la lecture.

Vivement que les chemins a l infini arrive


Édit
Le lien du forum owncloud :
http://forum.owncloud.org/viewtopic.php?f=29&t=26017

On me demande si le fstab est celui de owncloud ou thebrig quand on paramètre la jail ?
Je dirais owncloud, non ?
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#79

Post by laster13 »

ernie wrote:On me demande si le fstab est celui de owncloud ou thebrig quand on paramètre la jail ?
Je dirais owncloud, non ?
Oui c'est le fstab owncloud. Après, mais là je sais pas, peut être qu'il est possible de modifier le chemin du dossier "files" de owncloud et de le positionner dans /mnt/files (par exemple) de ta jail. Cela réglerait tous tes problèmes.

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#80

Post by ernie »

Hello

Suite à un échange sur le forum owncloud, j ai des doutes sur la responsabilité de owncloud.

J ai fait un test avec la jail de Plex : cheminé très long pour lier les vidéos . Même bug :

[2015/01/25 17:12:48]: TheBrig error!: mount_nullfs: /mnt/pool1/extensions/brig/Jail/plex/usr1/local/www/owncloud/data/champagne/files/video/personnel/personnel2/personnel3/personnel4: File name too long

Ne serait ce pas thebrig voir nas4free qui bloque cela ?

Quel test sous nas4free me permettrait de voir si c est thebrig ou nas4free ?
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

User avatar
lulu80
PowerUser
PowerUser
Posts: 763
Joined: 15 Jun 2014 12:15
Location: France-(Picardie 80)
Contact:
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#81

Post by lulu80 »

ernie ...c'est un marathon ton chemin :)
Version 11.2.0.4 - Omnius (revision 6400)
https://lucinfordi.fr

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#82

Post by ernie »

Puis je utiliser des liens symboliques pour pointer un répertoire avec le fStab, qui est lié symboliquement a un autre répertoire ?
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#83

Post by laster13 »

Bonsoir,

Sauf erreur de ma part, tu ne peux lier que des fichiers avec la commande "ln -s". Si tu n'as pas de réponses concernant le nombre de caractères dans fstab, je te conseille de tout recommencer, c'est plus sage ;)

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#84

Post by ernie »

AAAAAAAAAAAAAAAAHHHHHHHHHHHHHHHHHH !!!!!

cri de douleur :)

Je viens de desinstaller thebrig et de reinstaller, puis jail, puis owncloud.
J'évite un nom long pour les chemins.

Je remplis fstab. Pas d'erreur dans le log de thebrig . Cool :)

Je regarde via l'explorer de nas4free : mes répertoires de données owncloud contiennent les données de mon pool. Fstab a fait les liens. Super cool :)

je rentre dans l'interface d' owncloud, tous les répertoires sont vides => fais C....

je redemarre le nas, rien n'y change.

Via l'interface d'owncloud, je créée un fichier txt nommé toto, je le vois sur le pool.

Toutes idées est la bienvenue
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#85

Post by ernie »

Update:
suite à la création du fichier via owncloud, si je le supprime via nas4free, après je reviens dans owncloud : le répertoire se remplie.

Mystere
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

laster13
PowerUser
PowerUser
Posts: 995
Joined: 01 Jun 2013 19:15
Location: France-Marseille
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#86

Post by laster13 »

Pour les points de montage, il faut au départ que les dossiers soient vides sinon cela écrase les données déjà existantes. Si c'était déjà le cas, ne t'es tu pas trompé dans le sens de ton point de montage ?

User avatar
lulu80
PowerUser
PowerUser
Posts: 763
Joined: 15 Jun 2014 12:15
Location: France-(Picardie 80)
Contact:
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#87

Post by lulu80 »

bonjour,
il faut au départ que les dossiers soient vides sinon cela écrase les données déjà existantes
...tu parle pour owncloud ou en général ? c'est dire plex serviio ect...
parce que ont en fait et des points de montages dernierement et mes dossiers coté mnt/pool.. n'était pas vide ?
Version 11.2.0.4 - Omnius (revision 6400)
https://lucinfordi.fr

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#88

Post by ernie »

Oui pour finch, il faut que cela soit vide.
Non pour thebrig, cela marche. Le lien a du s activer dans les 2 sens via le créer détruire que j ai fait.
Cela me fait cela que sur owncloud. Plex rien a dire que cela soit vide ou pas.

Et les liens ont lieu physiquement puisque le webgui via Quick explorer me montre le contenu du pool. C est owncloud qui ne comprend pas, peut être une histoire de droit ou d actualisation .

En tout cas cela marche maintenant.
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#89

Post by ernie »

Owncloud 8 est sortie avec pas mal de nouveauté.

Savez vous si la communauté nas4free va mettre à jours les scripts ?

Quelqu'un a t il essayé de mettre à jours son owncloud ?
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1452
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [Topic unique] Installation Owncloud 7 + Mysql

#90

Post by ernie »

Hello,

Dans l'interface de Owncloud, est annoncée la dispo de l'upgrade 8.0.4.
J'ai tenté via l'interface d'administration web de lancer l'upgrade. A eviter. Les 2 premières étapes se sont bien passées (backup + télécharegement/extraction).
Une fois que j'ai appuyé sur le bouton Mise à jours vers 8.0.4 (un truc de ce style), quelques minutes après j'ai un message d'erreur:

Code: Select all

Fatal error: Class OCA\Contacts\Share\Addressbook contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (OCP\Share_Backend::isShareTypeAllowed) in /usr/local/www/owncloud/apps/contacts/lib/share/addressbook.php on line 130
donc à éviter pour le moment. Vivement l'adaptation du script pour avoir la v8.
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

Post Reply

Return to “Français”