*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[SOLVED] System Clock / Time not same as BIOS Clock / Time ?

General information about XigmaNAS
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Brett
NewUser
NewUser
Posts: 1
Joined: 15 Sep 2012 14:52
Status: Offline

[SOLVED] System Clock / Time not same as BIOS Clock / Time ?

#1

Post by Brett » 15 Sep 2012 15:35

I just set up NAS4Free last week and everything is running fine with the exception of one problem that I can't resolve. It is being used in my home, and I have all my computers shut down at night, and then turn themselves on in the morning via the bios settings. The motherboard is an Intel Corporation D945GCNL. I live in the central time zone in the USA. When I set the NAS4Free time to America/Chicago, it sets the motherboard system clock 5 hours ahead of the actual time. When I use CDT6DT, NAS4Free also sets the motherboard system clock 5 hours ahead of the actual time. If I try using etc/gmt - 5, NAS4Free shows a system time 10 hours ahead of the actual time. Obviously this causes all kinds of issues since I can't get the NAS4Free time and the motherboard system clock to sync. What the heck am I doing wrong?

Thanks
Last edited by al562 on 27 Dec 2012 08:08, edited 1 time in total.
Reason: Adjusted Subject. Added [SOLVED] Tag.

nwisrlit
NewUser
NewUser
Posts: 1
Joined: 20 Sep 2012 23:10
Status: Offline

Re: System Clock Issue

#2

Post by nwisrlit » 20 Sep 2012 23:37

Windows systems set your hardware clock to local time (so they would appear to you to be "in sync"), but all *nixish systems keep the hardware/BIOS/motherboard clock at GMT aka UTC (so they would only appear "in sync" if you lived in the GMT zone).

When you request the system time, using the 'date' command for instance, the O/S retrieves the UTC from the hardware clock, adds or subtracts the amount necessary per your timezone, then displays your answer.

The most correct thing to do would be to keep your NAS4Free timezone set to "America/Chicago", then adjust your BIOS wakeup time by 5 hours.

Post Reply

Return to “GENERAL INFORMATION”