Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Trouble with Powercom WAR-1000AP

Uninterruptable Power Supply service using NUT.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Yellow Horror
NewUser
NewUser
Posts: 2
Joined: 26 Jul 2019 20:28
Status: Offline

Trouble with Powercom WAR-1000AP

#1

Post by Yellow Horror » 26 Jul 2019 21:13

I can't make my Powercom WAR-1000AP to work with NUT in XigmaNAS 11.2.0.4. Have this error log:
Network UPS Tools - Generic HID driver 0.41 (2.7.4)
USB communication driver 0.33
0.000000 debug level is '3'
0.003678 upsdrv_initups...
0.005565 Checking device (0D9F/0004) (/dev/usb//dev/ugen0.2)
0.212468 - VendorID: 0d9f
0.212509 - ProductID: 0004
0.212529 - Manufacturer: unknown
0.212545 - Product: unknown
0.212560 - Serial Number: unknown
0.212576 - Bus: /dev/usb
0.212591 - Device release number: 0001
0.212606 Trying to match device
0.212634 Device matches
0.212663 nut_usb_set_altinterface: skipped usb_set_altinterface(udev, 0)
0.282189 Unable to get HID descriptor (Unknown error)
0.282240 HID descriptor length (method 1) -1
0.282269 HID descriptor, method 2: (9 bytes) => 09 21 00 01 00 01 22 c6 03
0.282286 HID descriptor length (method 2) 966
0.282302 HID descriptor length 966
0.352360 Unable to get Report descriptor: Input/output error
Tricks with additional parameters that I found on the Internet do not help. However, in Linux, the UPS works well with NUT on the same hardware and USB port. A noticeable difference is the driver version. In Linux, I have Generic HID driver 0.38 (2.7.2) and USB communication driver 0.32. I tried to report the issue to NUT developers on GitHub but get no help.

Is there a way to downgrade the drivers in XigmaNAS to check if the new ones are causing the problem? Any other suggestions (besides change the UPS)?

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4914
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Trouble with Powercom WAR-1000AP

#2

Post by raulfg3 » 28 Jul 2019 10:27

Yellow Horror wrote:Is there a way to downgrade the drivers in XigmaNAS to check if the new ones are causing the problem? Any other suggestions (besides change the UPS)?

Yes, you can detach your actual boot disk/USB Key and place in a safe box.

and boot from a live USB ( with old XigmaNAS) and test drivers from live system.


PD: Is not strictly mandatory detach your actual boot disk , but is safer for you.
12.0.0.4 - BETA (revision 6625)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes
Old Wiki

Yellow Horror
NewUser
NewUser
Posts: 2
Joined: 26 Jul 2019 20:28
Status: Offline

Re: Trouble with Powercom WAR-1000AP

#3

Post by Yellow Horror » 20 Aug 2019 06:49

I tried the Nas4free version 11.1.0.4 (build 5019) but it has the same Generic HID driver 0.41 (2.7.4) and USB communication driver 0.33. Where can i find an older version?

Post Reply

Return to “UPS”