Sorry we lost some posts because of database errors!

*New 12.1 series Release:
2020-09-01: XigmaNAS 12.1.0.4.7728 - released

*New 11.4 series Release:
2020-08-27: XigmaNAS 11.4.0.4.7718 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Configuring to use genericups upstype=5 driver

Uninterruptable Power Supply service using NUT.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Jdo300
NewUser
NewUser
Posts: 7
Joined: 25 Jul 2017 21:51
Status: Offline

Configuring to use genericups upstype=5 driver

#1

Post by Jdo300 »

Hello All,

This is probably an extremely n00b question but I've determined that the "genericups upstype=5" driver listed in the driver list is the appropriate one for my UPS (An old Tripp-Lite non-smart UPS with serial port). However, I'm not sure I'm setting up the driver correctly. I put "genericups" in the "Driver" field and "upstype=5" in the "Additional Parameters" box below. But when I enabled the UPS feature, the NAS just timed out and shut down. I suspect one of two problems:

1. I selected the wrong serial port (I used /dev/ttyu0 but there is also a /dev/ttyu1 and I'm not sure which is the hardware serial port).

2. I'm not putting the upstype=5 parameter in the right place and it is misreading the pins and shutting down.

3. Somehow the logic is reversed and it thinks it's constantly triggered?

I want to make sure that #2 isn't the issue first. Is it correct that I need to put the upstype=5 setting in the parameters box or does it need to go in the Driver field along with the driver name? (I tried putting the exact string in with the parameter setting included as shown above but it wouldn't let me save the settings)

NOTE: I should also note that I'm using the older version of XigmaNAS (NAS4FREE Version 11.0.0.4)

User avatar
ms49434
Developer
Developer
Posts: 842
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Configuring to use genericups upstype=5 driver

#2

Post by ms49434 »

Jdo300 wrote:
11 Aug 2020 00:44
Hello All,

This is probably an extremely n00b question but I've determined that the "genericups upstype=5" driver listed in the driver list is the appropriate one for my UPS (An old Tripp-Lite non-smart UPS with serial port). However, I'm not sure I'm setting up the driver correctly. I put "genericups" in the "Driver" field and "upstype=5" in the "Additional Parameters" box below. But when I enabled the UPS feature, the NAS just timed out and shut down. I suspect one of two problems:

1. I selected the wrong serial port (I used /dev/ttyu0 but there is also a /dev/ttyu1 and I'm not sure which is the hardware serial port).

2. I'm not putting the upstype=5 parameter in the right place and it is misreading the pins and shutting down.

3. Somehow the logic is reversed and it thinks it's constantly triggered?

I want to make sure that #2 isn't the issue first. Is it correct that I need to put the upstype=5 setting in the parameters box or does it need to go in the Driver field along with the driver name? (I tried putting the exact string in with the parameter setting included as shown above but it wouldn't let me save the settings)

NOTE: I should also note that I'm using the older version of XigmaNAS (NAS4FREE Version 11.0.0.4)
You can always verify your ups driver configuration, it's in /var/etc/ups.conf:

Code: Select all

xigmanasa: ~# cat /var/etc/ups.conf
[u1]
	driver = genericups
	port = auto
	upstype = 1

xigmanasa: ~# 
1) If the configured port immediately reports low battery, usually the wrong port was selected.
2) Additional Parameter is the right place to configure hardware-specific information of the driver
3) -> 1)
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Jdo300
NewUser
NewUser
Posts: 7
Joined: 25 Jul 2017 21:51
Status: Offline

Re: Configuring to use genericups upstype=5 driver

#3

Post by Jdo300 »

Thank you for the reply! I ran the command you mentioned and here is what was reported back from the ups.conf file:

Code: Select all

[TrippLite]
        driver = genericups
        port = /dev/ttyu1
        upstype=5
After doing some testing last night. I found that if I used ttyu0 as the port, the NAS immediately restarted after booting (regardless of the value I set for the timeout value). This also happened even when the serial cord was not plugged in. When I set it to ttyu1, then it showed the low battery alert immediately but didn't shut off regardless of whether the UPS was connected, triggered etc. I'm suspecting now that I still may not be referencing the correct serial port. Is there any quick/simple way to check the port to see if I am referencing the correct one?

Thanks,
Jason O

Jdo300
NewUser
NewUser
Posts: 7
Joined: 25 Jul 2017 21:51
Status: Offline

Re: Configuring to use genericups upstype=5 driver

#4

Post by Jdo300 »

As I'm looking into the serial port naming issue, I came across this page from FreeBSD that talks about the names for the serial ports:

https://www.freebsd.org/doc/en_US.ISO88 ... dp49949176

I'm a bit confused. Should I be referencing it as "cuad0" / "cuad1" or should I be using "ttyd0" / "ttyd1"?

Post Reply

Return to “UPS”