*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

APC BACK-UPS 1200 (Connection Guide)

Uninterruptable Power Supply service using NUT.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
Paladius
NewUser
NewUser
Posts: 6
Joined: 19 Sep 2013 13:55
Status: Offline

APC BACK-UPS 1200 (Connection Guide)

#1

Post by Paladius » 02 Dec 2014 14:04

Hi.

For 2 years, i'm using UPS SMS MANAGER III connected in Nas4free viewtopic.php?f=46&t=5092, very good Managed UPS, but broken for lightning.
i buy APC BACK-UPS 1200 (BZ1200-BR)(USB PORT) http://www.apc.com/products/resource/in ... =BZ1200-BR
ImageImage

When i try config, i lost 1~2 hours to activate then in Nas4free. See how I did to set it in nas4free.

Step 1 :
in console (ssh ) , type the command: sysctl -a dev.uftdi

Step 2 : Result for me is :
dev.uftdi.0.%desc: USB - Serial
dev.uftdi.0.%driver: uftdi
dev.uftdi.0.%location: bus=1 hubaddr=4 port=1 devaddr=3 interface=0
dev.uftdi.0.%pnpinfo: vendor=0x0403 product=0x6001 devclass=0x00 devsubclass=0x00 sernum="" release=0x0400 mode=host intclass=0xff intsubclass=0xff intprotocol=0xff ttyname=U1 ttyports=1
dev.uftdi.0.%parent: uhub1
dev.uftdi.0.ttyname: U1
dev.uftdi.0.ttyports: 1

Step 3 : in result see dev.uftdi.0.ttyname: U1 , that is equal /dev/ttyU1

Step 4 : now you already know which port your UPS is, in my case /dev/ttyU1

Step 5 : in your nas4free , "Services" -> "UPS" , Driver = genericups , Port = /dev/ttyU1 (is my case) , Auxiliary parameters = upstype=1 , save the config, and see status about your UPS.

Regards.
(Sorry for my bad english)
___________________________________
(Brazil Language)
Olá.
Por 2 anos, eu estive usando Nobreak SMS MANAGER III conectado ao Nas4free viewtopic.php?f=46&t=5092, mas queimou por um raio.
Comprei um APC BACK-UPS 1200 (BZ1200-BR)(Com porta USB)http://www.apc.com/products/resource/in ... =BZ1200-BR
ImageImage

Quando fui tentar configurar no meu nas4free, perdi 1~2 horas para ativar dentro do Nas4Free.

Passo 1 : no console (ssh) , digite o comando : sysctl -a dev.uftdi

Passo 2 : os resultados do comando anterior foram :
dev.uftdi.0.%desc: USB - Serial
dev.uftdi.0.%driver: uftdi
dev.uftdi.0.%location: bus=1 hubaddr=4 port=1 devaddr=3 interface=0
dev.uftdi.0.%pnpinfo: vendor=0x0403 product=0x6001 devclass=0x00 devsubclass=0x00 sernum="" release=0x0400 mode=host intclass=0xff intsubclass=0xff intprotocol=0xff ttyname=U1 ttyports=1
dev.uftdi.0.%parent: uhub1
dev.uftdi.0.ttyname: U1
dev.uftdi.0.ttyports: 1

Passo 3 : nos resultados vejam dev.uftdi.0.ttyname: U1 , isso é igual ao /dev/ttyU1

Passo 4 : Agora você já sabe qual porta que seu nobreak está conectado, no meu caso /dev/ttyU1

Passo 5 : no seu nas4free , na guia "Serviços(Services)" -> "Nobreak (UPS)" , Driver = genericups , Port = /dev/ttyU1 (no meu caso) , Auxiliary parameters = upstype=1 , salve as configurações, veja o status do seu nobreak.

Abraços
CentOS 6.6 x64 - Scandisk Ssd 32gb Sata III 6gb/s, 8 GB RAM, CPU Amd X8 FX-9590 4.7ghz, Cosair HX750
4x ST3000DM001 3TB SATA III 6gb/s on Raid10=6TB On a Asus Crosshair V Formula Z
Packages enable: Serviio - Trasmission - SMB - SSH - UPS - Apache2+PHP5 - Owncloud - TFTP - Asterisk 1.6 + TDM410P - Twin2Cs
Swith: Dlink DGS-1024D - 24ports 1Gbps

almirjakubaitis
NewUser
NewUser
Posts: 14
Joined: 19 Jun 2016 04:52
Status: Offline

Re: APC BACK-UPS 1200/1500-BR (Connection Guide)

#2

Post by almirjakubaitis » 05 Jul 2016 16:24

Hi Paladius.
Well, this topic is old but I also would like to share my tests with similar model: APC BACK-UPS 1500/BR
This model is made by Schneider Electric here in Brazil. I've tried genericups and did not work. And find device also was a little different.

Step1: (ssh - console)
sysctl -a dev.umodem - to find device. (with sysctl -a dev.uftdi show error)

Step2 - Response:
dev.umodem.0.ttyports: 1
dev.umodem.0.ttyname: U0
dev.umodem.0.%parent: uhub4
dev.umodem.0.%pnpinfo: vendor=0x051d product=0xc812 devclass=0x02 devsubclass=0x00 sernum="" release=0x0100 mode=host intclass=0x02 intsubclass=0x02 intprotocol=0x01 ttyname=U0 ttyports=1
dev.umodem.0.%location: bus=5 hubaddr=1 port=2 devaddr=2 interface=0 ugen=ugen5.2
dev.umodem.0.%driver: umodem
dev.umodem.0.%desc: APC BY SCHNEIDER ELECTRIC APC USB SERIAL CONVERTER., class 2/0, rev 2.00/1.00, addr 2
dev.umodem.%parent:

Step 3 : in result see dev.umodem.0.ttyname: U0
Step 4 : now you already know which port UPS is, in my case /dev/ttyU0
Step 5 : in your nas4free , "Services" -> "UPS" , Driver = solis (this works ins my case), Port = /dev/ttyU1 (is my case) , save the config, and see status about your UPS.
For APC BACK-UPS 1500/BR model running nice. I've tried to unplug it and received e-mails in both status (on / off), very cool.

Sorry by my english. I hope this could help someone else.

Thanks.
System specs:
NAS #1
Version: NAS4Free 11.0.0.4 (revision 5019) CPU: Supermicro X8SIL /x64 Xeon(R) CPU L3406 @ 2.27GHz
RAM: 16GB DDR3 ECC UDIMM/ STORAGE: 5x 2TB HTSG raidz1-0 @ zfs

NAS #2
Version: NAS4Free 11.0.0.4 (revision 5019) CPU: Supermicro X8SIL /x64 Xeon(R) CPU X3430 @ 2.40GHz
RAM: 16GB DDR3 ECC RDIMM/ STORAGE: 5x 2TB raidz1-0 @ zfs

NAS #3
Version: NAS4Free 11.0.0.4 (revision 5019) CPU: x64-embedded on Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
RAM: 8GB DDR2 / STORAGE: 1x 8TB Stripe @ zfs

Post Reply

Return to “UPS”