*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Login on UPS failed - got [ERR ACCESS-DENIED]

Uninterruptable Power Supply service using NUT.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Login on UPS failed - got [ERR ACCESS-DENIED]

#1

Post by Blaxtar » 30 Aug 2015 17:34

I'm using a PfSense-box as master and two NAS4Free as slave. No mather how i configure my PfSense-box i'm keep on getting a message in the log tellig me that "upsmon[3294]: Login on UPS [BR550GI@192.168.168.1] failed - got [ERR ACCESS-DENIED]". I've tryed to plug out the powercord and both NAS4Free and the PfSense-box shuts down as expected. What does this message says and is there someting i can do to solve it?

Running NAS4Free 10.1.0.2

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: RE: Login on UPS failed - got [ERR ACCESS-DENIED]

#2

Post by crest » 30 Aug 2015 18:05

Blaxtar wrote:I'm using a PfSense-box as master and two NAS4Free as slave. No mather how i configure my PfSense-box i'm keep on getting a message in the log tellig me that "upsmon[3294]: Login on UPS [BR550GI@192.168.168.1] failed - got [ERR ACCESS-DENIED]". I've tryed to plug out the powercord and both NAS4Free and the PfSense-box shuts down as expected. What does this message says and is there someting i can do to solve it?

Running NAS4Free 10.1.0.2
- do you get the messages in the N4F servers?
- is it possible to setup a monitor user in your pfsense box because N4F uses a dedicated upsmon user (to avoid to send the password of root throughout the network) for the slave mode?
- did you try to setup one N4F server as master and the second server as slave and also the pfsense box as a slave ?

Sent from my Lenovo B8000-F with Tapatalk.
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#3

Post by Blaxtar » 30 Aug 2015 18:24

Yes, these messages appear in the N4F servers.
Can you elaborate on what you mean with "setup a monitor user in your pfsense box"? One thing i recognized is that the settings in PfSense allows me to enter both a username and a password but the setting in N4F only allows a username. The messega appears regardless of whether a password is configuread or not in PfSense.
I haven't tried to set up any of the N4F as master and the other as slave, I would like to have the PfSense as master because of that the N4F isn't always on.

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: RE: Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#4

Post by crest » 30 Aug 2015 18:45

Blaxtar wrote:Yes, these messages appear in the N4F servers.
Can you elaborate on what you mean with "setup a monitor user in your pfsense box"? One thing i recognized is that the settings in PfSense allows me to enter both a username and a password but the setting in N4F only allows a username. The messega appears regardless of whether a password is configuread or not in PfSense.
I haven't tried to set up any of the N4F as master and the other as slave, I would like to have the PfSense as master because of that the N4F isn't always on.
So please try to setup a user upsmon with the password upsmon in the pfsense ups settings and restart the nut service in the pfsense box .


Sent from my Lenovo B8000-F with Tapatalk.
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#5

Post by crest » 04 Sep 2015 16:23

Blaxtar wrote:Yes, these messages appear in the N4F servers.
Can you elaborate on what you mean with "setup a monitor user in your pfsense box"? One thing i recognized is that the settings in PfSense allows me to enter both a username and a password but the setting in N4F only allows a username. The messega appears regardless of whether a password is configuread or not in PfSense.
I haven't tried to set up any of the N4F as master and the other as slave, I would like to have the PfSense as master because of that the N4F isn't always on.
Did you try the proposal from my previous post?
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#6

Post by Blaxtar » 04 Sep 2015 21:51

Sorry for late answere, I'll been on kick-off with my work this week. Actually, I didn't really get where I should setup the user in PfSense. I started to Google but didn't got any wiser and I'm not an expert in NUT. Is it in some of the *.conf-file?

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#7

Post by crest » 06 Sep 2015 12:00

Blaxtar wrote:Sorry for late answere, I'll been on kick-off with my work this week. Actually, I didn't really get where I should setup the user in PfSense. I started to Google but didn't got any wiser and I'm not an expert in NUT. Is it in some of the *.conf-file?
No problem, according to your previous post you wrote
One thing i recognized is that the settings in PfSense allows me to enter both a username and a password but the setting in N4F only allows a username.
so I thought you know where to change user and password ... ;) in pfsense.

There are conf files, if I remember right they are in /etc/rc.d/nut and / or ups... something (sorry, I'm out for some days and therefore I don't have access to my N4F boxes). But if pfsense works similar to N4F changes in the conf files will be overwritten at reboot of the system

I can take care about this at the end of next week .... If you are patient enough ;)
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#8

Post by Blaxtar » 06 Sep 2015 13:25

I wish i knew how to add user in Pfsense but my knowledge isn't that good and the documentation lacks a little bit. I've no problems waiting to next weekend and would appreciate your help a lot. I'ts the same problem with Pfsense as N4F that all config-files edited through vi via SSH is overwriten on a reebot. However, different from N4F, it's possible to write custom options in ups.conf, upsd.conf, upsd.users and upsmon.conf directly from the GUI in Pfsense.
Unfortunately I haven't got it to work with battery.charge < battery.charge.low; override.battery.charge.low = 50;

Image

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#9

Post by crest » 06 Sep 2015 18:17

Blaxtar wrote:I wish i knew how to add user in Pfsense but my knowledge isn't that good and the documentation lacks a little bit. I've no problems waiting to next weekend and would appreciate your help a lot. I'ts the same problem with Pfsense as N4F that all config-files edited through vi via SSH is overwriten on a reebot. However, different from N4F, it's possible to write custom options in ups.conf, upsd.conf, upsd.users and upsmon.conf directly from the GUI in Pfsense.
Unfortunately I haven't got it to work with battery.charge < battery.charge.low; override.battery.charge.low = 50;

Image
So you could try to setup the upsmon user in upsd.users advanced section like see also here e.g.

Code: Select all

[upsmon]
        password = upsmon
        upsmon slave
... and try it also without the semicolon but with a newline in the above battery settings
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#10

Post by Blaxtar » 08 Sep 2015 18:19

I tried to enter it as you suggested, this is how it looks before hitting the Change-button;
Image

Clicked Change (which restart the service) and then went back to the settings-tab again. Pfsense seems to have auto-corrected it to this;
Image

The message in the log is still there :|
upsmon[11046]: Login on UPS [BR550GI@192.168.168.1] failed - got [ERR ACCESS-DENIED]

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#11

Post by crest » 13 Sep 2015 08:56

Blaxtar wrote:I tried to enter it as you suggested, this is how it looks before hitting the Change-button;

...

The message in the log is still there :|
You can try to set the remote access user upsmon and password upsmon here
screen_20150913_084944.png
if this will not work then I would suggest to ask at the pfsense forum how to setup the remote monitoring user ...
You do not have the required permissions to view the files attached to this post.
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#12

Post by crest » 02 Oct 2015 08:21

crest wrote: You can try to set the remote access user upsmon and password upsmon here
...
if this will not work then I would suggest to ask at the pfsense forum how to setup the remote monitoring user ...
@Blaxtar: Did you try the above suggestion?
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#13

Post by Blaxtar » 03 Oct 2015 13:45

Sorry for late answer, whole september meant traveling around with my work, thanks for the reminder :-). I tried it right now and voilà, problem is solved! Thanks a lot for your help! If you are passing by Stockholm, let me know so I can invite you to a lunch as a thanks!

Two more question - is it possible to change the password for the upsmon-user in N4F? Is there any securityrisks using the standard upsmon-password?

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#14

Post by crest » 04 Oct 2015 07:03

Blaxtar wrote:Sorry for late answer, whole september meant traveling around with my work, thanks for the reminder :-). I tried it right now and voilà, problem is solved! Thanks a lot for your help! If you are passing by Stockholm, let me know so I can invite you to a lunch as a thanks!
Don't worry, good to see that my suggestion worked :D
Hmm, yes it's long time ago since I was in Stockholm, maybe I will come next year to visit again .. and to have a nice lunch :lol:
Blaxtar wrote: Two more question - is it possible to change the password for the upsmon-user in N4F? Is there any securityrisks using the standard upsmon-password?
- not yet but I planned already to extend the current implementation of UPS in N4F (user and password editable, support for two UPSs on one server) - but it can take a while ...
- IMHO it's not a security risk to use the standard upsmon user/password because this user is not a real system user (just in the NUT environment) and has only permissions to monitor the state of the UPS.

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Blaxtar
NewUser
NewUser
Posts: 9
Joined: 15 Jul 2015 00:04
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#15

Post by Blaxtar » 04 Oct 2015 12:16

Really appreciate your nice response and patient with beginners like me. Looking forward to see you in Stockholm then! :-D

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#16

Post by crest » 06 Oct 2015 08:36

Blaxtar wrote:Really appreciate your nice response and patient with beginners like me. Looking forward to see you in Stockholm then! :-D
You are always welcome :D
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

willrun4fun
NewUser
NewUser
Posts: 5
Joined: 11 Feb 2016 23:12
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#17

Post by willrun4fun » 13 Feb 2016 12:03

crest wrote:
Blaxtar wrote:Really appreciate your nice response and patient with beginners like me. Looking forward to see you in Stockholm then! :-D
You are always welcome :D
I just wanted to thank crest again for the final part in fixing the same issue for me! I will also add a link to one more thread over at the pfsense boards that goes through the NAT rule needed to allow remote NUT monitoring. This is required on newer releases of pfsense.
https://forum.pfsense.org/index.php?topic=99488.0

Thanks again!
Willrun4fun
X10SLL-F, i5-4590, 16GB ECC, four 2TB Toshiba 7200k, Kingston 120GB SSD boot, Antec Three Hundred, EVGA 500B

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Login on UPS failed - got [ERR ACCESS-DENIED]

#18

Post by crest » 17 Feb 2016 09:33

willrun4fun wrote:
crest wrote:
Blaxtar wrote:Really appreciate your nice response and patient with beginners like me. Looking forward to see you in Stockholm then! :-D
You are always welcome :D
I just wanted to thank crest again for the final part in fixing the same issue for me! I will also add a link to one more thread over at the pfsense boards that goes through the NAT rule needed to allow remote NUT monitoring. This is required on newer releases of pfsense.
https://forum.pfsense.org/index.php?topic=99488.0

Thanks again!
You're welcome - and thanks for the additional infos !
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Post Reply

Return to “UPS”