*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[SOLVED]Problems w/ new transmission version 2.93

Transmission bittorrent server.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
jamaroney
Advanced User
Advanced User
Posts: 217
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

[SOLVED]Problems w/ new transmission version 2.93

#1

Post by jamaroney » 03 Feb 2018 00:03

There's a new transmission version (2.93) in the latest N4F upgrade to r5109. But I can't get any port to open. Transmission 2.92 in all earlier N4F versions worked fine.

Is there anyone who installed the latest N4F version experiencing the same problem?

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problems w/ new transmission version 2.93

#2

Post by pierouelle » 03 Feb 2018 22:50

I have the same problem, i did not change anything since month and i can say year in my settings on Nas4free and even my router for port fowarding and transmission always works as supposed to and port show open.
Being said after the new version on the nas4free 5109 transmission says port close even worse when i hit save and restart in services bittorrent settings it shows error code 1. revert back to 5065 like i said without changing any settings and transmission works perfect.
Can someone explain...it will be helpful for the community.
Have a great day

User avatar
ms49434
Developer
Developer
Posts: 719
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Online

Re: Problems w/ new transmission version 2.93

#3

Post by ms49434 » 04 Feb 2018 00:19

Devs are aware of the issue.
Error code 1 is caused by transmission-remote which throws

Code: Select all

* Protocol "http" not supported or disabled in libcurl
* Closing connection -1
[2018-02-03 23:53:03.333] transmission-remote:  (http://localhost:9091/transmission/rpc/) Unsupported protocol
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4921
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Problems w/ new transmission version 2.93

#4

Post by raulfg3 » 04 Feb 2018 09:29

perhaps r5109 must be deleted to download until problem is solved?
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Re: Problems w/ new transmission version 2.93

#5

Post by pierouelle » 04 Feb 2018 15:39

Thank you ms49434 for the explanation, have a superb day

Post Reply

Return to “BitTorrent”