*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

problem when trying to install sql

Webserver service.
Forum rules
Set-Up GuideFAQsForum Rules
brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

problem when trying to install sql

#1

Post by brielem » 28 May 2013 19:29

First of all: I'm not a linux-person, I barely know what I'm doing with command line.

I'm trying to install mysql 5.5 on my nas according to this guide.
So I entered the codes like the guide said, but after "# pkg_add -r mysql55-server" I get an error: pipeline broken. I tried it a few times now, but the same error pops up every time.
What am I doing wrong/can someone help me to install mysql on my nas?

Thanks in advance.

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#2

Post by kkd » 28 May 2013 19:35

stupid question: do u have am internet connection? try ping
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#3

Post by brielem » 28 May 2013 19:40

Not a stupid question, I know how stupid users can be sometimes. :)

Yes I do have an internet connection. I can reach the webserver via a non-local connection, as well as SFTP.

you say try ping: what should I ping, and what will it tell me?

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#4

Post by kkd » 28 May 2013 21:34

ping freebsd.org
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#5

Post by kkd » 28 May 2013 21:37

u should see 8.8.178.135
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#6

Post by kkd » 28 May 2013 21:40

anyway what kind of n4f install do u use?
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#7

Post by brielem » 29 May 2013 20:46

I have n4f 9.1 embedded. Ping to freebsd.org went good, 0% loss. It does say it doesn't have an UDP connection to freebsd.org, but FTP is TCP only, isn't it?

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#8

Post by kkd » 29 May 2013 21:23

yes, ftp is tcp.
try to download mysql onto a different mashine and scp it to ur n4f server. i think usr/ports/distfiles
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#9

Post by brielem » 31 May 2013 16:00

As you said, I downloaded the file. is just the .tbz file enough?

And now, how do I install it? I can send it to my n4f server, but how do I install it then?

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#10

Post by kkd » 31 May 2013 16:12

If u use windows:
download mysql: ftp://ftp.freebsd.org/pub/FreeBSD/ports ... 5.5.28.tbz
install winscp
login nas4free webgui
turn on ssh (service shh enable, Permit root login = on, Password authentication=on)
start winscp
select scp and the ip of ur n4f server
select dirs (/usr/ports/distfiles) and the downloaded file
upload (copy the file)

start putty
login
cd /usr/ports/distfiles
make install
sh /usr/local/etc/rc.d/mysql-server.sh start

back to webgui:
/etc/rc.conf
mysql_enable="YES"
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#11

Post by kkd » 31 May 2013 16:17

XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#12

Post by brielem » 31 May 2013 17:26

Thanks man!

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#13

Post by brielem » 31 May 2013 18:00

okay, still some trouble:

I downloaded mysql, so far so good.
I regularly use SSH and winscp, so that's no problem either
I tried uploading it to /usr/ports/distfiles, but that directory doesn't exist. I created it, but when I tried to upload the mysql file to it, winscp said there was not enough space.
So Now I uploaded it to /mnt/hdd1/ but can I install it from there? I tried:
cd /mnt/hdd1/ (nas confirmed I was in that directory)
sh mysql-server-5.5.30.tbz

then, this error:
http://i.snag.gy/nPWXJ.jpg

What did I do wrong, and what should I do?

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#14

Post by kkd » 31 May 2013 18:49

ur right. u have to untar it:

cd /mnt/hd1
tar -zxvf mysql-server-5.5.30.tbz
cd mysql-5.5.30
make install
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#15

Post by brielem » 31 May 2013 20:08

Thanks again. Still problems, but we're getting closer:
untarring thing was complaining about a corrupt file. Re-downloaded it, still error.
I realized it was an archive, so I tried opening it in 7-zip in windows: success!
Copied the untarred folder to the location already mentioned (mnt/hd1)
now my install-directory is mnt/hd1/mysql-5.5.30
found the mysql_install_db file. It was in the mnt/hd1/mysql-5.5.30/bin
so, from mnt/hd1/mysql-5.5.30 :
sh bin/mysql_install_db
shit, error:
http://i.snag.gy/udam0.jpg

After that, I copied the file mysql_install_db to mnt/hd1/mysql-5.5.30
I tried again, from mnt/hd1/mysql-5.5.30
sh mysql_install_db

again, same error as mentioned above. I have confirmed that the my_print_defaults file is indeed in the /bin directory. What to do now?

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#16

Post by kkd » 31 May 2013 20:43

try
cd bin
mysql_install_db
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#17

Post by brielem » 31 May 2013 20:49

exactly the same error message

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#18

Post by kkd » 31 May 2013 20:54

XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#19

Post by kkd » 31 May 2013 20:57

monday i will install a test n4f. try to figure it out and back soon
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4940
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: problem when trying to install sql

#20

Post by raulfg3 » 31 May 2013 21:38

I install mysql using script done by fsbruva for owncloud install: viewtopic.php?f=79&t=1565&p=6725#p6725
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#21

Post by brielem » 31 May 2013 21:54

I don't quite get this: a script that is made to install owncloud, also installs mysql?
And the description states it should be run within a jail: I'm not far enough to create one without being sure of not f_* up my system. how necessary is it?

In other words: can you give me a description of how to use that script, because it's not clear to me at all.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4940
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: problem when trying to install sql

#22

Post by raulfg3 » 01 Jun 2013 09:40

brielem wrote:I don't quite get this: a script that is made to install owncloud, also installs mysql?
YES
brielem wrote:And the description states it should be run within a jail: I'm not far enough to create one without being sure of not f_* up my system. how necessary is it?
necessary , easy and recommended.

It's recommended because jails isolate N4F from your packages, so you can easy upgrade N4F and SQL (what you install) still works, I actually have 4 jails, one for owncloud, one for amule, one for minidlna, etc...

I test what happend if reinstall my N4F boot disk, and nothig is lost , jails are in data disk and restored once I restore N4F config after a full new install of N4F, so answering to your question, YES it's necessary & recommended.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#23

Post by brielem » 02 Jun 2013 17:29

When untarring the files, I get a 137 error every time. It does extract some files, but not all of them.
I tried it several times, several downloads, and it still doesn't work...

What do I do wrong?

User avatar
kkd
Forum Moderator
Forum Moderator
Posts: 303
Joined: 08 May 2013 21:47
Location: Budapest, Hungary
Contact:
Status: Offline

Re: problem when trying to install sql

#24

Post by kkd » 02 Jun 2013 18:50

i downloaded and managed to untar it successfully.
XigmaNAS x64-embedded | INTEL Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz | 9216MiB RAM | X x YTB WD Red ZFS mirror compressed

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4940
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: problem when trying to install sql

#25

Post by raulfg3 » 02 Jun 2013 19:44

brielem wrote:When untarring the files, I get a 137 error every time. It does extract some files, but not all of them.
I tried it several times, several downloads, and it still doesn't work...

What do I do wrong?
you say that have a N4F embeded install, perhaps you have exhaust your free space?

Do you untar in your data disk? or in data disk ? /mnt/yourmountpoint/foldertountar ??
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#26

Post by brielem » 08 Jun 2013 20:21

I tried both: in the partition on which the OS is, it doesn't untar, and in the data partition, it does, but after that it doesn't work.

How do I make the OS partition bigger? I think shortage of space is could indeed be the problem.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4940
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: problem when trying to install sql

#27

Post by raulfg3 » 08 Jun 2013 20:30

you do not need to make OS partition bigger, you only need to use jails to use data space to store SQL.

in Diagnostics|Information|Space Used revise how much space left have you in "/"
1.jpg
You do not have the required permissions to view the files attached to this post.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#28

Post by brielem » 09 Jun 2013 19:20

@raulfg3

3MB free... yup, that's not sufficient. But when I'm trying to create a jail, I run into the same (space) issue.
Is it possible to make the OS partition bigger?

@kkd
It's not a real problem if I don't succeed installing MySQL. The main use is still as a NAS, mediaserver etc.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4940
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: problem when trying to install sql

#29

Post by raulfg3 » 09 Jun 2013 19:27

brielem wrote:@raulfg3

3MB free... yup, that's not sufficient. But when I'm trying to create a jail, I run into the same (space) issue.
Is it possible to make the OS partition bigger?
Yes but I only know how to do in full install, not in embeded.

Basically you only need to save your actaul config, do a new fresh full install, and when promt about size of boot partition ( 364MB by default ) use size of your USB key eg: 4000MB or 8000MB ( depends of your USB key size).

boot and restore your previosly saved config.

PD: If you want to use embeded install and install SQL, you need to install TheBrig in your Data Disk that have lots of free Space, and create a jail named "SQL" , and do the install inside the jail ( you can install owncloud and as a side efect you obtain a guide install of SQL, you can use this SQL install and forget owncloud).

some usefull links:

viewtopic.php?f=79&t=3894
viewtopic.php?f=79&t=1565
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

brielem
Starter
Starter
Posts: 18
Joined: 09 Mar 2013 19:13
Location: Netherlands
Status: Offline

Re: problem when trying to install sql

#30

Post by brielem » 09 Jun 2013 19:34

might sound crazy, but:

I haven't installed nas4free on an usb key, but on a partition on the same harddrive as the data partition. If I take that HDD out of the nas, and hook it up to another pc that can read UFS, it should be possible to change the sizes of the partitions on that pc, right? Of course I'll make a backup first...

Post Reply

Return to “WebServer”