Latest News:
2018-11-29: XigmaNAS 11.2.0.4.6229 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

Configuring LAN interface to use VLAN on LAGG Not Working

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
tuaris
experienced User
experienced User
Posts: 86
Joined: 19 Jul 2012 21:31
Contact:
Status: Offline

Configuring LAN interface to use VLAN on LAGG Not Working

#1

Post by tuaris » 31 Dec 2017 23:16

Configuring the LAN interface to use a VLAN with the parent device as a LAGG results in networking not being setup correctly. Example:

Setup lagg0 using two physical devices bge0 and bge1.
Image

Create a vlan0 device for network A and vlan1 device for network B. Both using the newly created lagg0 device as the parent.
Image

Set the LAN interface to use the newly created vlan0 device.
Image

The above config results in an incorrectly configured system at boot time.

Code: Select all

# ifconfig
bge0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=c019b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
	ether 00:21:5e:4d:61:98
	hwaddr 00:21:5e:4d:61:98
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect
bge1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8009b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,LINKSTATE>
	ether 00:21:5e:4d:61:99
	hwaddr 00:21:5e:4d:61:99
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
	groups: lo 
vlan0: flags=8003<UP,BROADCAST,MULTICAST> metric 0 mtu 1500
	ether 00:00:00:00:00:00
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	vlan: 0 vlanpcp: 0 parent interface: <none>
	groups: vlan 
vlan1: flags=8002<BROADCAST,MULTICAST> metric 0 mtu 1500
	ether 00:00:00:00:00:00
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	vlan: 0 vlanpcp: 0 parent interface: <none>
	groups: vlan 

Code: Select all

# cat /etc/rc.conf
...
ifconfig_vlan0="inet 192.168.0.241/24 vlan 1 vlandev lagg0"
defaultrouter="192.168.0.100"
netwait_enable="YES"
netwait_ip="192.168.0.100"
netwait_if="vlan0"
cloned_interfaces="vlan0 vlan1"
...

octave
experienced User
experienced User
Posts: 124
Joined: 30 Sep 2013 12:37
Status: Offline

Re: Configuring LAN interface to use VLAN on LAGG Not Working

#2

Post by octave » 16 Aug 2018 16:52

hi

just a question ==> is your switch accepted vlan and be managed ?
Cluster Pfsense 2.3.x (2wan, 1lan, 1dmz, 1synchro, 1ipmi) in failover mode
Cluster N4f in project (1 lan, 1iscsilan>virtu, 1 synchro, 1 ipmi) 30TB by node raid hard [samba + iscsitarget]
Clsuter virtualisation (1nanaged, 1iscsilan>nas, 1ipmi)

User avatar
tuaris
experienced User
experienced User
Posts: 86
Joined: 19 Jul 2012 21:31
Contact:
Status: Offline

Re: Configuring LAN interface to use VLAN on LAGG Not Working

#3

Post by tuaris » 06 Dec 2018 20:42

Yes, this is a layer 3 managed switch.

Post Reply

Return to “LAN , Network controllers”