*New 11.4 series Release:
2020-07-03: XigmaNAS - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS - released

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

HELP - Getting only GbE transfers on 2 XigmaNAS servers via 10GbE Link

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Posts: 5
Joined: 10 Aug 2013 05:53
Status: Offline

HELP - Getting only GbE transfers on 2 XigmaNAS servers via 10GbE Link


Post by vlad1966 »

Apologies in advance if this isn't the correct forum to post this to.
Also, let me start by saying that I am NOT a networking expert.

My setup:
Main PC with Solar Flare SFN5122F SFP+ 10 10GbE card
Main Server running XigmaNAS with Mellanox ConnectX-3 10GbE card (6 4TB toshiba X300 7200rpm hard drives)
Backup Server running XigmaNAS with Mellanox ConnectX-3 10GbE card (6 4TB 5400rpm hard drives, 4 have 128MB cache, 2 have 256MB Cache)
Backup PC (Doesn't factor into this equation) simply connected via GbE to Motorola Modem/Router
MikroTik CRS305-1G-4S+IN Switch with 4 10GbE SFP+ ports
Motorola Modem/Router

Main PC, Main Server, Backup Server, each connected via DAC cable to Microtik switch
Microtik switch connected from it's GbE port to 1 of the 4 GbE ports on my modem/router
Main PC, each server also has GbE cable connected to GbE port on modem/router

My Backup Server Running XigmaNAS has all of my files on it. My Main Server I just installed XigmaNAS on it, I need to transfer all of my files from my Backup Server to my Main Server.
Of course I'd like to do this at 10GbE speeds. Until this past weekend, I used to have Win10 which I was using on my Main Server.

My situation:

I can't seem to be able to transfer files from the Backup Server to the Main Server at anything close to 10GbE speeds, only GbE speeds (110MB/sec max.) at most:
I've tried using the 10GbE link in my Main PC (disabling all other NICs in the system to make sure only the 10GbE link is used).
I've tried using FTPRush to transfer the files using FXP protocol - nothing but 100MB/sec @ most.

However, if i transfer a large movie file from the SSD of my Main PC to either server, I get anyhwere from 700-1000MB/sec transfer rates.
Each server has 9100 MTU size as well as the Solar Flare card in my Main PC & also the Microtik switch (nice switch BTW).

Not sure what else I can try, except going back to Win10 for my Main Server, which used to get up to 500MB/sec server to server transfers, but I switched since I like XigmaNAS better as a server.
I figure it must be some kind of configuration/network setting in XigmaNAS, but don't know what.


User avatar
Forum Moderator
Forum Moderator
Posts: 799
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Status: Offline

Re: HELP - Getting only GbE transfers on 2 XigmaNAS servers via 10GbE Link


Post by ChriZathens »

110 MB/s is very suspicious
Seems like a configuration issue to me
Try to rule out this by unplugging all GBe links from the servers
An iperf between those two and an rsync from the Backup to main is the next step then
I also think samba has an option to bind to a specific interface, check also that

Sorry, on mobile, can't write much...
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: U-NAS NSC-400, Gigabyte MB10-DS4 (4x4TB Seagate Exos disks in RaidZ configuration - 32GB RAM)

Post Reply

Return to “LAN , Network controllers”