*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Only seeing 2 of 4 ports on Intel Ethernet card (RESOLVED)

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Chucko
Starter
Starter
Posts: 25
Joined: 18 Jan 2016 09:48
Location: Silicon Valley, CA, USA
Status: Offline

Only seeing 2 of 4 ports on Intel Ethernet card (RESOLVED)

#1

Post by Chucko »

I just installed a Intel PRO/1000 PF Quad Port Server Adapter that I got used off eBay into my system. This is based on the Intel 82571EB chip.

For some reason, I'm only seeing ports em0 and em1. Those ports are working fine, lighting up, passing data, etc. Plugging a live Ethernet cable into the other 2 ports fails to light them up.

Am I looking at a broken card, a configuration issue, a known driver problem, ??? This is not a huge deal because I only need one port for now, but I'd like to have all 4 working if I change the network configuration in the future.

NAS4Free 10.3.0.3.2898, Intel Core 2 Quad 9550, Gigabyte EP45-UD3P motherboard. Card is in the PCIe x8 slot.

Thanks for any help.
Last edited by Chucko on 22 Nov 2016 05:45, edited 1 time in total.

Jack Foobar
experienced User
experienced User
Posts: 110
Joined: 07 Jul 2015 01:24
Status: Offline

Re: Only seeing 2 of 4 ports on Intel Ethernet card

#2

Post by Jack Foobar »

Hey.. I have your same setup. Cool.

Well, unless I'm reading your mobo specs wrong, you have one slot that can do x8. The x16 is for video cards only.

http://lime-technology.com/forum/index.php?topic=3739.0


1 x PCI Express x16 slot, running at x16
1 x PCI Express x16 slot, running at x8
(The PCIEx16 and PCIEx8 slots support ATI CrossFireX technology and conform to PCI Express 2.0 standard.)
3 x PCI Express x1 slot
2 x PCI slots

I have a similar issue on mine with a RAID card. It won't detect the damn thing unless I set the PCIE video card settings to on, instead of onboard video, using up my damn ram. And then it'll detect the raid card. This 775 chipset is like a woman scorned. Gotta nudge it just right or it'll stab you in the face.

Chucko
Starter
Starter
Posts: 25
Joined: 18 Jan 2016 09:48
Location: Silicon Valley, CA, USA
Status: Offline

Re: Only seeing 2 of 4 ports on Intel Ethernet card

#3

Post by Chucko »

I have an old GeForce 9600 card in the x16 slot, but I'm not using it for anything but monitoring the boot process. All the more reason to keep an eye peeled for used server mobos on eBay.

Chucko
Starter
Starter
Posts: 25
Joined: 18 Jan 2016 09:48
Location: Silicon Valley, CA, USA
Status: Offline

Re: Only seeing 2 of 4 ports on Intel Ethernet card

#4

Post by Chucko »

I just installed a newer vintage Intel Quad Port Server Adapter i340-T4 (an OEM card for an IBM system) and it sees all 4 ports. Plus it burns less power. So the problem is solved, but the mystery remains.

Post Reply

Return to “LAN , Network controllers”