*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

New system, WOL and Dual LAN questions

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Floh
Starter
Starter
Posts: 24
Joined: 10 Feb 2013 22:55
Status: Offline

New system, WOL and Dual LAN questions

#1

Post by Floh »

I just got my new server up and running.
Short system description: ASROCK C2750D4I board, 16GB ECC RAM, 6x4TB WD RED running as RAIDZ2, with NAS4Free 11.0.0.4 embedded 64bit.

My whole network runs on wired gigabit ethernet, as I hate WIFI with a passion.It's only good for phones and tablets IMO.

Main reasons why I built a new server (aside from the old one going on full):
I wanted it to power down when nobody was accessing it, also power up when data was requested, and I wanted to be able to use dual LAN. For this reason, I also bought a much better switch than I had previously (HP1820G 24 port Gigabit switch).

So here I am, with a pretty fresh system, and so far I haven't gotten anything from the list above to work. I read in another post here that WOL is not supported well, and IPMI should be used, my board has that ability, but I have no idea how to get my clients to use IPMI. I run a few Kodi machines on OpenElec, and there is a great addon that wakes the server up whenever a client is started up, but it's magic packet only I think. I am not very Linux savvy, but I could probably get a few lines of script to run on boot if that will give me the ability to wake my server up.

Regarding link aggregation, I followed the advice from this thread http://forums.nas4free.org/viewtopic.php?t=357
to make it work, but all I got was having to run down to the basement with a monitor and a keyboard to reset my network connection on the terminal, because the server stopped showing up in my network (no IP address). Either of the LANs will work, but connecting them together got me nowhere.

Do I need to do anything on the switch configuration to make it treat two connections as one? There is a trunking option in the web GUI of the switch, and I tried that, but it did not get my server back online.

jonyyybe
NewUser
NewUser
Posts: 14
Joined: 24 Dec 2016 22:27
Location: UK
Status: Offline

Re: New system, WOL and Dual LAN questions

#2

Post by jonyyybe »

Hi there,

You should note hate the Wi-Fi (well in my case I'm trying to get rid of cables :) not a big fan but I would like gigabit transfers from it in the next 3y) so bad, but i do agree with you as its good for phones, tablets and small appliances (small N4F as mine).

In regards to your link aggregation (i dont know in the N4F, but from networks) should apply same rule - link aggregation needs to be setup on both ends before rebooting any devices - not trunking mode :)

It is generally recommended that ports are first aggregated and then physically connect the aggregated ports. Be sure to configure the aggregate (or have LACP enabled) on both ends of the link.
Version 11.0.0.4 - Sayyadina (revision 3330)
Platform x64-embedded on Intel(R) Core(TM) i3-6100T CPU @ 3.20GHz
System GA-Z170N-WIFI-CF, 16GB RAM, White Node 304, Bequiet 450W Gold - all collers stock
ZFS RAID-Z2 - 6x1TB-RAIDZ2 (4WD+2Segate)

Post Reply

Return to “LAN , Network controllers”