*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[ LACP + iSCSI + ESXi + MPIO ] experience ?

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
justin
Starter
Starter
Posts: 19
Joined: 22 Jul 2013 15:10
Status: Offline

[ LACP + iSCSI + ESXi + MPIO ] experience ?

#1

Post by justin »

We try to find the better solution to configure iSCSI NAS4FREE with ESXi.

We have 2 nic on each ESXi.

We have 4 nic on our NAS4Free.

I would like to use 2 nic on each ESXi without LACP but with 2 ip and MPIO.

I would like to use 4 nic in LACP over a CISCO Catalyst 2950 to have only 1 IP.

Is there somebody what use this config to test? in production? Results?

Thank you,

Best regards,
Justin
- NAS4Free 9.1.0.1 x64-full 804 | x64-full on Intel(R) Xeon(R) CPU E5620 @ 2.40GHz | 98271MiB RAM | X x YTB WD ZFS mirror stripping compressed, Z x YTB WD ZFS zraid2 | 2 SSD ZIL, 1 SSD LOG
- NAS4Free 9.1.0.1 x64-full 804 | x64-full on Intel(R) Xeon(R) CPU E5620 @ 2.40GHz | 98271MiB RAM | Z x YTB WD ZFS zraid2

justin
Starter
Starter
Posts: 19
Joined: 22 Jul 2013 15:10
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#2

Post by justin »

Noone try solution like that?

Best regards,
Justin
- NAS4Free 9.1.0.1 x64-full 804 | x64-full on Intel(R) Xeon(R) CPU E5620 @ 2.40GHz | 98271MiB RAM | X x YTB WD ZFS mirror stripping compressed, Z x YTB WD ZFS zraid2 | 2 SSD ZIL, 1 SSD LOG
- NAS4Free 9.1.0.1 x64-full 804 | x64-full on Intel(R) Xeon(R) CPU E5620 @ 2.40GHz | 98271MiB RAM | Z x YTB WD ZFS zraid2

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#3

Post by raulfg3 »

people with experience on LACP + iSCSI + ESXi + MPIO are scarce, I have no experience for example. (sorry if scarce is not the word I use google traslator)
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Mindheat
Starter
Starter
Posts: 25
Joined: 16 Dec 2013 06:36
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#4

Post by Mindheat »

Hi Justin

i would like to do the same as you.

Nas4Free as a iSCSI device for my ESXi Host, both with 2 Nic`s in LACP.

But my Nas4free do not work with LACP on my Edgecore Switch, the EdgeCore is still connected to a Zyxel GS 1910 in LACP with two NICS and work smoothly.

All my 4 VLAN are useable on both Switches, but the NAs4Free will not work. Not even in the default Vlan1 ;)

So if you have any ideas for me it would be helpfully.

Thanks and best Regards

Mindheat

User avatar
STAMSTER
Starter
Starter
Posts: 72
Joined: 23 Feb 2014 15:58
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#5

Post by STAMSTER »

Read on this article: NAS4Free MPIO with VMWare ESXi 5.1
http://n4f.siftusystems.com/index.php/2 ... e-esxi-51/

P.S. I'm trying to achieve this setup only without VLAN's - using good old subnets (via Mikrotik).
rIPMI

mbze430
experienced User
experienced User
Posts: 95
Joined: 20 Nov 2014 05:41
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#6

Post by mbze430 »

anyone successfully configure LACP + iSCSI + ESXi + MPIO with NAS4Free?

I currently have a NAS4Free NAS with 4x1Gb NIC in a LACP but using NFS with ESXi hosts, I have 2 EXSi host, each with 2x1Gb NIC in Static LAG. From what I have read with the LACP+MPIO on ESXI with iSCSI you can saturate beyond the 1Gb
NAS #1 - 11.2.0.4 - Omnius (revision 6625) - SuperMicro X10SL7-F w/ 24GB ECC - LSI SAS 9207-16i - 2x RAIDZ1 (10x3TB) Pools and 1x (2x4TB) Stripe Pool
NAS #2 - 11.2.0.4 - Omnius (revision 6625) - SuperMicro X10SLM-F w/32GB ECC - LSI SAS 9207-8i (RAID10) - IBM M1015-IT Mode (RAID10)

Eliminateur
Starter
Starter
Posts: 58
Joined: 20 Jul 2012 16:31
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#7

Post by Eliminateur »

AFAIK using LACP for iscsi is not needed or recommended as you're doing double redundancy as iSCSI has excellent failure tolerance using MPIO.
so if your N4F has 2 iscsi nics and each of your servers has 2 NIC then you configure iscsi targets for both IP of the N4F nic and configure the load balance policy for 1 IO and round robin, forcing each io to use a separate port, by playing with subnets and addressing you can get a load balanced resilient config WITHOUT LACP.

check out this guide, is for a EMC VNXe setup but the steps are exactly the same for N4F https://communities.vmware.com/people/h ... 2/vnxe3150

in short: ditch LACP for iSCSI, stay with round robin and multipath, iscsi can handle the failures instantly

i have configured esxi with n4f iscsi but only 1 nic (it's a backup nas)

User avatar
STAMSTER
Starter
Starter
Posts: 72
Joined: 23 Feb 2014 15:58
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#8

Post by STAMSTER »

+1 for iSCSI, and -1 for LACP! You don't ever need LACP if using iSCSI multipath :)
rIPMI

User avatar
STAMSTER
Starter
Starter
Posts: 72
Joined: 23 Feb 2014 15:58
Status: Offline

Re: [ LACP + iSCSI + ESXi + MPIO ] experience ?

#9

Post by STAMSTER »

time dd if=BigTestFile.zfs of=/dev/null bs=512K
10240+0 records in
10240+0 records out
5368709120 bytes (5.4 GB) copied, 46.1671 s, 116 MB/s

real 0m46.168s
user 0m0.013s
sys 0m2.142s
^^ that result is directly from VM hosted on a ESXi, and with special mount point pointed directly to the N4F box as an iscsi initiator. :)
rIPMI

Post Reply

Return to “LAN , Network controllers”