*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

USB WiFi adapter

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
ssjoco
NewUser
NewUser
Posts: 5
Joined: 19 May 2015 23:14
Status: Offline

USB WiFi adapter

#1

Post by ssjoco »

Hi,
I installed NAS4free 10.2.0.2 on rpi2 and I need a Wifi connection. I have a Ralink USB Wifi but I can't get to work. I'can add the adapter in the GUI.
I tried to configure from cli, it seems to be working. FreeBSD recognise after ifconfig wlan0 create wlandev run0 command, but the config lost every reboot.

Any idea?
Thanks

User avatar
daoyama
Developer
Developer
Posts: 422
Joined: 25 Aug 2012 09:28
Location: Japan
Status: Offline

Re: USB WiFi adapter

#2

Post by daoyama »

ssjoco wrote: I installed NAS4free 10.2.0.2 on rpi2 and I need a Wifi connection. I have a Ralink USB Wifi but I can't get to work. I'can add the adapter in the GUI.
It seems new kernel has changed wlan device. Please wait next build.
Until next image, please create wlan from CLI by hand.


Latest version support WLAN from WebGUI.
If you have old WLAN, try to remove it and re-create it.
NAS4Free 10.2.0.2.2115 (x64-embedded), 10.2.0.2.2258 (arm), 10.2.0.2.2258(dom0)
GIGABYTE 5YASV-RH, Celeron E3400 (Dual 2.6GHz), ECC 8GB, Intel ET/CT/82566DM (on-board), ZFS mirror (2TBx2)
ASRock E350M1/USB3, 16GB, Realtek 8111E (on-board), ZFS mirror (2TBx2)
MSI MS-9666, Core i7-860(Quad 2.8GHz/HT), 32GB, Mellanox ConnectX-2 EN/Intel 82578DM (on-board), ZFS mirror (3TBx2+L2ARC/ZIL:SSD128GB)
Develop/test environment:
VirtualBox 512MB VM, ESXi 512MB-8GB VM, Raspberry Pi, Pi2, ODROID-C1

User avatar
F8BOE
experienced User
experienced User
Posts: 106
Joined: 03 Jun 2013 23:09
Location: France
Status: Offline

Re: USB WiFi adapter

#3

Post by F8BOE »

Hello,

Merely the same problem here under 10.2.0.2.2234 with an Edimax EW-7811Un which came with my Renkforce distributed RPi2.
As for this post: viewtopic.php?f=58&t=8834#p53591
The WLAN adapter is configured and recognised, but in AP mode it does not work:

kernel: urtwn0: HOSTAP mode not supported

And in client mode it does not connect to any of my WLAN APs (WPA2, b+g mode, SSID hidden, short preamble).

kernel: wlan0: ieee80211_new_state_locked: pending INIT -> SCAN transition lost

It also seems that the WLAN function is broken as the OPT1 configuration when used the first time before reboot lacks the "Mode" (802.11b, 802.11g, else), and when it runs after reboot, WLAN channels 12 and 13 are missing in the list??? Are these really the European WLAN channels that are programmed?

The WLAN adapter works perfectly on the RPi2 under Ubuntu Mate.

Ciao @+

User avatar
daoyama
Developer
Developer
Posts: 422
Joined: 25 Aug 2012 09:28
Location: Japan
Status: Offline

Re: USB WiFi adapter

#4

Post by daoyama »

F8BOE wrote:kernel: urtwn0: HOSTAP mode not supported
Not all card (firm/driver) have ap mode. This is not limit of NAS4Free nor FreeBSD.
F8BOE wrote: And in client mode it does not connect to any of my WLAN APs (WPA2, b+g mode, SSID hidden, short preamble).
According to the man page, urtwn need:

legal.realtek.license_ack=1

in loader.conf. Did you set it? In NAS4Free GUI, you can set from System|Advanced|loader.conf.

Note that some previous version does not work with bridge as expected.
Please use latest NAS4Free if you want use Bridge.
NAS4Free 10.2.0.2.2115 (x64-embedded), 10.2.0.2.2258 (arm), 10.2.0.2.2258(dom0)
GIGABYTE 5YASV-RH, Celeron E3400 (Dual 2.6GHz), ECC 8GB, Intel ET/CT/82566DM (on-board), ZFS mirror (2TBx2)
ASRock E350M1/USB3, 16GB, Realtek 8111E (on-board), ZFS mirror (2TBx2)
MSI MS-9666, Core i7-860(Quad 2.8GHz/HT), 32GB, Mellanox ConnectX-2 EN/Intel 82578DM (on-board), ZFS mirror (3TBx2+L2ARC/ZIL:SSD128GB)
Develop/test environment:
VirtualBox 512MB VM, ESXi 512MB-8GB VM, Raspberry Pi, Pi2, ODROID-C1

User avatar
F8BOE
experienced User
experienced User
Posts: 106
Joined: 03 Jun 2013 23:09
Location: France
Status: Offline

Re: USB WiFi adapter

#5

Post by F8BOE »

Hello,

As I wrote I use 10.2.0.2.2234...

legal.realtek.license_ack is set to 1 in loader.conf, but I guess that it needs to see it in the real loader.conf file, which is still "virtual" in an embedded installation...

This adapter definitely do not run in host mode. I tried it on my MGA4 box and it also lacks channels 12 and 13, but it works perfectly on the Ubuntu Mate on my RPi2 (on channel 12)??? Flawlessly and reliable as it should!

There are also no connection possible using my MGA4 computer (Vaio FW-54M), the driver didn't have to be installed when I plugged the adapter, so I think the driver was installed by default when I installed the OS.

As soon as possible I will try it on my only MGA5 box... Perhaps there was an update needed to the driver...

Err NOOOOOOOOOO!
It just has broken in pieces as I pulled it out of my RPi2!

For heaven's sake, DO NOT BUY ANY EDIMAX OR OTHER BULLSHITE FROM CHINA UNTIL YOU WANT TO WASTE YOUR MONEY IN BAD QUALITY!

Amen.
So long bye-bye WiFi crap!

Ciao @+

Post Reply

Return to “LAN , Network controllers”