*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Issue replacing a failed drive(R1) on an old install

Hard disks, HDD, RAID Hardware, disk controllers, SATA, PATA, SCSI, IDE, On Board, USB, Firewire, CF (Compact Flash)
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Eliminateur
Starter
Starter
Posts: 51
Joined: 20 Jul 2012 16:31
Status: Offline

Issue replacing a failed drive(R1) on an old install

#1

Post by Eliminateur » 04 Feb 2016 15:09

Hello,
i have a box with 9.0.0.1 (for diverse reasons i can't upgrade so not the point) with a 2 disk ZFS mirror.

one of the drives failed, i replaced it with a different brand one, and when i check the webgui in disk|management y saw the old model in the name but the comment showed the new model!.
So i deleted the disk there so that it can de detected with the correct model number....

well that's where things went bad, pressing redetect does nothing, i rebooted, power cycled, powered up with drive removed, i cleansed the disk again just in case, nothing, BUT the disk is shown on the smart info.

if i want to replace it i get:

Code: Select all

Welcome to NAS4Free!mastnas:~# zpool status poolhdd
  pool: poolhdd
 state: DEGRADED
status: One or more devices could not be opened.  Sufficient replicas exist for
        the pool to continue functioning in a degraded state.
action: Attach the missing device and online it using 'zpool online'.
   see: http://www.sun.com/msg/ZFS-8000-2Q
 scan: scrub repaired 0 in 0h39m with 0 errors on Tue Feb  2 04:40:06 2016
config:

        NAME                    STATE     READ WRITE CKSUM
        poolhdd                 DEGRADED     0     0     0
          mirror-0              DEGRADED     0     0     0
            ada0.nop            ONLINE       0     0     0
            636574886888084722  UNAVAIL      0     0     0  was /dev/ada1.nop

errors: No known data errors
mastnas:~# zpool status poolhd
cannot open 'poolhd': no such pool
mastnas:~# zpool replace poolhdd 636574886888084722 /dev/ada1.nop
invalid vdev specification
use '-f' to override the following errors:
/dev/ada1.nop is part of potentially active pool 'tank'
mastnas:~# zpool replace poolhdd /dev/ada1.nop
invalid vdev specification
use '-f' to override the following errors:
/dev/ada1.nop is part of potentially active pool 'tank'
i tried with /dev/ada1 alone and again.

what do i do?, do i force the replace?, why isn't it showing on the disk|management even after a rescan?

User avatar
b0ssman
Forum Moderator
Forum Moderator
Posts: 2458
Joined: 14 Feb 2013 08:34
Location: Munich, Germany
Status: Offline

Re: Issue replacing a failed drive(R1) on an old install

#2

Post by b0ssman » 04 Feb 2016 16:11

you seem to have a pool tank.

only if you are absolutely sure that ada1 is free wipe the disc using this
http://www.zoonsweb.nl/wiki/doku.php?id=faq:0129
Nas4Free 11.1.0.4.4517. Supermicro X10SLL-F, 16gb ECC, i3 4130, IBM M1015 with IT firmware. 4x 3tb WD Red, 4x 2TB Samsung F4, both GEOM AES 256 encrypted.

Eliminateur
Starter
Starter
Posts: 51
Joined: 20 Jul 2012 16:31
Status: Offline

Re: Issue replacing a failed drive(R1) on an old install

#3

Post by Eliminateur » 04 Feb 2016 16:17

i already wiped the drive very thoroughly between the tests, more than what the mbr+gpt does.

ended up forcing the replace, it's still running the resilver

Eliminateur
Starter
Starter
Posts: 51
Joined: 20 Jul 2012 16:31
Status: Offline

Re: Issue replacing a failed drive(R1) on an old install

#4

Post by Eliminateur » 04 Feb 2016 20:14

Resilver completed, i then added the disk with the + icon(completely forgot about that) so it was a PEBKAC.

solved

Post Reply

Return to “Hard disk & controller”