*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

SMART scheduled tests not running

Hard disks, HDD, RAID Hardware, disk controllers, SATA, PATA, SCSI, IDE, On Board, USB, Firewire, CF (Compact Flash)
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
papaf76
NewUser
NewUser
Posts: 3
Joined: 29 Aug 2016 08:58
Status: Offline

SMART scheduled tests not running

#1

Post by papaf76 »

Hi all,
I'm running 10.2.0.2 Prester rev 2545. I'm having issues with smart, in that scheduled SMART tests are not executed. I ran one by hand and it worked fine, I can see the lone test reported on all my drives, however no additional tests are being appended even if I have them scheduled.
I understand there was some issue with the day of week numbering, so I tried selecting several days (tried sunday, saturday and monday) to no avail.

Any input would be appreciated.

Thanks!

User avatar
tony1
Moderator
Moderator
Posts: 171
Joined: 14 Jul 2016 19:04
Status: Offline

Re: SMART scheduled tests not running

#2

Post by tony1 »

make sure smart is enabled on the disk. Disks|Management|HDD Management
then schedule a test in Disks|Management|S.M.A.R.T.
select "8" for hours, "all" for days, "all" for months, and "Wednesday" for week days.
test type short.
this will run a short test on the selected drive every Wednesday @ 8:00

repeat for other drives on your system.
take care!

papaf76
NewUser
NewUser
Posts: 3
Joined: 29 Aug 2016 08:58
Status: Offline

Re: SMART scheduled tests not running

#3

Post by papaf76 »

Thanks for the reply.

SMART was already enabled, but in the meantime, I shed some light into the issue. I chose a specific day of the month, yesterday (31) and an hour and I left the day of the week alone. This way the short test ran without an hitch.
I mean, for my usage, I can pick some days in the month and be done with it, but there's something fishy with the DoW setting.

User avatar
tony1
Moderator
Moderator
Posts: 171
Joined: 14 Jul 2016 19:04
Status: Offline

Re: SMART scheduled tests not running

#4

Post by tony1 »

seems to work fine for me, it is probably how you are selecting the time for it to run.
another example would be "weekdays = Wednesday" "days = 28, 26, 30 etc" would be the last Wednesday of the month.

papaf76
NewUser
NewUser
Posts: 3
Joined: 29 Aug 2016 08:58
Status: Offline

Re: SMART scheduled tests not running

#5

Post by papaf76 »

Hm, this could all boil down to how pages are rendered in my chrome browser. It's really really hard to make out what I selected on the various fields. Maybe a different color could be chosen? Is it possible to change it somehow?

kenZ71
Advanced User
Advanced User
Posts: 401
Joined: 27 Jun 2012 20:18
Location: Northeast, USA
Status: Offline

Re: SMART scheduled tests not running

#6

Post by kenZ71 »

smart must run as root
11.2-RELEASE-p3 | ZFS Mirror - 2 x 8TB WD Red | 28GB ECC Ram
HP ML10v2 x64-embedded on Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz

Extra memory so I can host a couple VMs
1) Unifi Controller on Ubuntu
2) Librenms on Ubuntu

Post Reply

Return to “Hard disk & controller”