*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Drive formatting problem (GUI)

Hard disks, HDD, RAID Hardware, disk controllers, SATA, PATA, SCSI, IDE, On Board, USB, Firewire, CF (Compact Flash)
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
N4Fuser
NewUser
NewUser
Posts: 6
Joined: 25 Jan 2016 15:16
Status: Offline

Drive formatting problem (GUI)

#1

Post by N4Fuser »

Hi,

I don't see any drive in Disks|Management|HDD Format.
I've updated to 10.3.0.3.3379 - tested with 2 different hardware sets, different browsers (one of them chromium based).
In Disks|Management|HDD Management - all drives are present with a Filesystem "unknown or unformatted" - but in "HDD Format" can not choose any of these drives: the are not there (see attached screenshot).

Can anyone confirm/test such a behaviour in 10.3.0.3.3379?

Thanks in advance

Regards,
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5116
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Drive formatting problem (GUI)

#2

Post by raulfg3 »

save your config and atach it ( delete password if neded), in a zip file to revise the HD section.
And post an screen capture of Disks > Management > HDD Management
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

N4Fuser
NewUser
NewUser
Posts: 6
Joined: 25 Jan 2016 15:16
Status: Offline

Re: Drive formatting problem (GUI)

#3

Post by N4Fuser »

is attached now
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5116
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Drive formatting problem (GUI)

#4

Post by raulfg3 »

Please use button "Clean config & import Disk", and send new screen capture, please do not configure this time:
standbyTime, APM & Acoustic , I prefer to use default values untill the problem is identify. (you use 60 minutes of stanbytime, Acoustic=64 and APM=127

Code: Select all

	<uuid>e5e5b2f6-50d5-4651-ac4e-057e2fd40cdb</uuid>
			<name>ada2</name>
			<id>2</id>
			<devicespecialfile>/dev/ada2</devicespecialfile>
			<model>Hitachi HDE721010SLA330</model>
			<desc>Hitachi Deskstar E7K1000</desc>
			<type>SCSI</type>
			<serial>Some_Serial</serial>
			<size>953870MB</size>
			<harddiskstandby>60</harddiskstandby>
			<acoustic>64</acoustic>
			<apm>127</apm>
			<transfermode>auto</transfermode>
			<controller>ahcich</controller>
			<controller_id>2</controller_id>
			<controller_desc>Intel Cougar Point AHCI SATA controller</controller_desc>
			<smart>
				<devicefilepath>/dev/ada2</devicefilepath>
				<devicetype>atacam</devicetype>
				<devicetypearg>atacam</devicetypearg>
				<extraoptions/>
			</smart>
		</disk>
PD: How do you configure disk in BIOS?, perhaps in IDE or RAID Mode? (Must be on ahci mode).

Can you send me some photos of how disk are configured in BIOS?
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

N4Fuser
NewUser
NewUser
Posts: 6
Joined: 25 Jan 2016 15:16
Status: Offline

Re: Drive formatting problem (GUI)

#5

Post by N4Fuser »

I don't know, what standby and acoustic has to do with (dis-)appearing of disks in "Format HDD"-tab, but it's ok.
I've done (one more time) "Clear config & import disks" and now screen shot looks pretty the same - except of "Standby" column: now there are "Always on" for every HDD. Screen shot of BIOS is attached.

Have a question: do you see in your NAS all your disks in Disks|Management|HDD Format? (if you have 10.3.0.3.3379)
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5116
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Drive formatting problem (GUI)

#6

Post by raulfg3 »

N4Fuser wrote:
13 Jan 2017 11:11
Have a question: do you see in your NAS all your disks in Disks|Management|HDD Format? (if you have 10.3.0.3.3379)
No, only disk that are not in use.

in your case is normal that do not appear any disk, because all of your disk are in use ( are in use in your pool), so this is not the real fault , for me the real fault is that do not apear like ZFS formatted disk in Disks|Management|HDD management
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

User avatar
mooblie
experienced User
experienced User
Posts: 88
Joined: 23 Jun 2012 13:31
Location: The Highlands, Scotland
Contact:
Status: Offline

Re: Drive formatting problem (GUI)

#7

Post by mooblie »

raulfg3 wrote:
13 Jan 2017 11:31
.... for me the real fault is that do not apear like ZFS formatted disk in Disks|Management|HDD management

Agreed. Surely it would be better if ALL disks appeared in the Disks|Management|HDD Format GUI Page?

Clearly there should be big warnings given before you format any disk, but that's expected.

Can we make a feature request to at least debate the benefits/risks of doing this?
Martin

N4Fuser
NewUser
NewUser
Posts: 6
Joined: 25 Jan 2016 15:16
Status: Offline

Re: Drive formatting problem (GUI)

#8

Post by N4Fuser »

I don't think so. They are not in pool - I took even another HDD's set. They are unformatted - I've to format they to create a new pool. I can't format - so they are not in disks list for vdev, zpool can't be created. I can't delete an old one also - see attached screen shots.
You do not have the required permissions to view the files attached to this post.

N4Fuser
NewUser
NewUser
Posts: 6
Joined: 25 Jan 2016 15:16
Status: Offline

Re: Drive formatting problem (GUI)

#9

Post by N4Fuser »

Ok - I've fixed this: removed disks, another set of unformatted disks (have backup) - not appeared in HDD Format tab;
System -> Factory Defaults. Reboot, added disks - now they are visible in HDD Format.

Thanks for your help.

Post Reply

Return to “Hard disk & controller”