*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[SOLVED] ASrock J3455-ITX won't boot NAS4Free

Motherboard compatibillity with XigmaNAS, questions, answers, suggestions
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
MisterPiggo
NewUser
NewUser
Posts: 9
Joined: 22 Jun 2017 02:44
Status: Offline

[SOLVED] ASrock J3455-ITX won't boot NAS4Free

#1

Post by MisterPiggo » 22 Jun 2017 02:53

Hi,

I have a little problem with NAS4Free and my motherboard. I have a ASrock J3455-ITX and it won't boot NAS4Free.
I already tried the following things:
- Update the motherboard;
- Booted a Windows USB (Worked)
- Booted a Linux USB (Worked)
- Booted FreeNAS, this only worked when I installed FreeNAS with UEFI, I already changed the boot settings to legacy but legacy won't boot;
- Fully installed NAS4Free on a USB drive with a virtual environment and tried booting that one (Did not work);
- Tried USBs from different sizes (4, 16, 32 and 64 GB) and different manufactures (Sony, Kingston, Duracell, Icizu);
- Booted the Fully installed NAS4Free on another computer (Worked)
- Fully installed NAS4Free in mbr mode, gpt mode, both with and without swap (Did not work);
- I tried installing both ISOs from NAS4Free and FreeNas on my proxmox server and that works.

I hope someone could help, thanks
Last edited by MisterPiggo on 23 Jun 2017 16:39, edited 1 time in total.

tron44
Starter
Starter
Posts: 34
Joined: 18 Feb 2013 20:04
Status: Offline

Re: ASrock J3455-ITX won't boot NAS4Free

#2

Post by tron44 » 22 Jun 2017 08:04

Hi,
I had a 3455B a while ago.
To make it work, you need to change the following in the bios:
- turn on the CSM (Compatibility Support Module)
- set the C-States to off or 0 (I don't remember)

good luck

MisterPiggo
NewUser
NewUser
Posts: 9
Joined: 22 Jun 2017 02:44
Status: Offline

Re: ASrock J3455-ITX won't boot NAS4Free

#3

Post by MisterPiggo » 22 Jun 2017 16:46

Wauw thanks a lot, turning on the CSM worked for me :)

But I have still a question, where are the C-states for?? Because right now I have it working without turning off the C-states.

Thanks a lot

noclaf
experienced User
experienced User
Posts: 125
Joined: 08 Dec 2013 12:37
Status: Offline

Re: ASrock J3455-ITX won't boot NAS4Free

#4

Post by noclaf » 23 Jun 2017 09:37

C states are CPU operational states - used for power-saving.
C0 - is the "full operation" state and any higher number means some level of sleep.
http://www.hardwaresecrets.com/everythi ... ing-modes/

tron44
Starter
Starter
Posts: 34
Joined: 18 Feb 2013 20:04
Status: Offline

Re: ASrock J3455-ITX won't boot NAS4Free

#5

Post by tron44 » 23 Jun 2017 11:14

according to this site, the system is way faster without C-States:
( because FreeBSD 11 did not fully support the Apollo Lake )
https://forums.freebsd.org/threads/59653/

quote:
I did several tests on meassuring the computing time of "freebsd-update fetch", results:
1) C-States up to C3 -> time: about 27minutes
2) C-States up to C1 -> time: about 7 minutes
3) C-States off: time: 40 seconds
btw. he uses a ASRock J4205-ITX

MisterPiggo
NewUser
NewUser
Posts: 9
Joined: 22 Jun 2017 02:44
Status: Offline

Re: ASrock J3455-ITX won't boot NAS4Free

#6

Post by MisterPiggo » 23 Jun 2017 15:43

Thanks a lot for your help guys, I will test this when I get home.

WoodrowStool
NewUser
NewUser
Posts: 7
Joined: 13 Feb 2015 00:45
Status: Offline

Re: [SOLVED] ASrock J3455-ITX won't boot NAS4Free

#7

Post by WoodrowStool » 18 Aug 2017 01:10

I'm having a similar problem with the ASRock J4205-ITX - this is the same board as the J3455-ITX but with a slightly faster processor. I have enabled CSM (the legacy BIOS compatibility mode) so it begins to boot NAS4Free but it hangs on:

Timecounter "HPET" frequency 19200000 Hz quality 950

and that is as far as it will go. Some discussion on the FreeBSD.org forums about this, other than enabling CSM not alot of suggestions. I am booting a fresh install of the lastest NAS4Free and the UEFI firmware in the motherboard is the latest.

Has anyone got this to work?

WoodrowStool
NewUser
NewUser
Posts: 7
Joined: 13 Feb 2015 00:45
Status: Offline

Re: [SOLVED] ASrock J3455-ITX won't boot NAS4Free

#8

Post by WoodrowStool » 18 Aug 2017 04:45

From the NAS4Free boot console (option 5 when it boots): set hint.hpet.0.clock=0

This solves the boot problem (thanks to a recent post on Freebsd.org). Now where do I put this permanently? The gui gives me load.conf, rc.conf, or sysctl.conf as options.

User avatar
ChriZathens
Forum Moderator
Forum Moderator
Posts: 833
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Contact:
Status: Offline

Re: [SOLVED] ASrock J3455-ITX won't boot NAS4Free

#9

Post by ChriZathens » 18 Aug 2017 13:24

Hmm, don't quote me on this, but I believe it must be in loader.conf
Give it a try and let us know of the result!
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS 11.2.0.4.6625 -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: HP N40L (4x1TB HP branded Seagate disks in RaidZ configuration - 8GB ECC RAM)

Post Reply

Return to “Motherboards”