*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Boot error: kernel: pcib0: _OSC returned error 0x10

Motherboard compatibillity with XigmaNAS, questions, answers, suggestions
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
maarten
Starter
Starter
Posts: 38
Joined: 17 Jul 2012 20:20
Status: Offline

Boot error: kernel: pcib0: _OSC returned error 0x10

#1

Post by maarten » 15 Nov 2018 12:25

Hi devs,

First, thanks for your great work on XigmaNAS !

When booting I get following error:
Nov 15 13:17:58 xigmanas kernel: pci0: <ACPI PCI bus> on pcib0
Nov 15 13:17:58 xigmanas kernel: pcib0: _OSC returned error 0x10
Nov 15 13:17:58 xigmanas kernel: pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
How I can solve this?

Regards, Maarten

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1160
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: Boot error: kernel: pcib0: _OSC returned error 0x10

#2

Post by JoseMR » 15 Nov 2018 13:59

maarten wrote:
15 Nov 2018 12:25
Hi devs,

First, thanks for your great work on XigmaNAS !

When booting I get following error:
Nov 15 13:17:58 xigmanas kernel: pci0: <ACPI PCI bus> on pcib0
Nov 15 13:17:58 xigmanas kernel: pcib0: _OSC returned error 0x10
Nov 15 13:17:58 xigmanas kernel: pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
How I can solve this?

Regards, Maarten

You may want to look HERE for reference.

On XigmaNAS Embedded Platform the fix is abit more hackish though, you may also need a modified config.xml including the "hw.pci.realloc_bars=1" sysctl tunable and after installation, while still in the Live system you have to mount the target install partition and overwrite default config.xml, then reboot.

On XigmaNAS Full Platforms simply after install open the shell console and type the below command and reboot:

Code: Select all

echo hw.pci.realloc_bars=1 | tee -a /etc/sysctl.conf
Regard
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
Addons at GitHub
JoseMRPubServ
Boot Environments Intro

maarten
Starter
Starter
Posts: 38
Joined: 17 Jul 2012 20:20
Status: Offline

Re: Boot error: kernel: pcib0: _OSC returned error 0x10

#3

Post by maarten » 15 Nov 2018 17:01

Thanks!

I use XigmaNAS embedded. Not clear to me how to fix it...

Maybe developers can fix it in forthcoming release?

Maarten
Last edited by maarten on 15 Nov 2018 17:59, edited 3 times in total.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1160
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: Boot error: kernel: pcib0: _OSC returned error 0x10

#4

Post by JoseMR » 15 Nov 2018 17:29

maarten wrote:
15 Nov 2018 17:01
Thanks!

I use XigmaNAS embedded. Not clear to me how to fix.

Maarten
EDIT: Fount the thread HERE

Ok I assume you can boot just fine but you want to suppress the error message, in that case just follow this simple steeps:

1: Go to "System > Advanced > sysctl.conf" and click on the [+] icon to add the sysctl tunable.
2: Create a new sysctl tunable for "hw.pci.realloc_bars" with value of "1" .
3: Reboot and watch for the error if solved.

System Tunable Screenshot:
sysctl_sys_tune.png
Regards
You do not have the required permissions to view the files attached to this post.
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
Addons at GitHub
JoseMRPubServ
Boot Environments Intro

maarten
Starter
Starter
Posts: 38
Joined: 17 Jul 2012 20:20
Status: Offline

Re: Boot error: kernel: pcib0: _OSC returned error 0x10

#5

Post by maarten » 15 Nov 2018 17:42

Thanks a lot ! I will try and let you know. You are right: my system boots but gives error.

update:
Does not help. Overwriting config.xml in installation path (/cf/conf/config.xml) is the same as changing config through web interface.
Tried both. It won't solve the problem.

Kind regards, Maarten

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1160
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: Boot error: kernel: pcib0: _OSC returned error 0x10

#6

Post by JoseMR » 15 Nov 2018 23:29

maarten wrote:
15 Nov 2018 17:42
Thanks a lot ! I will try and let you know. You are right: my system boots but gives error.

update:
Does not help. Overwriting config.xml in installation path (/cf/conf/config.xml) is the same as changing config through web interface.
Tried both. It won't solve the problem.

Kind regards, Maarten

Hi Maarteen, yes overwriting config was a workaround just in case your Embedded system can't boot, if this tunable is of no help and system seems working ok, you can safely delete the tunable and ignore the error until a better solution.

Regards
System: FreeBSD 12 RootOnZFS, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
Addons at GitHub
JoseMRPubServ
Boot Environments Intro

maarten
Starter
Starter
Posts: 38
Joined: 17 Jul 2012 20:20
Status: Offline

Re: Boot error: kernel: pcib0: _OSC returned error 0x10

#7

Post by maarten » 16 Nov 2018 11:42

Hi Jose,

Thanks, I can boot and system seems to work normally... so I will ignore the error since changing the tunable has no effect.

Maarten

Post Reply

Return to “Motherboards”