Page 1 of 1

Dlink-DIR 825 link speed issue

Posted: 17 Sep 2015 16:58
by sene4kin
Hello there! Can you help me please. I installed Nas4free 10.2.0.2 server connected with my router Dlink-DIR 825. Server receives DHCP reserved IP address. Evrth works fine until i manually reboot the server. After that speed drops down significantly - from 100 mbits before - to 0.8 mbit per sec after. But when i do manually re-assign DHCP address (press 2nd option in the server) - evrth goes back to normal again..until the next reboot. What can be wrong?
I had been using Freenas 9.2 for 1 year before switched to Nas4free and never encountered this kinda issue.
Sorry, i must say i'm a complete noob wth FreeBSD. )

Re: Dlink-DIR 825 link speed issue

Posted: 17 Sep 2015 17:14
by b0ssman
please post the required information about your hardware.

Re: Dlink-DIR 825 link speed issue

Posted: 17 Sep 2015 18:19
by sene4kin
FreeBSD Revision: 199506
FreeBSD 10.2-RELEASE-p2 #0 r287260M: Fri Aug 28 18:37:35 CEST 2015
x86-embedded Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
ASUSTeK Computer INC. P5KPL-AM EPU
3gb RAM
ada0 WDC WD20EARX-008FB0 Western Digital Green 1907730MB
ada1 ST31000528AS Seagate Barracuda 7200.12 953870MB
Installed on USB 8 gb
Router D-link Dir-825 Hardware Version: B1 Firmware Version: 2.09WW

Re: Dlink-DIR 825 link speed issue

Posted: 17 Sep 2015 18:51
by b0ssman
well it could be a problem of your nic? realtek are known to be crap.

or the dir 825. you could try openwrt on it.

Re: Dlink-DIR 825 link speed issue

Posted: 18 Sep 2015 11:38
by sene4kin
Thx for the answer! I couldn't get multicast (IPTV) working properly on the openwrt(

Re: Dlink-DIR 825 link speed issue

Posted: 18 Sep 2015 22:01
by b0ssman
you could also get a proper gigabit switch. they are dirt cheap.
like a TP-Link TL-SG1005D