*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Problem with disk space usage

Software RAID information and help
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Ocean36
NewUser
NewUser
Posts: 1
Joined: 29 Nov 2016 11:17
Status: Offline

Problem with disk space usage

#1

Post by Ocean36 » 29 Nov 2016 11:55

Good afternoon everybody!

I recently installed NAS4free in order to be able to share some files with others.Below you can see my system information:

Version 10.3.0.3 - Pilingitam (revision 2942)
Compiled Sunday August 28 18:56:24 GMT+2 2016
Platform OS FreeBSD 10.3-RELEASE-p7 #0 r304958M: Sun Aug 28 20:17:06 CEST 2016
Platform x64-embedded on Intel(R) Celeron(R) CPU G1840 @ 2.80GHz
System Gigabyte Technology Co., Ltd. H81M-HD3
System bios American Megatrends Inc. version: FA 12/01/2014
System time Tuesday November 29 08:35:55 GMT+2 2016
System uptime 8 day(s) 1 hour(s) 16 minute(s) 31 second(s)
System last config change Tuesday November 29 07:33:51 GMT+2 2016
CPU temperature
°C
°C
CPU frequency
CPU usage
Memory usage
Swap usage
5% of 4GB
Device: /dev/ada2s2b | Total: 4G | Used: 220.72M | Free: 3.78G
Load averages [Show Process Information]
Disk space usage
SharedFiles
69% of 451GB
Total: 451G | Used: 287G | Free: 128G
UPS Status ups1

My problem it seems that I have 128GB free space but when I right click properties on the windows file explorer environment ,seems that this does not apply to the reality.In other words,the size in"properties" is what represent the 287G used but the real size on disk in "properties" is nearly 400G.Big difference!Yesterday some users complained that they were unable to save files,which surprised me knowing that my disk free space is 128G.
I deactivated the recycle bin(emptied it first) and then users were able to save,but noticed no change regarding the disk space.

I guess this is something regarding disk fragmentation and disk alocation units.

My question is if there is a setting(s) in Nas4free webGui that I should modify in order to be able to use this disk space and overcome this problem.

Thank a lot in advance

kenZ71
Advanced User
Advanced User
Posts: 403
Joined: 27 Jun 2012 20:18
Location: Northeast, USA
Status: Offline

Re: Problem with disk space usage

#2

Post by kenZ71 » 29 Nov 2016 14:29

Are you positive the disk is shared vs the usb boot disk?

Double check your mount settings and share setup
11.2-RELEASE-p3 | ZFS Mirror - 2 x 8TB WD Red | 28GB ECC Ram
HP ML10v2 x64-embedded on Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz

Extra memory so I can host a couple VMs
1) Unifi Controller on Ubuntu
2) Librenms on Ubuntu

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4924
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Problem with disk space usage

#3

Post by raulfg3 » 29 Nov 2016 18:50

same as kenZ71 says, revise your mount point and your shares.

eg: if your mount point is /mnt/myRaid you can't share /mnt/myRaid , you need to share /mnt/myRaid/Video or /mnt/myRaid/Mydata.

if you share /mnt/myRaid your free space is the free space on your boot disk , not in your data disk that is what you want.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

Post Reply

Return to “Software RAID”