Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

From FreeNAS 9 to XigmaNAS 12 update

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
hiroaking
NewUser
NewUser
Posts: 4
Joined: 02 Sep 2019 15:36
Status: Offline

From FreeNAS 9 to XigmaNAS 12 update

#1

Post by hiroaking » 02 Sep 2019 17:01

I want to use Old FreeNAS 9's ZFS Volume in XigmaNAS 12.

I used HP ProLiant MicroServer(2011), and it used USB boot NAS. The version was FreeNAS 9, use 4 HDDs for strage.
Lastday, USB boot drive broken. Cannot boot it. But unfortunately I lost the USB thumb drive backup.
So, I installed XigmaNAS 12.0.0.4.6766, and try to rebuild ZFS volume.

At first, I confirmed "Disks > ZFS > Pools > Information". But Pool Information & Status and ZFS Pool I/O Statistics were "no pools available" displayed.
Next, I confirmed Disks > Management > HDD Management, it was listed from ada0 to ada3, total 4 HDDs displayed.
The list displayed "Standby" are "always on", and "Status" are "ONLINE".
But from ada0 to ada3's "Filesystem" column are "Unknown or unformatted".

Please help me How to rebuild ZFS volume, without erase datas.
TQ.

User avatar
ms49434
Developer
Developer
Posts: 673
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: From FreeNAS 9 to XigmaNAS 12 update

#2

Post by ms49434 » 02 Sep 2019 17:03

hiroaking wrote:
02 Sep 2019 17:01
I want to use Old FreeNAS 9's ZFS Volume in XigmaNAS 12.

I used HP ProLiant MicroServer(2011), and it used USB boot NAS. The version was FreeNAS 9, use 4 HDDs for strage.
Lastday, USB boot drive broken. Cannot boot it. But unfortunately I lost the USB thumb drive backup.
So, I installed XigmaNAS 12.0.0.4.6766, and try to rebuild ZFS volume.

At first, I confirmed "Disks > ZFS > Pools > Information". But Pool Information & Status and ZFS Pool I/O Statistics were "no pools available" displayed.
Next, I confirmed Disks > Management > HDD Management, it was listed from ada0 to ada3, total 4 HDDs displayed.
The list displayed "Standby" are "always on", and "Status" are "ONLINE".
But from ada0 to ada3's "Filesystem" column are "Unknown or unformatted".

Please help me How to rebuild ZFS volume, without erase datas.
TQ.
Synchronizing the WebGUI when using ZFS is a two-step task:
a) Goto Disks > Management > HDD Management, check box "Clear configuration information before importing disks." and click import in the Import Disks section. (Importing software RAID disks is not necessary).
b) Goto Disks > ZFS > Configuration > Synchronize. Run synchronize with all 3 checkboxes checked.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

hiroaking
NewUser
NewUser
Posts: 4
Joined: 02 Sep 2019 15:36
Status: Offline

Re: From FreeNAS 9 to XigmaNAS 12 update

#3

Post by hiroaking » 03 Sep 2019 17:08

Thank you for your reply,
a) May be passed. From ada0 to ada3's FileSystem become "Unknown or unformatted" to "ZFS Storage Pool".
But I clicked Import button, displayed 2 alert messages.
<!>All disks are imported.
<!>The configuration has been changed.
You must apply the changes in order for them to take effect.
If this message persist take a look at the system log for more information.
So I clicked Applied Change button.
b) click Disks > ZFS > Configuration > Detected, but displayed alert,
<!>No pool was found. Try to import from on-disk ZFS config.
click Disks > ZFS > Configration >Synchronize, and 3 checkboses checked and click Synchronize, Displayed alert <!red>
Nothing to synchronize.

Please help me.
TQ.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4929
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: From FreeNAS 9 to XigmaNAS 12 update

#4

Post by raulfg3 » 04 Sep 2019 08:18

post a screenshot of

Disks > Management > HDD Management


and Disks > ZFS > Configuration
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

hiroaking
NewUser
NewUser
Posts: 4
Joined: 02 Sep 2019 15:36
Status: Offline

Re: From FreeNAS 9 to XigmaNAS 12 update

#5

Post by hiroaking » 04 Sep 2019 16:51

Thank you for your help.
I upload HDD management screen and ZFS>Configuration screen.
20190904234851_526a61585a.png
20190904234851_3034694874.png
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4929
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: From FreeNAS 9 to XigmaNAS 12 update

#6

Post by raulfg3 » 04 Sep 2019 19:44

push the button "import on-disk ZFS config"
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

hiroaking
NewUser
NewUser
Posts: 4
Joined: 02 Sep 2019 15:36
Status: Offline

Re: From FreeNAS 9 to XigmaNAS 12 update

#7

Post by hiroaking » 05 Sep 2019 14:45

Thank you for your great suppor!
I did it. last day, I push the button 'import on-disk ZFS config', nothing to answer.

Awesome, may be import complete.
Thank you!

Post Reply

Return to “ZFS (only!)”