*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Suddenly Lost All Data On ZFSPool - Help Please

Problems, solutions, software
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
checkbin
NewUser
NewUser
Posts: 6
Joined: 16 Jan 2017 20:26
Status: Offline

Suddenly Lost All Data On ZFSPool - Help Please

#1

Post by checkbin » 21 Jan 2017 23:07

I searched the forums but didn't see anything related to my issue. I have 3 ZPOOL RAID-z3 datasets, each with 11 3TB drives. Running Nas4Free version 9.3.0.2. Everything has been running great for several years, but I just I noticed I lost ALL my data on the 3rd dataset. The health of the pool is showing as fine but all the data just disappeared. I have the dataset also shared by SMB and I see the recycle bin is also gone now. I did not delete any data nor do anything to the pool or vdevs. All the drives show up still and the pool shows as healthy. I don't know how all of my nearly 25TB of data could be gone but it appears to be. Since I didn't delete any files and oddly the .recycle directory of the SMB share is even gone, I'm hoping something strange is going on and my data is really still there.

Does anyone have any ideas of what may have happened? Is there any hope of me recovering all my data? And no, foolish me I don't have snapshots enabled. (Though I do now). Thanks in advance for any thoughts or suggestions.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4923
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Suddenly Lost All Data On ZFSPool - Help Please

#2

Post by raulfg3 » 22 Jan 2017 07:25

please post the result of command: "zpool history" to see what happened with your pool, and more info (Read Forum rules).


and remember a raidZx is not a backup ( neverless the number of redundant disk).
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

checkbin
NewUser
NewUser
Posts: 6
Joined: 16 Jan 2017 20:26
Status: Offline

Re: Suddenly Lost All Data On ZFSPool - Help Please

#3

Post by checkbin » 22 Jan 2017 17:04

NAS4Free 9.3.0.2 (revision 1349) x64-embedded
SMCI SMCISLP2 Intel(R) Xeon(R) CPU L5420 @ 2.50GHz 17152MiB RAM

Intel 63XXESB USB 2.0 controller Intel 631XESB/632XESB/3100 USB
controller USB-1 Intel 631XESB/632XESB/3100 USB controller USB-2 Intel
63XXESB2 UDMA100 controller Intel 631XESB/632XESB/3100 USB controller
USB-3 bus=1 hubaddr=2 port=3 devaddr=2 interface=0
Subject:
Lost All Data On Thrid ZFS Pool
Description:
Suddenly lost all data on third ZFS Pool for no apparent reason. Did not delete
anything manually but all files and folders are now gone, including the .recycle
directory used by the CIFS/Samba share connected to Windows systems.

I have 11 3TB drives making up the raid-z3 pool.

nas4free status shows:
pool: VPOOL3
state: ONLINE
scan: scrub repaired 0 in 0h2m with 0 errors on Mon Jan 16 20:37:00 2017
config:

NAME STATE READ WRITE CKSUM
VPOOL3 ONLINE 0 0 0
raidz3-0 ONLINE 0 0 0
da0 ONLINE 0 0 0
da1 ONLINE 0 0 0
da2 ONLINE 0 0 0
da3 ONLINE 0 0 0
da4 ONLINE 0 0 0
da5 ONLINE 0 0 0
da6 ONLINE 0 0 0
da7 ONLINE 0 0 0
da8 ONLINE 0 0 0
da9 ONLINE 0 0 0
da10 ONLINE 0 0 0

ZFS history shows no activity that would cause the issue. Problem actually started prior to 01-16-2017.
zpool history
2015-01-30.21:34:13 zpool scrub VPOOL3
2015-04-04.13:30:20 zpool upgrade VPOOL3
2015-08-02.11:35:55 zpool clear VPOOL3
2015-08-03.20:10:39 zpool replace VPOOL3 16013241588135576150 /dev/da20
2015-08-05.19:10:41 zpool clear VPOOL3
2015-08-05.19:11:13 zpool clear VPOOL3
2015-08-07.22:33:07 zpool clear VPOOL3
2015-08-07.22:36:00 zpool clear VPOOL3 da20
2015-08-07.22:37:02 zpool clear VPOOL3 9772217997088037192
2015-08-07.22:57:36 zpool offline VPOOL3 9772217997088037192
2015-08-07.23:00:42 zpool online VPOOL3 /dev/da20
2015-08-08.09:43:08 zpool detach VPOOL3 9772217997088037192
2017-01-16.11:43:04 zpool export VPOOL3
2017-01-16.11:54:42 zpool import VPOOL3
2017-01-16.11:56:35 zpool export VPOOL3
2017-01-16.13:04:20 zpool import VPOOL3
2017-01-16.13:06:04 zpool export VPOOL3
2017-01-16.13:07:31 zpool import VPOOL3
2017-01-16.14:30:23 zpool export VPOOL3
2017-01-16.14:55:14 zpool import VPOOL3
2017-01-16.19:16:27 zpool reopen VPOOL3
2017-01-16.19:27:01 zfs set compression=lz4 VPOOL3/VDATASET3
2017-01-16.19:27:01 zfs set dedup=off VPOOL3/VDATASET3
2017-01-16.19:27:02 zfs set sync=standard VPOOL3/VDATASET3
2017-01-16.19:27:02 zfs set atime=off VPOOL3/VDATASET3
2017-01-16.19:27:03 zfs set canmount=on VPOOL3/VDATASET3
2017-01-16.19:27:03 zfs set readonly=off VPOOL3/VDATASET3
2017-01-16.19:27:03 zfs set reservation=none VPOOL3/VDATASET3
2017-01-16.19:27:04 zfs set quota=none VPOOL3/VDATASET3
2017-01-16.19:27:09 zfs set snapdir=visible VPOOL3/VDATASET3
2017-01-16.20:14:05 zpool scrub VPOOL3
2017-01-16.20:35:06 zpool scrub VPOOL3
2017-01-16.20:36:08 zfs set compression=lz4 VPOOL3/VDATASET3
2017-01-16.20:36:11 zfs set dedup=off VPOOL3/VDATASET3
2017-01-16.20:36:14 zfs set sync=standard VPOOL3/VDATASET3
2017-01-16.20:36:18 zfs set atime=off VPOOL3/VDATASET3
2017-01-16.20:36:21 zfs set canmount=on VPOOL3/VDATASET3
2017-01-16.20:36:24 zfs set readonly=off VPOOL3/VDATASET3
2017-01-16.20:36:27 zfs set reservation=none VPOOL3/VDATASET3
2017-01-16.20:36:31 zfs set quota=none VPOOL3/VDATASET3
2017-01-16.20:36:39 zfs set snapdir=visible VPOOL3/VDATASET3
2017-01-17.21:28:24 zpool export VPOOL3
2017-01-18.20:06:12 zpool import VPOOL3

Post Reply

Return to “Data recovery and backups”