*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

(Resolved)USB Drive broken, no backup config

Problems, solutions, software
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Gnarls
NewUser
NewUser
Posts: 2
Joined: 14 Sep 2017 22:26
Status: Offline

(Resolved)USB Drive broken, no backup config

#1

Post by Gnarls » 14 Sep 2017 22:34

Hello folks,


I'm new to this forum and I hope you can help me with my problem.

I'm running a NAS4FREE server (N54L) with 6 4TB HDD Drives in a RAID6 (or 5, have to check) ZFS pool.. Now, coming to my problem: I've no idea what happened, but after some weeks turned off, my USB Drive seems to be broken. Won't be recognized in any pc under any condition I tried in the last few days.. So that's gone unfortunately. To make things worse, I don't have a config file.

So, coming to my question: Is there any way to restore or reimport my ZFS pool in my new setup on my new USB stick?

In the webGUI I found the option to import a HDD as ZFS, but will it be automatically be able to recognize the correct ZFS pool setup?

Thanks for any help that is coming, you'd do me a big favor,


Gnarls

User avatar
ms49434
Developer
Developer
Posts: 720
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: USB Drive broken, no backup config

#2

Post by ms49434 » 14 Sep 2017 23:29

Step 1: Import hard drives via Disks > Management > HDD Management, check 'Clear configuration information before importing disks.'
Step 2: Import your ZFS pool via Disks > ZFS > Configuration > Synchronize
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Gnarls
NewUser
NewUser
Posts: 2
Joined: 14 Sep 2017 22:26
Status: Offline

Re: USB Drive broken, no backup config

#3

Post by Gnarls » 15 Sep 2017 18:59

Thank you so much for the quick reply! I was a bit scared of losing all my data, if I import the zfs pool in the wrong way. I managed to recover all my data after some time of troubleshooting. Thanks a lot! :)

Post Reply

Return to “Data recovery and backups”