*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Sudo 1.0?

Compile and development by yourself!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Sudo 1.0?

#1

Post by jasch » 23 Mar 2016 10:15

He
Today i am compiling a new version for me with my needed changes.(Maxio,Maxphys...)
There i see, that the script trys to build port sudo version 1(heartblead bug).
Version 1.8.16 is the actual one.
Is there a Reason for this, or just a typo in the script?

MfG Alex
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

User avatar
zoon01
Developer
Developer
Posts: 768
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

Re: Sudo 1.0?

#2

Post by zoon01 » 23 Mar 2016 11:25

you point now to nas4free port build system.

the sudo make file points into freebsd ports to sudo port

I see new sudo version in ports so coming new release n4f has than of course sudo-1.8.16 included.

https://svnweb.freebsd.org/ports/head/security/sudo/
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.84 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: Sudo 1.0?

#3

Post by jasch » 23 Mar 2016 11:57

Thx for the fast answer.

I just changed Version in script to 1.8.16 all working.
At the Moment i just change 2 things from stock compile.
In Kernelconf. i add
options MAXPHYS=(1024*1024)
and in mps driver change maxio from 256*1024 to MAXPHYS.
So i can use 1MB Blocksize for Bareos Tapebackups.
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

Post Reply

Return to “Development & Developers”