*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[SOLVED] UTF8 from script running in cron

XigmaNAS Scripts and shell tips
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
AmBeR
NewUser
NewUser
Posts: 4
Joined: 18 Jan 2017 10:56
Status: Offline

[SOLVED] UTF8 from script running in cron

#1

Post by AmBeR » 18 Dec 2017 09:44

Hi,

I have script which use lftp to make backup from one server to another.

My script running well when I run it from terminal. But when it run from cron, don't copy files with unicode characters. What should I add to add UTF8 support to cron?

Regards

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4918
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: UTF8 from script running in cron

#2

Post by raulfg3 » 18 Dec 2017 11:50

try to configure keyboard from shell menu , option 12?? <- Not totally sure what number is it.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

AmBeR
NewUser
NewUser
Posts: 4
Joined: 18 Jan 2017 10:56
Status: Offline

Re: UTF8 from script running in cron

#3

Post by AmBeR » 18 Dec 2017 13:10

Post to close.

I added this to script:

Code: Select all

LANG=en_US.UTF-8
export LANG
LANGUAGE=en_US.UTF-8
export LANGUAGE
LC_ALL=en_US.UTF-8
export LC_ALL
And now it works fine.

Post Reply

Return to “Scripts and shell tips”