*New 12.1 series Release:
2020-03-24: XigmaNAS 12.1.0.4.7389 - released

*New 11.3 series Release:
2020-03-24: XigmaNAS 11.3.0.4.7383 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[EXTENSION] OneButtonInstaller

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
User avatar
raulfg3
Site Admin
Site Admin
Posts: 4958
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#151

Post by raulfg3 »

please post ls -la /mnt/NASys/

to know owner and permission of /mnt/NASys/Ext dataset
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

IG33
NewUser
NewUser
Posts: 13
Joined: 01 Sep 2016 12:48
Location: Moscow, Russia
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#152

Post by IG33 »

raulfg3 wrote:
15 Feb 2020 13:20
please post ls -la /mnt/NASys/

Code: Select all

ignasv: ~# ls -la /mnt/NASys/
total 14
drwxrwxrwx  4 root  wheel     512 Feb 14 15:19 .
drwxr-xr-x  3 root  wheel     512 Feb 14 18:13 ..
drwxrwxr-x  2 root  operator  512 Feb 14 18:00 .snap
drwxrwxrwx  3 root  wheel     512 Feb 14 15:19 Ext

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4958
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#153

Post by raulfg3 »

all is good.

Sorry no more ideas what it's wrong.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

IG33
NewUser
NewUser
Posts: 13
Joined: 01 Sep 2016 12:48
Location: Moscow, Russia
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#154

Post by IG33 »

raulfg3 wrote:
15 Feb 2020 17:50
no more ideas what it's wrong.
It is possible that the reasons are in the network settings in the place where the NAS is installed. I will talk to the network administrator and write if something clears up.

IG33
NewUser
NewUser
Posts: 13
Joined: 01 Sep 2016 12:48
Location: Moscow, Russia
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#155

Post by IG33 »

IG33 wrote:
14 Feb 2020 22:22
Help me, please.
...
As it turned out, the problem is related to the settings of the access restriction system in our company. Administrators are trying to figure out the problem, but I have so far bypassed it by temporarily connecting the NAS to the Internet via another provider (mobile 4G).

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#156

Post by TJF »

I have the same problem like IG33:

$ ls -la /mnt/extensions/
total 8
drwxrwxr-x 2 root wheel 512 Mar 2 14:56 .
drwxr-xr-x 4 root wheel 512 Mar 2 14:56 ..

No access restriction system at home!
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4958
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#157

Post by raulfg3 »

TJF wrote:
02 Mar 2020 14:59
I have the same problem like IG33:

$ ls -la /mnt/extensions/
total 8
drwxrwxr-x 2 root wheel 512 Mar 2 14:56 .
drwxr-xr-x 4 root wheel 512 Mar 2 14:56 ..

No access restriction system at home!
but you bon't have a folder for extension like IG33 only . and ..

please read topic from the ini, and post your steps and the output of the shell to see what appends.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#158

Post by TJF »

After installing OBI everything seems to be ok. After restart of the NAS it is totally gone.


/mnt/DATA/extensions

$ ls -la /mnt/DATA/
total 12
drwxrwxr-x 3 root wheel 512 Mar 2 18:25 .
drwxr-xr-x 4 root wheel 512 Mar 2 18:25 ..
drwxrwxr-x 3 root wheel 512 Mar 2 18:26 extensions

$ ls -la /mnt/DATA/extensions
total 12
drwxrwxr-x 3 root wheel 512 Mar 2 18:26 .
drwxrwxr-x 3 root wheel 512 Mar 2 18:25 ..
drwxrwxr-x 5 root wheel 512 Mar 2 18:37 onebuttoninstaller


$ fetch https://raw.github.com/crestAT/nas4free ... er/OBI.php && mkdir -p ext/OBI && echo '<a href="OBI.php">OneButtonInstaller</a>' > ext/OBI/menu.inc && echo -e "\nDONE"

DONE


$ ping -t 4 github.com
PING github.com (140.82.118.4): 56 data bytes
64 bytes from 140.82.118.4: icmp_seq=0 ttl=58 time=48.453 ms
64 bytes from 140.82.118.4: icmp_seq=1 ttl=58 time=47.443 ms
64 bytes from 140.82.118.4: icmp_seq=2 ttl=58 time=47.444 ms
64 bytes from 140.82.118.4: icmp_seq=3 ttl=58 time=46.960 ms

--- github.com ping statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 46.960/47.575/48.453/0.544 ms


$ fetch https://github.com/crestAT/nas4free-one ... -v0402.zip
-> nothing happens
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#159

Post by TJF »

Before restart this (attachment) happens, when I try to install Plex Media Server.
You do not have the required permissions to view the files attached to this post.
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1043
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#160

Post by JoseMR »

TJF wrote:
02 Mar 2020 19:48
Before restart this (attachment) happens, when I try to install Plex Media Server.

This error may be related due a FreeBSD issue in they PKG causing mismatch ABI errors

"There's a known issue with the official FreeBSD package builders (which use ports-mgmt/pkg-devel) causing mismatched ABI error messages for package users. Pull request addressing the issue has been submitted..."

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#161

Post by TJF »

Thank you JoseMR!

Nobody any idea, why after restart of the NAS OBI is totally gone?
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1043
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#162

Post by JoseMR »

TJF wrote:
04 Mar 2020 06:19
Thank you JoseMR!

Nobody any idea, why after restart of the NAS OBI is totally gone?
Most likely you are running an XN Embedded installation don't installed the OBI Extension in a persistent data location i.e. your ZFS pool, or have an issue with the PostInit command.

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#163

Post by TJF »

I have installed it according to the recommendation ( viewtopic.php?f=71&t=11184#p69861 ):
/mnt/DATA/extensions
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4958
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#164

Post by raulfg3 »

TJF wrote:
05 Mar 2020 08:51
I have installed it according to the recommendation ( viewtopic.php?f=71&t=11184#p69861 ):
/mnt/DATA/extensions
/mnt/DATA ia a dataset ?,

please post where point /mnt/DATA and try to copy something to it and see if survie a reboot.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#165

Post by TJF »

No, DATA is not a dataset! I did not put it into a dataset. May be - like JoseMR said - that is the point. I will try...
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#166

Post by TJF »

Now, that was the problem. My dataset is named "pool1". Now I installed OBI in /mnt/pool1/DATA/extensions/ and OBI works - even after restart. But I went one step too much, too deep...

After installing Plex the same error like in #410, but there is a folder with Plex-Files. S. Attachment.
You do not have the required permissions to view the files attached to this post.
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#167

Post by TJF »

Meanwhile I could install Plex. It is working again -> #410
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1043
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#168

Post by JoseMR »

TJF wrote:
11 Mar 2020 15:58
Meanwhile I could install Plex. It is working again -> #410

Hi, latest Plex Media Server Extension now allow the user to initially install from official Plex Tarballs for convenience, so in case you have further problems with FreeBSD repositories with either Plex pkg version being too old or ABI/connection errors, just upload a latest Plex Tarball and that's it.

More on this in this small Plex Tarball Install/Upgrade How-To

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#169

Post by TJF »

Yes. Thank you! I've updated to the latest extension v. 4.3.015 and after that I downloaded and installed the FreeBSD-Version PlexMediaServer-1.18.7.2457-77cb9455c-FreeBSD-amd64.tar.bz2 from the Plex-Website. Installation over the extension (maintenance). Everything seems to work fine.
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

Post Reply

Return to “Extensions / Add-ons”