*New 12.1 series Release:
2020-04-05: XigmaNAS 12.1.0.4.7509 - released

*New 11.3 series Release:
2020-04-05: XigmaNAS 11.3.0.4.7509 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Plex pkg upgrade issue

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
pierouelle
Starter
Starter
Posts: 60
Joined: 24 Jun 2012 04:02
Location: Québec, Canada
Status: Offline

Plex pkg upgrade issue

#1

Post by pierouelle »

Hi everyone,
i have an issue with plex pkg upgrade this is my error : Shared object "libcrypto.so.8" not found, required by "libarchive.so.6"
i am running plex in a jail from the brig for years and it used to run and upgrade easily.
i am running latest version of nas4free and the brig.
Is there something i can do like a reinstall (overwrite), or di i need to start from scratch.
thanks everyone for your help, have a great day

danzi
Starter
Starter
Posts: 66
Joined: 11 Nov 2012 23:24
Location: Budapest
Status: Offline

Re: Plex pkg upgrade issue

#2

Post by danzi »

Mine simply won't upgrade to the latest one.

Updating FreeBSD repository catalogue...
Fetching meta.txz: . done
Fetching packagesite.txz: .......... done
Processing entries: .......... done
FreeBSD repository update completed. 26873 packages processed.
All repositories are up to date.
Checking integrity... done (0 conflicting)
Your packages are up to date.
Looking for new Plex Extension package!
No new Plex Extension package available!


On the server's page:
Version 1.7.5.4035 An update is available. Please install manually.

On the main Plex page:
A Plex Media Server update is available for the server <srv name>! 1.8.3.4235 Download now Skip this version
----------------------------------------------
Dell T130 - 32Gb ECC - ESXi 6.7
VM Full Instal - 11.2.0.4 - Omnius (revision 6005)
HP/LSI 9121-4i SAS2008 Pass Through mode
2 x 2Tb ZFS mirror
1 x 3Tb UFS
----------------------------------------------

danzi
Starter
Starter
Posts: 66
Joined: 11 Nov 2012 23:24
Location: Budapest
Status: Offline

Re: Plex pkg upgrade issue

#3

Post by danzi »

although plex IS available according to pkg. But I don't want to mess around manually...

#pkg search plexmediaserver
plexmediaserver-1.8.1.4139 Plex Media Server component
plexmediaserver-plexpass-1.8.2.4209 Plex Media Server component
----------------------------------------------
Dell T130 - 32Gb ECC - ESXi 6.7
VM Full Instal - 11.2.0.4 - Omnius (revision 6005)
HP/LSI 9121-4i SAS2008 Pass Through mode
2 x 2Tb ZFS mirror
1 x 3Tb UFS
----------------------------------------------

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4968
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Plex pkg upgrade issue

#4

Post by raulfg3 »

please clarify if you install plex using OBI, if not my recomendation is that delete/purge your actual install and do a new one using OBI (your media files are safe).
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

User avatar
Veloce
NewUser
NewUser
Posts: 5
Joined: 20 Nov 2013 15:13
Location: Netherlands
Status: Offline

Re: Plex pkg upgrade issue

#5

Post by Veloce »

Although I'm no longer using the brig but OBI these days, back then I wondered why upgrading PMS did not fetch me the latest version Plex offered on their site. (tried to make it as elaborate as possible for other N4F users)

Since your version is upgraded time after time, my guess is the local repository is updated from the quarterly not the latest ports version at BSD.
check the following config where you update your local repository from:

cd /etc/pkg
vi FreeBSD.conf


[Contents of FreBSD.conf]

FreeBSD: {
url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly", <<-- this is what it might read
url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest", <<-- change to "latest"

save (esc wq)

Make sure the Plex is stopped inside the jail:
jexec -u root Plex

service plexmediaserver stop
Stopping plexmediaserve
....
...

And run the update of again (from an old scratch file I had from the time I ran it in a jail, ignore the versions here):

root@Plex:/ # pkg update
Updating FreeBSD repository catalogue...
Repository FreeBSD has a wrong packagesite, need to re-create database
[Plex.local] Fetching meta.txz: 100% 944 B 0.9kB/s 00:01
[Plex.local] Fetching packagesite.txz: 100% 6 MiB 5.8MB/s 00:01
Processing entries: 100%
FreeBSD repository update completed. 25540 packages processed.

root@Plex:/ # pkg install plexmediaserver
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
New version of pkg detected; it needs to be installed first.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
pkg: 1.8.8 -> 1.9.3

Number of packages to be upgraded: 1

2 MiB to be downloaded.

Proceed with this action? [y/N]: y

[Plex.local] Fetching pkg-1.9.3.txz: 100% 2 MiB 2.6MB/s 00:01
Checking integrity... done (0 conflicting)
[Plex.local] [1/1] Upgrading pkg from 1.8.8 to 1.9.3...
[Plex.local] [1/1] Extracting pkg-1.9.3: 100%
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
The following 1 package(s) will be affected (of 0 checked):

Proceed with this action? [y/N]: y
[Plex.local] Fetching pkg-1.9.4.txz: 100% 2 MiB 2.5MB/s 00:01
Checking integrity... done (0 conflicting)
[Plex.local] [1/1] Upgrading pkg from 1.9.3 to 1.9.4...
[Plex.local] [1/1] Extracting pkg-1.9.4: 100%
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
plexmediaserver: 1.2.7.2987 -> 1.3.3.3148

Number of packages to be upgraded: 1

The operation will free 8 MiB.
63 MiB to be downloaded.

Proceed with this action? [y/N]: y
[Plex.local] Fetching plexmediaserver-1.3.3.3148.txz: 100% 63 MiB 4.7MB/s 00:14
Checking integrity... done (0 conflicting)
[Plex.local] [1/1] Upgrading plexmediaserver from 1.2.7.2987 to 1.3.3.3148...
===> Creating groups.
Using existing group 'plex'.
===> Creating users
Using existing user 'plex'.
[Plex.local] [1/1] Extracting plexmediaserver-1.3.3.3148: 100%
Message from plexmediaserver-1.3.3.3148:
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

multimedia/plexmediaserver includes an RC script:
/usr/local/etc/rc.d/plexmediaserver

TO START PLEXMEDIASERVER ON BOOT:
sysrc plexmediaserver_enable=YES

START MANUALLY:
service plexmediaserver start

Once started, visit the following to configure:
http://localhost:32400/web

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

root@Plex:/ # service plexmediaserver start (start Plex again)
Starting plexmediaserver.
11.1.0.4 - Atomics (revision 5313) + OBI (Full version)
Lian Li PC-Q25B
x64-full on AMD A10-5745M APU(8Gb RAM)
HP Apacer 16GB (Boot)
5*3TB WD-RED

Post Reply

Return to “Extensions / Add-ons”