*New 12.1 series Release:
2020-04-05: XigmaNAS 12.1.0.4.7509 - released

*New 11.3 series Release:
2020-04-05: XigmaNAS 11.3.0.4.7509 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Plex via OBI

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
numbskull
NewUser
NewUser
Posts: 6
Joined: 11 Nov 2017 15:43
Status: Offline

Plex via OBI

#1

Post by numbskull »

Hi,

I am trying to install the Plex extension using the OBI interface. When I do this I get an error message:

Installation error: Plex Media Server
Updating FreeBSD repository catalogue...
Fetching meta.txz: . done
Fetching packagesite.txz: .......... done
Processing entries: ........
Processing entries... done
Unable to update repository FreeBSD
Error updating repositories!

Looking in the logs, I have the following entries:

Nov 11 14:46:08 nas4free kernel: pid 8901 (pkg), uid 0 inumber 229 on /: filesystem full
Nov 11 14:46:08 nas4free root: plexinit: an error has occurred during initialize
Nov 11 14:45:50 nas4free root: /mnt/Extensions/onebuttoninstaller/extensions.txt 0 B 0 Bps

Please appreciate that I know NOTHING about Linux (over-emphasis intended), I've simply managed to get NAS4Free working through trial and error. I use it just as a file server for Kodi (on an nVidia Shield), but would like to try Plex as it is supported by the Xbox One. The only service currently running is SMB, and the N4F version I'm running is 11.1.0.4 (4812).

Thanks

User avatar
lindsay
Forum Moderator
Forum Moderator
Posts: 294
Joined: 23 Jun 2012 09:59
Location: Steinkjer,Norway
Status: Offline

Re: Plex via OBI

#2

Post by lindsay »

Nov 11 14:46:08 nas4free kernel: pid 8901 (pkg), uid 0 inumber 229 on /: filesystem full says it all you have not enough space to install ,you have not mounted the data partition as i guess you have installed embedded?
I say data but you can call the partition with what ever you want
Protected by smoothiebox Red,Green,
Purple,Orange Zones/VLAN`s
Powered by AMD A10-6700T


XigmaNAS Box-1 11.2.0.4 - Omnius (revision 6625)
Platform : x64-embedded on 2X Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz
Motherboard: ASUS Z10PA-D8, 2xSocket-2011-3
SATA Controllers : 1X Avago Technologies (LSI) SAS2008 and 1x Avago Technologies (LSI) SAS2308
Pool 1 (Media-Pool) 8X4TB in raidz2
Pool 2 (Media-Pool-2) 4X2TB in raidz2 and 2X2TB in mirror mirror and 2X3TB in mirror
Pool 3 (Media-Pool-3) 2X2TB in mirror and 2X4TB in mirror and 2X1TB in mirror

numbskull
NewUser
NewUser
Posts: 6
Joined: 11 Nov 2017 15:43
Status: Offline

Re: Plex via OBI

#3

Post by numbskull »

Thanks for the reply. I got it working by putting the directory in one of the four media drives in the server. What I wanted to do was install it on the 'main' drive where N4F is installed which is a 120GB SSD.

After that, I got Plex to start but then it would stop after a few seconds with 'exit on signal 6' in the log. I then tried to install the Plex Pass Media Server - and it now shows under OBI that I have both installed (I thought it was one or the other). But strangely it's now working without error...

User avatar
lindsay
Forum Moderator
Forum Moderator
Posts: 294
Joined: 23 Jun 2012 09:59
Location: Steinkjer,Norway
Status: Offline

Re: Plex via OBI

#4

Post by lindsay »

OK open putty and paste output of df -h ?
There we can see if you have mounted right on the 120GB SSD

https://www.nas4free.org/wiki/faq/0055
Protected by smoothiebox Red,Green,
Purple,Orange Zones/VLAN`s
Powered by AMD A10-6700T


XigmaNAS Box-1 11.2.0.4 - Omnius (revision 6625)
Platform : x64-embedded on 2X Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz
Motherboard: ASUS Z10PA-D8, 2xSocket-2011-3
SATA Controllers : 1X Avago Technologies (LSI) SAS2008 and 1x Avago Technologies (LSI) SAS2308
Pool 1 (Media-Pool) 8X4TB in raidz2
Pool 2 (Media-Pool-2) 4X2TB in raidz2 and 2X2TB in mirror mirror and 2X3TB in mirror
Pool 3 (Media-Pool-3) 2X2TB in mirror and 2X4TB in mirror and 2X1TB in mirror

numbskull
NewUser
NewUser
Posts: 6
Joined: 11 Nov 2017 15:43
Status: Offline

Re: Plex via OBI

#5

Post by numbskull »

I know I haven't installed it on the main drive because I don't know how to mount a directory on it (which is what I need to do)? Assume here that when I say mount, I mean make it available for the user to interact with?

As requested:

Filesystem Size Used Avail Capacity Mounted on
/dev/md0 120M 90M 30M 75% /
devfs 1.0K 1.0K 0B 100% /dev
/dev/md1 719M 577M 142M 80% /usr/local
procfs 4.0K 4.0K 0B 100% /proc
/dev/ufsid/542eb11e2c15c171 1.8T 1.5T 81G 95% /mnt/Red_Vol1
/dev/ufsid/542fcc1c353479ce 1.3T 986G 259G 79% /mnt/Sam_1500_3
/dev/ufsid/542ff6906599cf5f 1.8T 1.5T 89G 95% /mnt/WD_2000_2
/dev/ufsid/549ec9073998b632 902G 662G 168G 80% /mnt/WD_1000_4
/dev/md2 496M 5.1M 481M 1% /var
tmpfs 256M 80K 256M 0% /var/tmp
tmpfs 320M 4.0K 320M 0% /var/tmp/ftmp
/dev/ada4s1a 743M 237M 507M 32% /cf

The names Sam and WD simply refer to Samsung and Western Digital drives so that I can see which physical disk N4F is referring to when I open the computer :oops:

numbskull
NewUser
NewUser
Posts: 6
Joined: 11 Nov 2017 15:43
Status: Offline

Re: Plex via OBI

#6

Post by numbskull »

Sorry, I tried to format the dump above but it didn't follow in the forum post.

I tried the instructions to mount the data portion and first got:

Can't mount the system partition 1, the DATA partition is the 2.

Then changed the partition to 2 (my fault) and got:

/dev/ada4s2: Can't get UFS ID.
dumpfs: /dev/ada4s2: could not read superblock to fill out disk


I know that the filesystem is UFS.

User avatar
ms49434
Developer
Developer
Posts: 834
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Plex via OBI

#7

Post by ms49434 »

now show us the output of

Code: Select all

gpart show ada4
This command is used to identify all partitions of your boot device.
Usually the bootable device starts with a small partition for boot, followed by the root partition (OS).
The swap and the data partition are not mandatory:

Code: Select all

nas4free: ~# gpart show ada4
=>     40  8388528  ada4  GPT  (4.0G)
       40     1024     1  freebsd-boot  (512K)
     1064     7128        - free -  (3.5M)
     8192  2097152     2  freebsd-ufs  (1.0G)
  2105344  2097152     3  freebsd-swap  (1.0G)
  4202496  4177920     4  freebsd-ufs  (2.0G)
  8380416     8152        - free -  (4.0M)
in the above scenario partition #4 contains the data partition.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

numbskull
NewUser
NewUser
Posts: 6
Joined: 11 Nov 2017 15:43
Status: Offline

Re: Plex via OBI

#8

Post by numbskull »

Code: Select all

=>       63  234441585  ada4  MBR  (112G)
         63    1654632     1  freebsd  [active]  (808M)
    1654695    8401995     2  freebsd  (4.0G)
   10056690  224379855     3  freebsd  (107G)
  234436545       5103        - free -  (2.5M)

User avatar
ms49434
Developer
Developer
Posts: 834
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Plex via OBI

#9

Post by ms49434 »

It looks like partition 3 is your data partition and partition 2 is your swap partition.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

numbskull
NewUser
NewUser
Posts: 6
Joined: 11 Nov 2017 15:43
Status: Offline

Re: Plex via OBI

#10

Post by numbskull »

Sorry for the delay in replying. All sorted, and reinstalling PMS into the new 'data' location stopped it crashing.

Thanks again!

Post Reply

Return to “Extensions / Add-ons”