*New 12.1 series Release:
2020-04-05: XigmaNAS 12.1.0.4.7509 - released

*New 11.3 series Release:
2020-04-05: XigmaNAS 11.3.0.4.7509 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Resolved) Subsonic in jail(thebrig) does not start on Nas4free reboot.

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
mrjacobrussell
Starter
Starter
Posts: 62
Joined: 05 Jun 2015 17:57
Status: Offline

Resolved) Subsonic in jail(thebrig) does not start on Nas4free reboot.

#1

Post by mrjacobrussell »

As the topic states I am having an issue with subsonic starting on reboot.
I am using the newest version of thebrig and Nas4Free 11.1.0.4 - Atomics (revision 4994)

If I stop and restart the jail from the brig tab Subsonic does start though.

I have the startup script sh /var/subsonic/standalone/subsonic.sh for after jail start I have tried all of the nice levels. 0-5

I am not sure where to check for what is preventing it from loading correctly. I never had this issue until I did a clean install to upgrade to nas4free 11.1

Any help would be greatly appreciated!
Last edited by mrjacobrussell on 21 Aug 2018 20:16, edited 1 time in total.
11.2.0.4 - Omnius (revision 6766)
x64-embedded on Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz 16gb ram 15.4Tb pool storage

User avatar
mrjacobrussell
Starter
Starter
Posts: 62
Joined: 05 Jun 2015 17:57
Status: Offline

Re: Subsonic in jail(thebrig) does not start on Nas4free reboot.

#2

Post by mrjacobrussell »

I have tried this command as /var/subsonic/standalone/subsonic.sh
and
"sh /var/subsonic/standalone/subsonic.sh"

neither load with system boot but both work when I restart the jail after the initial failure to load..

I'm wondering could the script loading need to be delayed?
11.2.0.4 - Omnius (revision 6766)
x64-embedded on Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz 16gb ram 15.4Tb pool storage

User avatar
mrjacobrussell
Starter
Starter
Posts: 62
Joined: 05 Jun 2015 17:57
Status: Offline

Re: Subsonic in jail(thebrig) does not start on Nas4free reboot.

#3

Post by mrjacobrussell »

Resolved.

The jail is set to auto start.

then I created a command script tab (not the jail config)

System > Advanced > Command Scripts>

"jexec (jailname) /var/subsonic/standalone/subsonic.sh "

"PostInit"
11.2.0.4 - Omnius (revision 6766)
x64-embedded on Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz 16gb ram 15.4Tb pool storage

Post Reply

Return to “Extensions / Add-ons”