*New 12.1 series Release:
2020-04-05: XigmaNAS 12.1.0.4.7509 - released

*New 11.3 series Release:
2020-04-05: XigmaNAS 11.3.0.4.7509 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

USB automount (Extended GUI enabled) won't mount anything

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
paulj
Starter
Starter
Posts: 22
Joined: 12 Mar 2015 01:48
Status: Offline

USB automount (Extended GUI enabled) won't mount anything

#1

Post by paulj »

I've enabled USB automount via the Extended GUI

The buttons are present on the systems page. The mount button doesn't mount the drive (formatted Fat32 or msdosfs)

The log reports an error:
rm: /mnt/*.automount*: No such file or directory
The hardware is recognized by the system (seen in the logs)

What's wrong?

Addendum:

I was able to mount the drive by adding a mount point via command line and manually mounting:

Code: Select all

mount_msdosfs -o large /dev/da0p2 /mnt/usb-hdd
Xigmanas 11.2.0.4 - Omnius (revision 6315)
Supermicro A1SRi x64-full on Intel(R) Atom(TM) CPU C2758 @ 2.40GHz 16GB ECC memory
ZFS on Root Install

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 529
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: USB automount (Extended GUI enabled) won't mount anything

#2

Post by crest »

Hello paulj,
paulj wrote:
23 Mar 2018 16:13
I've enabled USB automount via the Extended GUI

The buttons are present on the systems page. The mount button doesn't mount the drive (formatted Fat32 or msdosfs)

The log reports an error:
rm: /mnt/*.automount*: No such file or directory
The hardware is recognized by the system (seen in the logs)

What's wrong?

Addendum:

I was able to mount the drive by adding a mount point via command line and manually mounting:

Code: Select all

mount_msdosfs -o large /dev/da0p2 /mnt/usb-hdd
OK, finally I recognized this post and there is a workaround for your issue directly within the eGUI thread, please refere to this => https://www.nas4free.org/forums/viewtop ... 469#p84469

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Post Reply

Return to “Extensions / Add-ons”