*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

installed CUPS disappeared after reboot

XigmaNAS Packages
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
drnicolas
Advanced User
Advanced User
Posts: 182
Joined: 15 Aug 2013 14:03
Location: Wiesbaden, Germany
Status: Offline

installed CUPS disappeared after reboot

#1

Post by drnicolas » 26 Dec 2016 15:03

I am trying to install CUPS on my NAS4FREE machine.

This seems to be more complicated than expected.
I found several postings with lists of packets to install.

- One of the packets (py27-cups) cannot be found and installed.
- INstalling CUPS itself went fine, but the installed software has disappeared after reboot.

I think this is caused by my EMBEDDED install.
Therefore I tried to find a persistent solution with the unionfs method.
But the scripts to mount the unionfs at reboot also seem to fail.

The directories were created at the /mnt/vStorage, Is this correct? The created directories are there even after reboot but do not contain any useful data.
In addition, I get error messages that the file-system /usr/local is full when trying to install all packages.

Can someone help ?
HP Proliant N54L - Bios Mod -16GB non-ECC-RAM - ZFS RAIDZ1 (3x3TB) - 1VM running XigmaNAS 11.2.0.4.6026

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4921
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: installed CUPS disappeared after reboot

#2

Post by raulfg3 » 27 Dec 2016 17:14

Save your actual config.
Do a New install. This time do a full install.
Restore your config.

Now you are ready to install packages in a persistent Way.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

drnicolas
Advanced User
Advanced User
Posts: 182
Joined: 15 Aug 2013 14:03
Location: Wiesbaden, Germany
Status: Offline

Re: installed CUPS disappeared after reboot

#3

Post by drnicolas » 27 Dec 2016 20:45

Okay, understand
Can I use my USB-Stick to install NAS4Free on? I do not have a HDD available
HP Proliant N54L - Bios Mod -16GB non-ECC-RAM - ZFS RAIDZ1 (3x3TB) - 1VM running XigmaNAS 11.2.0.4.6026

User avatar
MikeMac
Forum Moderator
Forum Moderator
Posts: 498
Joined: 07 Oct 2012 23:12
Location: Moscow, Russia
Contact:
Status: Offline

Re: installed CUPS disappeared after reboot

#4

Post by MikeMac » 27 Dec 2016 21:47

drnicolas wrote:Can I use my USB-Stick to install NAS4Free on?
You can. The other question is for how long your USB stick will survive... Depending of one's quality - from a few weeks to a few months, I suppose.
This is more then enought for testing, but not suitable for normal usage. But during this time you could find HDD and (or?) try to understand how to resolve your task.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4921
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: installed CUPS disappeared after reboot

#5

Post by raulfg3 » 27 Dec 2016 22:06

+1

Use an HD/SSD Is really recommended for a full install, but use a good USB Is aceptable for testing time.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

Post Reply

Return to “Packages”